aboutsummaryrefslogtreecommitdiff
path: root/mail/dcc-dccd
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-07 15:20:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-07 15:20:26 +0000
commitaeb514f96f04a9fb84291873df2f06d2441ab9d8 (patch)
tree577ebae47d57dbab0e85c1f223d08f6eac8384e3 /mail/dcc-dccd
parent6e75038caa52d9f343f82926bf03b1c3b204d2a7 (diff)
downloadports-aeb514f96f04a9fb84291873df2f06d2441ab9d8.tar.gz
ports-aeb514f96f04a9fb84291873df2f06d2441ab9d8.zip
- Update to 1.3.50
PR: 109039 Submitted by: Dean Hollister <dean@odyssey.apana.org.au> (maintainer)
Notes
Notes: svn path=/head/; revision=186815
Diffstat (limited to 'mail/dcc-dccd')
-rw-r--r--mail/dcc-dccd/Makefile10
-rw-r--r--mail/dcc-dccd/distinfo6
-rw-r--r--mail/dcc-dccd/files/dcc-start.sh.in57
-rw-r--r--mail/dcc-dccd/files/patch-homedir::Makefile.in66
-rw-r--r--mail/dcc-dccd/pkg-plist7
5 files changed, 98 insertions, 48 deletions
diff --git a/mail/dcc-dccd/Makefile b/mail/dcc-dccd/Makefile
index b973fac3717a..ffd8ffdb17f8 100644
--- a/mail/dcc-dccd/Makefile
+++ b/mail/dcc-dccd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dcc-dccd
-PORTVERSION= 1.3.42
+PORTVERSION= 1.3.50
CATEGORIES= mail
MASTER_SITES= http://www.rhyolite.com/anti-spam/dcc/source/ \
http://www.wa.apana.org.au/~dean/sources/
@@ -23,6 +23,8 @@ MAN8= cdcc.8 dbclean.8 dblist.8 dcc.8 dccd.8 dccifd.8 dccm.8 \
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+USE_RC_SUBR= dcc-start.sh
+
#
# User for dcc files and SUID binaries
#
@@ -106,10 +108,4 @@ pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PREFIX} PRE-INSTALL
-post-install:
-.if !exists(${PREFIX}/dcc/map)
- ${CP} ${PREFIX}/dcc/map ${PREFIX}/dcc/map.dist
- @${CHOWN} ${DCCUSER} ${PREFIX}/dcc/map.dist
-.endif
-
.include <bsd.port.post.mk>
diff --git a/mail/dcc-dccd/distinfo b/mail/dcc-dccd/distinfo
index dbc0b09f2955..11741c2c8875 100644
--- a/mail/dcc-dccd/distinfo
+++ b/mail/dcc-dccd/distinfo
@@ -1,3 +1,3 @@
-MD5 (dcc-dccd-1.3.42.tar.Z) = 47d023c6d96f0f8fa7910425b1e76459
-SHA256 (dcc-dccd-1.3.42.tar.Z) = 2544815d2fab2c913f3d8ca8bf1fe8ec247c50837a138998d86f708cf696a20b
-SIZE (dcc-dccd-1.3.42.tar.Z) = 1424267
+MD5 (dcc-dccd-1.3.50.tar.Z) = 4306df4a05d04f926995ddc0c1d480e1
+SHA256 (dcc-dccd-1.3.50.tar.Z) = 942c9be56f3ff765b524e6c49d85dd84aa4a22c1514afe096d34e246cbf6cc21
+SIZE (dcc-dccd-1.3.50.tar.Z) = 1448485
diff --git a/mail/dcc-dccd/files/dcc-start.sh.in b/mail/dcc-dccd/files/dcc-start.sh.in
new file mode 100644
index 000000000000..b20aaac078a6
--- /dev/null
+++ b/mail/dcc-dccd/files/dcc-start.sh.in
@@ -0,0 +1,57 @@
+#!/bin/sh
+#
+# PROVIDE: dccifd
+# REQUIRE: LOGIN
+# BEFORE: mail
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable dccifd:
+#
+#dccifd_enable="YES"
+#
+# See dccifd(8) for flags
+#
+
+. %%RC_SUBR%%
+
+name=dccifd
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+# Set defaults
+: ${dccifd_enable:="NO"}
+: ${dccifd_flags=""}
+: ${dccifd_home="%%PREFIX%%/dcc"}
+: ${dccifd_conf="$dccifd_home/dcc_conf"}
+
+
+pidfile=${dccifd_pidfile:-"/var/run/dccifd.pid"}
+command="${dccifd_home}/libexec/start-dccifd"
+procname="${dccifd_home}/libexec/dccifd"
+required_dirs="$dccifd_home"
+required_files="${dccifd_conf}"
+
+stop_postcmd="stop_postcmd"
+start_precmd="start_precmd"
+
+
+stop_postcmd()
+{
+ rm -f $pidfile
+}
+
+start_precmd()
+{
+X=`grep DCCIFD_ENABLE ${dccifd_conf}`
+eval $X
+if [ "$DCCIFD_ENABLE" != "on" ]
+then
+ echo "Warning ${X} needs to be on in ${dccifd_conf}"
+ return 1
+fi
+}
+
+run_rc_command "$1"
+
diff --git a/mail/dcc-dccd/files/patch-homedir::Makefile.in b/mail/dcc-dccd/files/patch-homedir::Makefile.in
index 86224591e1e9..e10c4a51f0f8 100644
--- a/mail/dcc-dccd/files/patch-homedir::Makefile.in
+++ b/mail/dcc-dccd/files/patch-homedir::Makefile.in
@@ -1,37 +1,33 @@
---- homedir/Makefile.in.orig Thu Sep 8 09:57:07 2005
-+++ homedir/Makefile.in Wed Mar 1 07:39:11 2006
-@@ -51,15 +51,11 @@
- $(HINSTALL) -m 755 -d $(INST_HOMEDIR); fi
- if test ! -d $(INST_HOMEDIR)/log; then \
- $(HINSTALL) -m 710 -d $(INST_HOMEDIR)/log; fi
-- if test -s $(INST_HOMEDIR)/dcc_conf; then \
-- sh make-dcc_conf -h $(INST_HOMEDIR); \
-- else \
-- $(HINSTALL) -m 644 dcc_conf $(INST_HOMEDIR)/dcc_conf; \
+--- homedir/Makefile.in.orig Sun Feb 11 09:05:45 2007
++++ homedir/Makefile.in Sun Feb 11 09:07:59 2007
+@@ -57,23 +57,19 @@
+ $(HINST) -m 755 -d $(DIR); fi
+ if test ! -d $(DIR)/log; then\
+ $(HINST) -m 710 -d $(DIR)/log; fi
+- if test -s $(DIR)/dcc_conf; then\
+- sh make-dcc_conf -h $(DIR);\
+- else\
+- $(HINST) -m 644 dcc_conf $(DIR)/dcc_conf;\
- fi
-+ $(HINSTALL) -m 644 dcc_conf $(INST_HOMEDIR)/dcc_conf.dist; \
- for nm in flod grey_flod whitelist grey_whitelist \
- whiteclnt whitecommon; do \
- if test ! -f $(INST_HOMEDIR)/$$nm; then \
-- $(HINSTALL) -m 644 $$nm $(INST_HOMEDIR)/$$nm; fi; \
-+ $(HINSTALL) -m 644 $$nm $(INST_HOMEDIR)/$$nm.dist; fi; \
- done
- @if test ! -f $(INST_HOMEDIR)/ids \
- -a ! -f $(INST_HOMEDIR)/map \
-@@ -67,11 +63,11 @@
- PASSWD1=`ps|cksum|tr ' ' 'xy'`; \
- PASSWD2=`ps|cksum|tr ' ' 'yx'`; \
- umask 077; \
-- sed -e "s/secret1/$$PASSWD1/" map.txt >$(INST_HOMEDIR)/map.txt; \
-+ sed -e "s/secret1/$$PASSWD1/" map.txt >$(INST_HOMEDIR)/map.txt.dist; \
- sed -e "s/secret1/$$PASSWD1/" -e "s/secret2/$$PASSWD2/" ids \
-- >$(INST_HOMEDIR)/ids; \
-+ >$(INST_HOMEDIR)/ids.dist; \
- ${DEPTH}/cdcc/cdcc -qh $(INST_HOMEDIR) 'new map; load -' \
-- <$(INST_HOMEDIR)/map.txt >/dev/null; \
-- set +e; chown $(DCC_SUID) $(INST_HOMEDIR)/map.txt \
-- $(INST_HOMEDIR)/map $(INST_HOMEDIR)/ids; \
-+ <$(INST_HOMEDIR)/map.txt.dist >/dev/null; \
-+ set +e; chown $(DCC_SUID) $(INST_HOMEDIR)/map.txt.dist \
-+ $(INST_HOMEDIR)/map $(INST_HOMEDIR)/ids.dist; \
++ $(INSTALL) -m 644 dcc_conf $(DIR)/dcc_conf.dist; \
+ for nm in flod grey_flod whitelist grey_whitelist\
+ whiteclnt whitecommon; do\
+ if test ! -f $(DIR)/$$nm; then\
+- $(HINST) -m 644 $$nm $(DIR)/$$nm; fi; done
++ $(INSTALL) -m 644 $$nm $(DIR)/$$nm.dist; fi; done
+ if test ! -f $(DIR)/ids -a ! -f $(DIR)/map -a ! -f $(DIR)/map.txt; then\
+ umask 077; PASSWD1=`$(RSTRING)`; PASSWD2=`$(RSTRING)`;\
+- sed -e "s/secret1/$$PASSWD1/" map.txt >$(DIR)/map.txt;\
++ sed -e "s/secret1/$$PASSWD1/" map.txt >$(DIR)/map.txt.dist;\
+ sed -e "s/secret1/$$PASSWD1/" -e "s/secret2/$$PASSWD2/" ids\
+- >$(DIR)/ids;\
+- ${DEPTH}/cdcc/cdcc -qh $(DIR) 'new map; load $(DIR)/map.txt';\
+- set +e; chown $(DCC_SUID) $(DIR)/map.txt\
+- $(DIR)/map $(DIR)/ids;\
++ >$(DIR)/ids.dist;\
++ ${DEPTH}/cdcc/cdcc -qh $(DIR) 'new map; load $(DIR)/map.txt.dist';\
++ set +e; chown $(DCC_SUID) $(DIR)/map.txt.dist\
++ $(DIR)/map $(DIR)/ids.dist;\
fi
+
+ deinstall:
diff --git a/mail/dcc-dccd/pkg-plist b/mail/dcc-dccd/pkg-plist
index 048db3804c98..b3716160ca84 100644
--- a/mail/dcc-dccd/pkg-plist
+++ b/mail/dcc-dccd/pkg-plist
@@ -13,9 +13,6 @@ dcc/grey_whitelist.dist
@unexec if cmp -s %D/dcc/ids %D/dcc/ids.dist; then rm -f %D/dcc/ids; fi
dcc/ids.dist
@exec [ -f %B/ids ] || cp %B/%f %B/ids
-@unexec if cmp -s %D/dcc/map %D/dcc/map.dist; then rm -f %D/dcc/map; fi
-dcc/map.dist
-@exec [ -f %B/map ] || cp %B/%f %B/map
@unexec if cmp -s %D/dcc/map.txt %D/dcc/map.txt.dist; then rm -f %D/dcc/map.txt; fi
dcc/map.txt.dist
@exec [ -f %B/map.txt ] || cp %B/%f %B/map.txt
@@ -39,6 +36,8 @@ dcc/cgi-bin/http2https
dcc/cgi-bin/list-log
dcc/cgi-bin/list-msg
dcc/cgi-bin/webuser-notify
+dcc/cgi-bin/footer.dist
+dcc/cgi-bin/header.dist
dcc/libexec/cron-dccd
%%WITH_DCCIFD%%dcc/libexec/dccifd
%%WITH_SENDMAIL%%dcc/libexec/dccm
@@ -49,6 +48,7 @@ dcc/libexec/dcc-stats-graph
dcc/libexec/dcc-stats-init
dcc/libexec/dccd
dcc/libexec/dccsight
+dcc/libexec/dns-helper
dcc/libexec/fetchblack
dcc/libexec/fetch-testmsg-whitelist
dcc/libexec/hackmc
@@ -65,6 +65,7 @@ dcc/libexec/stop-dccd
dcc/libexec/updatedcc
dcc/libexec/uninstalldcc
dcc/libexec/wlist
+dcc/map
@dirrm dcc/log
@dirrm dcc/libexec
@dirrm dcc/cgi-bin