aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot-antispam
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-07 05:33:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-07 05:33:07 +0000
commitd9d5ea228cbb565682ac0eebe8c9bfbc3be42542 (patch)
tree7c5865433575cd5e7d9eeb8e139c6bdca73025ac /mail/dovecot-antispam
parenta4d282716fc872823c7dcfb6b81135e961540e15 (diff)
downloadports-d9d5ea228cbb565682ac0eebe8c9bfbc3be42542.tar.gz
ports-d9d5ea228cbb565682ac0eebe8c9bfbc3be42542.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=320145
Diffstat (limited to 'mail/dovecot-antispam')
-rw-r--r--mail/dovecot-antispam/Makefile44
1 files changed, 21 insertions, 23 deletions
diff --git a/mail/dovecot-antispam/Makefile b/mail/dovecot-antispam/Makefile
index 9a85dc1981b4..917a14e9091b 100644
--- a/mail/dovecot-antispam/Makefile
+++ b/mail/dovecot-antispam/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dovecot-antispam
-# Date created: Sat Jan 5 16:31:30 MSK 2008
-# Whom: Denis Shaposhnikov <dsh@wizard.volgograd.ru>
-#
+# Created by: Denis Shaposhnikov <dsh@wizard.volgograd.ru>
# $FreeBSD$
-#
PORTNAME= dovecot-antispam
PORTVERSION= 1.3
@@ -25,36 +21,38 @@ USE_LDCONFIG= ${PREFIX}/lib/dovecot/imap
MAN7= dovecot-antispam.7
-OPTIONS+= DSPAM "direct dspam training" on
-OPTIONS+= MAILTRAIN "send mail to special addresses for training" off
-OPTIONS+= DEBUG "Turn on debug information (syslog)" off
-OPTIONS+= DEBUG_VERBOSE "Turn on verbose debug" off
+OPTIONS_DEFINE= DSPAM MAILTRAIN DEBUG DEBUG_VERBOSE
+OPTIONS_DEFAULT= DSPAM
+DSPAM_DESC= Direct dspam training
+MAILTRAIN_DESC= send mail to special addresses for training
+DEBUG_DESC= Turn on debug information (syslog)
+DEBUG_VERBOSE_DESC= Turn on verbose debug
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/lib90_antispam_plugin.so \
- ${PREFIX}/lib/dovecot/imap/
- ${INSTALL_MAN} ${WRKSRC}/antispam.7 \
- ${MANPREFIX}/man/man7/dovecot-antispam.7
-
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
do-configure:
DOVECOT=`${MAKE} -C ${PORTSDIR}/mail/dovecot -V WRKSRC` && \
${ECHO} "DOVECOT=$$DOVECOT" > ${WRKSRC}/.config
-.if defined(WITH_DSPAM)
+.if ${PORT_OPTIONS:MDSPAM}
${ECHO} "BACKEND=dspam-exec" >> ${WRKSRC}/.config
.endif
-.if defined(WITH_MAILTRAIN)
+.if ${PORT_OPTIONS:MMAILTRAIN}
${ECHO} "BACKEND=mailtrain" >> ${WRKSRC}/.config
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
${ECHO} "DEBUG=syslog" >> ${WRKSRC}/.config
.endif
-.if defined(WITH_DEBUG_VERBOSE)
+.if ${PORT_OPTIONS:MDEBUG_VERBOSE}
${ECHO} "DEBUG_VERBOSE=1" >> ${WRKSRC}/.config
.endif
${ECHO} "PLUGINNAME=antispam" >> ${WRKSRC}/.config
-.include <bsd.port.post.mk>
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib90_antispam_plugin.so \
+ ${PREFIX}/lib/dovecot/imap/
+ ${INSTALL_MAN} ${WRKSRC}/antispam.7 \
+ ${MANPREFIX}/man/man7/dovecot-antispam.7
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>