aboutsummaryrefslogtreecommitdiff
path: root/mail/elm+ME/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-01-31 17:16:07 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-01-31 17:16:07 +0000
commitba75d40447b0ae425dbf278692a9429137d655dc (patch)
tree42fb93cb2c99da0ee4f0da21cf4e55036383282b /mail/elm+ME/Makefile
parent7e52050297b041a86b785390f866ddd095809cad (diff)
downloadports-ba75d40447b0ae425dbf278692a9429137d655dc.tar.gz
ports-ba75d40447b0ae425dbf278692a9429137d655dc.zip
update to 2.4ME+87.
o change package name elm-2.4ME+82 -> elm+ME-2.4.87. previous naming scheme violates our porting rule. o add PORTEPOCH not to confuse pkg_version. o change maintainer. o add more and more MASTER_SITES. PR: 24171 Submitted by: Cyrille Lefevre <clefevre@citeweb.net> (new maintainer)
Notes
Notes: svn path=/head/; revision=37844
Diffstat (limited to 'mail/elm+ME/Makefile')
-rw-r--r--mail/elm+ME/Makefile111
1 files changed, 89 insertions, 22 deletions
diff --git a/mail/elm+ME/Makefile b/mail/elm+ME/Makefile
index 1c1ed9604f55..53963e885980 100644
--- a/mail/elm+ME/Makefile
+++ b/mail/elm+ME/Makefile
@@ -5,35 +5,102 @@
# $FreeBSD$
#
-PORTNAME= elm
-PORTVERSION= 2.4ME+82
+PORTNAME= elm+ME
+PORTVERSION= 2.4.87
+PORTEPOCH= 1
CATEGORIES= mail
+DISTNAME= ${PORTNAME:S/+ME//}-${PORTVERSION:R}ME+${PORTVERSION:E}
+
+# here are the main repositories.
MASTER_SITES= ftp://ftp.ozone.fmi.fi/KEH/ \
- ftp://ftp.funet.fi/pub/unix/mail/elm/elm-2.4ME+/ \
- ftp://ftp.ibp.fr/pub/unix/mail/elm-me/
+ http://www.ozone.fmi.fi/KEH/
-MAINTAINER= ports@FreeBSD.org
+# the following repositories conform to the main repository.
+MASTER_SITES+= ftp://ftp.tu-darmstadt.de/pub/networking/mail/elm+ME/ \
+ ftp://ftp.cs.tu-berlin.de/pub/net/mail/elm-me-plus/ \
+ ftp://ftp.ntua.gr/pub/net/mail/elm-me/ \
+ ftp://ftp.eos.hokudai.ac.jp/pub/network/mail/elm-2.4ME+/ \
+ ftp://ftp.win.ne.jp/pub/network/mail/elm-2.4ME+/
-WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/ME+/\.ME+\./}
-MAN1= answer.1 checkalias.1 elm.1 elmalias.1 fastmail.1 \
- frm.1 listalias.1 messages.1 newalias.1 newmail.1 \
- printmail.1 readmsg.1 elmcharset.1 elmterminal.1
-MLINKS= frm.1 nfrm.1 newmail.1 wnewmail.1
+# the following repositories maybe conform to the main repository.
+MASTER_SITES+= ftp://ftp.unina.it/pub/Unix/pkgs/network/mail/elm-me+/ \
+ ftp://ftp.rge.com/pub/mail/elm/elm-2.4ME+/ \
+ ftp://ftp.uni-trier.de/pub/unix/network/mail/elm-me+/
+
+# fetch doesn't work w/ ftp.lip6.fr and ftp doesn't work w/ the http protocol.
+# MASTER_SITES+= ftp://ftp.lip6.fr/pub/unix/mail/elm-me/
+# FETCH_CMD= /usr/bin/ftp
+
+MAINTAINER= clefevre@citeweb.net
+
+# not needed since config.sh is generated by scripts/pre-configure.
+# BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
+# BUILD_DEPENDS= metamail:${PORTSDIR}/mail/metamail
+# BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
+# BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-//:S/ME+/.ME+./}
+
+#
+# Global variables
+#
HAS_CONFIGURE= yes
+
CONFIGURE_SCRIPT= Configure
-CONFIGURE_ENV= PREFIX="${PREFIX}"
-CONFIGURE_ARGS= -S -d
-
-post-install:
- perl -pi -e 's,/usr/local,${PREFIX},' ${WRKSRC}/nls/LANGS
- cd ${WRKSRC}/nls; ${MAKE} install
- if [ -f ${PREFIX}/lib/elm.mimetypes ] ; then \
- ${INSTALL_DATA} \
- ${FILESDIR}/elm.mimetypes ${PREFIX}/lib/elm.mimetypes-dist; \
- else \
- ${INSTALL_DATA} \
- ${FILESDIR}/elm.mimetypes ${PREFIX}/lib; \
+SCRIPTS_ENV= CFLAGS="${CFLAGS}" PREFIX="${PREFIX}"
+CONFIGURE_ARGS= -S -d -P${PREFIX}
+
+MAN1= answer.1 checkalias.1 elm.1 elmalias.1 elmcharset.1 \
+ elmterminal.1 fastmail.1 frm.1 listalias.1 messages.1 \
+ newalias.1 newmail.1 printmail.1 readmsg.1
+MLINKS= frm.1 nfrm.1 newmail.1 wnewmail.1
+
+#
+# Local variables
+#
+
+DESTLIBDIR= ${PREFIX}/lib/${PORTNAME:S/+ME//}
+MIMETYPES= elm.mimetypes
+
+#
+# Post-configure
+#
+
+post-configure:
+ @${PERL} -pi.bsd -e 's,/usr/local,${PREFIX},' ${WRKSRC}/nls/LANGS
+
+#
+# Post-install
+#
+
+post-install: install-nls install-mime-types \
+ remove-catman-files remove-catman-links
+
+install-nls:
+ @cd ${WRKSRC}/nls; ${MAKE} install
+
+install-mime-types:
+ @${INSTALL_DATA} \
+ ${FILESDIR}/${MIMETYPES} ${DESTLIBDIR}/${MIMETYPES}-dist
+ @if [ ! -f ${DESTLIBDIR}/${MIMETYPES} ]; then \
+ ${INSTALL_DATA} ${FILESDIR}/${MIMETYPES} ${DESTLIBDIR}; \
fi
+remove-catman-files:
+.for sect in 1
+.for page in ${MAN${sect}}
+ @${RM} -f ${MAN${sect}PREFIX}/man/cat${sect}/${page}
+.endfor
+.endfor
+
+remove-catman-links:
+.for sect in 1
+.for page in ${MLINKS}
+.if ${MAN${sect}:M${page}} == ""
+ @${RM} -f ${MAN${sect}PREFIX}/man/cat${sect}/${page}
+.endif
+.endfor
+.endfor
+
.include <bsd.port.mk>