aboutsummaryrefslogtreecommitdiff
path: root/mail/elm
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-03-03 10:44:26 +0000
committerChris Rees <crees@FreeBSD.org>2013-03-03 10:44:26 +0000
commit33a3535a9e8f03f0fb9a05e73751f559d0e6b29b (patch)
tree7083c7f4b6c4f7414bbf5d98e70f45335dd7f91c /mail/elm
parentef1d9441f0940ce1441e74de11a87ebfc081d504 (diff)
downloadports-33a3535a9e8f03f0fb9a05e73751f559d0e6b29b.tar.gz
ports-33a3535a9e8f03f0fb9a05e73751f559d0e6b29b.zip
Stop being INTERACTIVE
Correct name of patch-aa PR: ports/175412 Approved by: maintainer timeout (toasty@dragondata.com, 6 weeks)
Notes
Notes: svn path=/head/; revision=313340
Diffstat (limited to 'mail/elm')
-rw-r--r--mail/elm/Makefile8
-rw-r--r--mail/elm/files/patch-Configure (renamed from mail/elm/files/patch-aa)26
2 files changed, 23 insertions, 11 deletions
diff --git a/mail/elm/Makefile b/mail/elm/Makefile
index 36013d0e9aef..0f22fd968d01 100644
--- a/mail/elm/Makefile
+++ b/mail/elm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: elm25
-# Date created: 04 Feb 2000
-# Whom: dhagan@cs.vt.edu
-#
+# Created by: dhagan@cs.vt.edu
# $FreeBSD$
-#
PORTNAME= elm
PORTVERSION= 2.5.8
@@ -24,10 +20,10 @@ CFLAGS+= -D_SIZE_T
WRKSRC= ${WRKDIR}/elm${PORTVERSION}
NO_LATEST_LINK= yes
USE_GETTEXT= yes
-IS_INTERACTIVE= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ENV= PREFIX="${PREFIX}"
+CONFIGURE_ARGS= -d
MAN1= answer.1 checkalias.1 elm.1 elmalias.1 fastmail.1 \
frm.1 listalias.1 messages.1 newalias.1 newmail.1 \
printmail.1 readmsg.1 mmencode.1
diff --git a/mail/elm/files/patch-aa b/mail/elm/files/patch-Configure
index 0f84acf0848d..95d2af9e29f2 100644
--- a/mail/elm/files/patch-aa
+++ b/mail/elm/files/patch-Configure
@@ -1,5 +1,5 @@
---- Configure.orig Fri Dec 15 14:00:55 2000
-+++ Configure Mon Jan 27 04:04:55 2003
+--- Configure.orig 2005-08-18 13:49:24.000000000 +0100
++++ Configure 2013-01-18 16:14:29.794050455 +0000
@@ -18,11 +18,6 @@
PATH=".:/bin:/usr/bin:/usr/local/bin:/usr/ucb:/usr/local:/usr/lbin:/etc:/usr/new:/usr/new/bin:/usr/nbin:$PATH"
export PATH || (echo "OOPS, this isn't sh. Desperation time. I will feed myself to sh."; sh $0; kill $$)
@@ -12,7 +12,15 @@
(alias) >/dev/null 2>&1 && \
echo "(I see you are using the Korn shell. Some ksh's blow up on Configure," && \
echo "especially on exotic machines. If yours does, try the Bourne shell instead.)"
-@@ -2055,6 +2050,7 @@
+@@ -491,7 +486,6 @@
+ c='\c'
+ fi
+ echo $n "Type carriage return to continue. Your cursor should be here-->$c"
+-read ans
+ rm -f .echotmp
+
+ : now set up to do reads with possible shell escape and default assignment
+@@ -2058,6 +2052,7 @@
libc=/usr/lib/libc.a
else
set /usr/ccs/lib/libc.so
@@ -20,7 +28,7 @@
test -f $1 || set /usr/lib/libc.so
test -f $1 || set /usr/lib/libc.so.[0-9]*
test -f $1 || set /lib/libsys_s.a
-@@ -2108,7 +2104,7 @@
+@@ -2111,7 +2106,7 @@
set `echo $libc $libnames | tr ' ' '\012' | sort | uniq`
$echo $n "Extracting names from $* for later perusal...$c"
nm $nm_opts $* 2>/dev/null >libc.tmp
@@ -29,7 +37,7 @@
if $contains '^printf$' libc.list >/dev/null 2>&1; then
echo done
elif $sed -n -e 's/^__*//' -e 's/^\([a-zA-Z_0-9$]*\).*xtern.*/\1/p' \
-@@ -2496,7 +2492,10 @@
+@@ -2499,7 +2494,10 @@
#
: see if crypt exists
echo " "
@@ -41,3 +49,11 @@
echo 'crypt() found.'
d_crypt="$define"
cryptlib=''
+@@ -5499,7 +5497,6 @@
+ echo "If you didn't make any mistakes, then just type a carriage return here."
+ rp="If you need to edit config.sh, do it as a shell escape here:"
+ $echo $n "$rp $c"
+-. UU/myread
+ case "$ans" in
+ '') ;;
+ *) : in case they cannot read