aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-09 21:56:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-07-09 21:56:37 +0000
commitaea805e7015158f94dea96cbb3c6781db691518a (patch)
tree37a25d324ac45010327a548f06ed06cc1852eb25 /mail/evolution-devel
parent2d1575bb6f67b89ecbc09b3cc7fe5c92835daeb6 (diff)
downloadports-aea805e7015158f94dea96cbb3c6781db691518a.tar.gz
ports-aea805e7015158f94dea96cbb3c6781db691518a.zip
* Update to 1.0.8.
* Implement USE_GNOMENG * Implement REINPLACE With this commit, and the upcoming bonobo-conf commit, GNOME 2.0 users should be able to use Evolution wihtout needing any other hacks.
Notes
Notes: svn path=/head/; revision=62723
Diffstat (limited to 'mail/evolution-devel')
-rw-r--r--mail/evolution-devel/Makefile19
-rw-r--r--mail/evolution-devel/distinfo2
-rw-r--r--mail/evolution-devel/pkg-plist36
3 files changed, 43 insertions, 14 deletions
diff --git a/mail/evolution-devel/Makefile b/mail/evolution-devel/Makefile
index 226eb3b54a05..d87020aecd43 100644
--- a/mail/evolution-devel/Makefile
+++ b/mail/evolution-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= evolution
-PORTVERSION= 1.0.7
+PORTVERSION= 1.0.8
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://people.FreeBSD.org/~sobomax/:local
@@ -38,13 +38,14 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_REINPLACE= yes
USE_OPENSSL= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure libical/configure
CONFIGURE_ARGS= --with-db3-libs=${DB3_WRKSRC} \
--with-db3-includes=${DB3_WRKSRC} \
- --with-html-dir=${PREFIX}/share/gnome/html \
--with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nspr-libs=${LOCALBASE}/lib \
--with-nss-includes=${LOCALBASE}/include/nss/security \
@@ -58,24 +59,22 @@ CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
CONFIGURE_ARGS+= --with-pisock=${LOCALBASE} \
--enable-pilot-conduits=yes
PLIST_SUB= PILOT:=""
+USE_GNOME+= gnomecc
.else
PLIST_SUB= PILOT:="@comment "
.endif
CONFIGURE_ENV= CPPFLAGS="-I${DB3_WRKSRC} -I${LOCALBASE}/include" \
- LIBS="-pthread -L${LOCALBASE}/lib"
+ LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
PLIST_SUB+= VERSION=${PORTVERSION}
MAN1= evolution.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
@find ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l '<db.h>' | \
- xargs ${PERL} -pi -e 's|<db.h>|<db3/db.h>|g'
+ xargs ${REINPLACE_CMD} -e 's|<db.h>|<db3/db.h>|g'
# DB3 stuff. Ugly, I know, but that's life.
DB3_WRKSRC= ${WRKDIR}/db-3.1.17/build_unix
diff --git a/mail/evolution-devel/distinfo b/mail/evolution-devel/distinfo
index 29ce0dcd6da9..4768cba53740 100644
--- a/mail/evolution-devel/distinfo
+++ b/mail/evolution-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome/evolution-1.0.7.tar.bz2) = dc9903e497fc063d77d256bb026a933f
+MD5 (gnome/evolution-1.0.8.tar.bz2) = e8fceec57a66d15d0e8530661e6be490
MD5 (gnome/db-3.1.17.tar.bz2) = b237f4e38a650d096389ff54d564928d
MD5 (gnome/evolution-1.0.2-reply-to.diff.gz) = d7d7dd874562da73979ce13a57093760
diff --git a/mail/evolution-devel/pkg-plist b/mail/evolution-devel/pkg-plist
index 2ebade00f905..94a1c66557d2 100644
--- a/mail/evolution-devel/pkg-plist
+++ b/mail/evolution-devel/pkg-plist
@@ -526,6 +526,35 @@ share/gnome/help/evolution/no/usage-print.html
share/gnome/help/evolution/no/usage-summary.html
share/gnome/help/evolution/no/usage-sync.html
share/gnome/help/evolution/no/usage.html
+share/gnome/html/evolution-devel-guide/alarm-trigger-generation-code.html
+share/gnome/html/evolution-devel-guide/calclient.html
+share/gnome/html/evolution-devel-guide/calcomponent.html
+share/gnome/html/evolution-devel-guide/calendar-alarm-generation.html
+share/gnome/html/evolution-devel-guide/calendar-architecture.html
+share/gnome/html/evolution-devel-guide/calendar-public-reference.html
+share/gnome/html/evolution-devel-guide/evolution-api-reference.html
+share/gnome/html/evolution-devel-guide/evolution-cal-util-cal-recur.html
+share/gnome/html/evolution-devel-guide/evolution-cal-util-cal-util.html
+share/gnome/html/evolution-devel-guide/evolution-cal-util-timeutil.html
+share/gnome/html/evolution-devel-guide/evolution-calendar.html
+share/gnome/html/evolution-devel-guide/fdl-section1.html
+share/gnome/html/evolution-devel-guide/fdl-section10.html
+share/gnome/html/evolution-devel-guide/fdl-section2.html
+share/gnome/html/evolution-devel-guide/fdl-section3.html
+share/gnome/html/evolution-devel-guide/fdl-section4.html
+share/gnome/html/evolution-devel-guide/fdl-section5.html
+share/gnome/html/evolution-devel-guide/fdl-section6.html
+share/gnome/html/evolution-devel-guide/fdl-section7.html
+share/gnome/html/evolution-devel-guide/fdl-section8.html
+share/gnome/html/evolution-devel-guide/fdl-section9.html
+share/gnome/html/evolution-devel-guide/fdl-using.html
+share/gnome/html/evolution-devel-guide/fdl.html
+share/gnome/html/evolution-devel-guide/generating-trigger-instances.html
+share/gnome/html/evolution-devel-guide/index.html
+share/gnome/html/evolution-devel-guide/introduction.html
+share/gnome/html/evolution-devel-guide/x102.html
+share/gnome/html/evolution-devel-guide/x125.html
+share/gnome/html/evolution-devel-guide/x134.html
share/gnome/idl/Composer.idl
share/gnome/idl/Evolution-Activity.idl
share/gnome/idl/Evolution-Composer.idl
@@ -940,16 +969,20 @@ share/gnome/libical-evolution/zoneinfo/Asia/Kuala_Lumpur.ics
share/gnome/libical-evolution/zoneinfo/Asia/Kuching.ics
share/gnome/libical-evolution/zoneinfo/Asia/Kuwait.ics
share/gnome/libical-evolution/zoneinfo/Asia/Macao.ics
+share/gnome/libical-evolution/zoneinfo/Asia/Macau.ics
share/gnome/libical-evolution/zoneinfo/Asia/Magadan.ics
+share/gnome/libical-evolution/zoneinfo/Asia/Makassar.ics
share/gnome/libical-evolution/zoneinfo/Asia/Manila.ics
share/gnome/libical-evolution/zoneinfo/Asia/Muscat.ics
share/gnome/libical-evolution/zoneinfo/Asia/Nicosia.ics
share/gnome/libical-evolution/zoneinfo/Asia/Novosibirsk.ics
share/gnome/libical-evolution/zoneinfo/Asia/Omsk.ics
+share/gnome/libical-evolution/zoneinfo/Asia/Oral.ics
share/gnome/libical-evolution/zoneinfo/Asia/Phnom_Penh.ics
share/gnome/libical-evolution/zoneinfo/Asia/Pontianak.ics
share/gnome/libical-evolution/zoneinfo/Asia/Pyongyang.ics
share/gnome/libical-evolution/zoneinfo/Asia/Qatar.ics
+share/gnome/libical-evolution/zoneinfo/Asia/Qyzylorda.ics
share/gnome/libical-evolution/zoneinfo/Asia/Rangoon.ics
share/gnome/libical-evolution/zoneinfo/Asia/Riyadh.ics
share/gnome/libical-evolution/zoneinfo/Asia/Saigon.ics
@@ -1191,10 +1224,7 @@ share/locale/zh_TW/LC_MESSAGES/evolution.mo
@dirrm share/gnome/images/evolution/conduits
@dirrm share/gnome/images/evolution/buttons
@dirrm share/gnome/images/evolution
-@dirrm share/gnome/images
@dirrm share/gnome/html/evolution-devel-guide
-@dirrm share/gnome/html/evolution-cal-util
-@dirrm share/gnome/html/evolution-cal-client
@dirrm share/gnome/help/evolution/no/stylesheet-images
@dirrm share/gnome/help/evolution/no/sgml
@dirrm share/gnome/help/evolution/no/figures