aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-02-12 16:46:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-02-12 16:46:23 +0000
commitaf13aa1d5ade82c77983431447fe548a4a2a8b03 (patch)
tree67d9a52057aeec6fe5dea083c10d121698bcf41e /mail/evolution
parent7ada5affed049fa6c975d47ea65bb3fd4e834e2f (diff)
downloadports-af13aa1d5ade82c77983431447fe548a4a2a8b03.tar.gz
ports-af13aa1d5ade82c77983431447fe548a4a2a8b03.zip
- Simplify ldconfig handling
Notes
Notes: svn path=/head/; revision=228123
Diffstat (limited to 'mail/evolution')
-rw-r--r--mail/evolution/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 491993667fd3..504d4a8af362 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -27,8 +27,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack evolutiondataserver gtkhtml3 \
USE_AUTOTOOLS= libtool:15
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-USE_LDCONFIG= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/evolution/%%VERSION%%
+USE_LDCONFIG= ${PREFIX}/lib/evolution/${EVO_VERSION}
CONFIGURE_ARGS= --enable-nss=yes \
--enable-mono=no \
--with-sub-version=" FreeBSD GNOME Team Port"
@@ -56,9 +55,6 @@ OPTIONS= PILOT "Enable Palm Pilot sync support" off \
.include <bsd.port.pre.mk>
-USE_LDCONFIG= ${PREFIX}/lib/evolution/${EVO_VERSION}
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
-
.if defined(WITH_PILOT)
LIB_DEPENDS+= gpilotdconduit.2:${PORTSDIR}/palm/gnome-pilot
CONFIGURE_ARGS+= --with-pisock=${LOCALBASE} \
@@ -100,7 +96,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/sbin|${LOCALBASE}/bin|g' \
${WRKSRC}/plugins/sa-junk-plugin/em-junk-filter.c
-post-install: install-ldconfig-file
+post-install:
${MKDIR} ${PREFIX}/include/evolution-${EVO_VERSION}/composer
${INSTALL_DATA} ${WRKSRC}/composer/e-msg*.h ${PREFIX}/include/evolution-${EVO_VERSION}/composer