aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2003-04-09 18:44:05 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2003-04-09 18:44:05 +0000
commit29399f79c93875d8725f1d44c2f65b9109b56482 (patch)
tree8c499d86afa36dad30abdddb397f79d8e8655ff1 /mail/exim
parent68128a40e4d6b69104351a706b190d35cffaa7a3 (diff)
downloadports-29399f79c93875d8725f1d44c2f65b9109b56482.tar.gz
ports-29399f79c93875d8725f1d44c2f65b9109b56482.zip
1) Fix reproducible plaintext authentication crash.
2) In the sample configuration file, allow relaying from the IPv6 and IPv4 localhost addresses. This fixes relaying problems for folks using things like IPv6-enabled mailman. Bump PORTREVISION accordingly. Reported by: Alexander Sabourenkov <lxnt@caravan.ru> (1) Mark Edwards <mark@antsclimbtree.com> (2)
Notes
Notes: svn path=/head/; revision=78676
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile1
-rw-r--r--mail/exim/files/patch-src::auths::plantext.c11
-rw-r--r--mail/exim/files/patch-src::configure.default9
3 files changed, 21 insertions, 0 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 96823e4ec895..aff8ca389001 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim4/ \
http://www.exim.org/ftp/exim4/ \
diff --git a/mail/exim/files/patch-src::auths::plantext.c b/mail/exim/files/patch-src::auths::plantext.c
new file mode 100644
index 000000000000..4beccd085242
--- /dev/null
+++ b/mail/exim/files/patch-src::auths::plantext.c
@@ -0,0 +1,11 @@
+--- src/auths/plaintext.c.orig Tue Apr 1 14:53:33 2003
++++ src/auths/plaintext.c Tue Apr 1 14:53:40 2003
+@@ -93,7 +93,7 @@
+ if (Ustrcmp(data, "=") == 0)
+ {
+ expand_nstring[++expand_nmax] = US"";
+- expand_nstring[expand_nmax] = 0;
++ expand_nlength[expand_nmax] = 0;
+ }
+ else
+ {
diff --git a/mail/exim/files/patch-src::configure.default b/mail/exim/files/patch-src::configure.default
index 47178ccf03dc..03ba42184f8f 100644
--- a/mail/exim/files/patch-src::configure.default
+++ b/mail/exim/files/patch-src::configure.default
@@ -1,5 +1,14 @@
--- src/configure.default.orig Fri Nov 23 17:31:16 2001
+++ src/configure.default Tue Dec 18 23:34:07 2001
+@@ -56,7 +56,7 @@
+
+ domainlist local_domains = @
+ domainlist relay_to_domains =
+-hostlist relay_from_hosts = 127.0.0.1
++hostlist relay_from_hosts = localhost
+
+ # Most straightforward access control requirements can be obtained by
+ # appropriate settings of the above options. In more complicated situations, you
@@ -147,6 +147,8 @@
# were a normal user. This isn't usually a problem, as most sites have an alias
# for root that redirects such mail to a human administrator.