aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2003-05-21 12:57:33 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2003-05-21 12:57:33 +0000
commitbc7aea83aad9638f31db5ed9778003626e3a51c1 (patch)
tree3bddec2fb5d7a3b49c1f4652e4d2fbcb8c86921b /mail/exim
parent608796ba030f3976a2cb8a032ff12e32ab95f31f (diff)
downloadports-bc7aea83aad9638f31db5ed9778003626e3a51c1.tar.gz
ports-bc7aea83aad9638f31db5ed9778003626e3a51c1.zip
Enable client-side Microsoft "Secure Password Authentication" SMTP AUTH
support by default and provide the WITHOUT_AUTH_SPA knob to turn it off. Adds 11KB to the installed binary and requires configuration changes to enable, so it seems a harmless addition to the default feature set. Bump PORTREVISION accordingly. Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com>
Notes
Notes: svn path=/head/; revision=81608
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 8f2eb2e7bedc..1876beae24f1 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/%SUBDIR%/ \
ftp://gd.tuwien.ac.at/infosys/mail/exim/%SUBDIR%/ \
@@ -121,11 +122,13 @@ DB_LIB_VERSION?=1
# be called during string expansion.
#WITHOUT_PERL= yes
#
-# Disable built-in Exim support for the PAM, RFC 2195 and RFC 2595
-# authentication mechanisms, used for SMTP AUTH.
+# Disable built-in Exim support for the PAM, RFC 2195, RFC 2595 and
+# Microsoft "Secure Password Authentication" authentication mechanisms,
+# used for SMTP AUTH.
#WITHOUT_PAM= yes
#WITHOUT_AUTH_CRAM_MD5= yes
#WITHOUT_AUTH_PLAINTEXT= yes
+#WITHOUT_AUTH_SPA= yes
#
# Disable built-in Exim support for additional mailbox formats.
#WITHOUT_MAILDIR= yes
@@ -278,6 +281,10 @@ SEDLIST+= -e 's,^\# AUTH_CRAM_MD5=,AUTH_CRAM_MD5=,'
SEDLIST+= -e 's,^\# AUTH_PLAINTEXT=,AUTH_PLAINTEXT=,'
.endif
+.if !defined(WITHOUT_AUTH_SPA)
+SEDLIST+= -e 's,^\# AUTH_SPA=,AUTH_SPA=,'
+.endif
+
.if defined(WITH_PGSQL)
LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
SEDLIST+= -e 's,XX_PGSQL_LIBS_XX,-L${LOCALBASE}/lib -lpq,' \