aboutsummaryrefslogtreecommitdiff
path: root/mail/hashcash
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-01 17:31:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-01 17:31:20 +0000
commitce13e96bb7e8264c028ee9d55e267bca96e798bd (patch)
treedd7be75f5970e748d430972225c13896e0a727fc /mail/hashcash
parent0e047ba62db465dae8de2afc96584614e0493e50 (diff)
downloadports-ce13e96bb7e8264c028ee9d55e267bca96e798bd.tar.gz
ports-ce13e96bb7e8264c028ee9d55e267bca96e798bd.zip
Add hashcash, a tool used to sign email with a token guaranteeing that
it took some computation to send. PR: ports/62138 Submitted by: David Bremner <bremner@unb.ca>
Notes
Notes: svn path=/head/; revision=99721
Diffstat (limited to 'mail/hashcash')
-rw-r--r--mail/hashcash/Makefile19
-rw-r--r--mail/hashcash/distinfo1
-rw-r--r--mail/hashcash/files/patch-Makefile16
-rw-r--r--mail/hashcash/files/patch-hashcash-h19
-rw-r--r--mail/hashcash/pkg-descr4
-rw-r--r--mail/hashcash/pkg-plist2
6 files changed, 61 insertions, 0 deletions
diff --git a/mail/hashcash/Makefile b/mail/hashcash/Makefile
new file mode 100644
index 000000000000..d24df2c9caf5
--- /dev/null
+++ b/mail/hashcash/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: hashcash
+# Date created: Jan 30, 2003
+# Whom: bremner@unb.ca
+#
+# $FreeBSD$
+#
+
+PORTNAME= hashcash
+PORTVERSION= 0.28
+CATEGORIES= mail
+MASTER_SITES= http://www.cypherspace.org/hashcash/source/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bremner@unb.ca
+COMMENT= Anti-spam / denial of service counter-measure tool
+
+MAN1= hashcash.1 sha1.1
+
+.include <bsd.port.mk>
diff --git a/mail/hashcash/distinfo b/mail/hashcash/distinfo
new file mode 100644
index 000000000000..47697baa82b7
--- /dev/null
+++ b/mail/hashcash/distinfo
@@ -0,0 +1 @@
+MD5 (hashcash-0.28.tgz) = 8c929d963fcb6240af251cca5990d741
diff --git a/mail/hashcash/files/patch-Makefile b/mail/hashcash/files/patch-Makefile
new file mode 100644
index 000000000000..d5de85cba777
--- /dev/null
+++ b/mail/hashcash/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig Fri Sep 26 07:28:03 2003
++++ Makefile Sun Feb 1 18:23:29 2004
+@@ -1,10 +1,9 @@
+ HC_VERS = 0.28
+-INSTALL_PATH = /usr/local/bin
+-MAN_INSTALL_PATH = /usr/share/man/man1
++INSTALL_PATH = ${PREFIX}/bin
++MAN_INSTALL_PATH = ${PREFIX}/man/man1
+ MAKEDEPEND = makedepend
+-COPT = -O3
+ LDFLAGS = $(CARCH)
+-CFLAGS = $(COPT) $(CWARN) $(CARCH)
++CFLAGS += $(CWARN) $(CARCH)
+ EXES = hashcash sha1 sha1test
+ INSTALL = /usr/bin/install
+ POD2MAN = pod2man
diff --git a/mail/hashcash/files/patch-hashcash-h b/mail/hashcash/files/patch-hashcash-h
new file mode 100644
index 000000000000..42496fec9e37
--- /dev/null
+++ b/mail/hashcash/files/patch-hashcash-h
@@ -0,0 +1,19 @@
+*** hashcash.h~ Fri Sep 26 02:28:03 2003
+--- hashcash.h Fri Jan 30 14:13:22 2004
+***************
+*** 130,136 ****
+ /* simple function calling hashcash_parse, hashcash_count for convenience */
+
+ int hashcash_check( const char* token, const char* resource, time_t now_time,
+! time_t validity_period, long grace_period,
+ int required_bits );
+
+ /* return how many tries per second the machine can do */
+--- 130,136 ----
+ /* simple function calling hashcash_parse, hashcash_count for convenience */
+
+ int hashcash_check( const char* token, const char* resource, time_t now_time,
+! time_t validity_period, time_t grace_period,
+ int required_bits );
+
+ /* return how many tries per second the machine can do */
diff --git a/mail/hashcash/pkg-descr b/mail/hashcash/pkg-descr
new file mode 100644
index 000000000000..aee2f9f740a7
--- /dev/null
+++ b/mail/hashcash/pkg-descr
@@ -0,0 +1,4 @@
+The hashcash tool allows you to create hashcash tokens to attach to
+emails you send, and to verify hashcash tokens attached to emails you
+receive. A hashcash token constitutes a proof-of-work which takes a
+parameterizable amount of work to compute for the sender.
diff --git a/mail/hashcash/pkg-plist b/mail/hashcash/pkg-plist
new file mode 100644
index 000000000000..3a4b284ea95b
--- /dev/null
+++ b/mail/hashcash/pkg-plist
@@ -0,0 +1,2 @@
+bin/hashcash
+bin/sha1