aboutsummaryrefslogtreecommitdiff
path: root/mail/heirloom-mailx
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2010-05-11 22:05:32 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2010-05-11 22:05:32 +0000
commit0ccc4f67677fcd3f4b12e99a95b4a01195e50c0f (patch)
tree8c1784c4ab5f5d6b77fa05cc4f5d48c7a107f0d1 /mail/heirloom-mailx
parent14c1f32ea67e47d7f1fdf417736099abcc88d74b (diff)
downloadports-0ccc4f67677fcd3f4b12e99a95b4a01195e50c0f.tar.gz
ports-0ccc4f67677fcd3f4b12e99a95b4a01195e50c0f.zip
- Add a patch to fix "unignore" and similar commands
- Bump PORTREVISION PR: ports/146280 Submitted by: B. Smith <anon_101100 at yahoo.com> Obtained from: developers cvs
Notes
Notes: svn path=/head/; revision=254169
Diffstat (limited to 'mail/heirloom-mailx')
-rw-r--r--mail/heirloom-mailx/Makefile2
-rw-r--r--mail/heirloom-mailx/files/patch-cmd2.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/mail/heirloom-mailx/Makefile b/mail/heirloom-mailx/Makefile
index 604f2871c197..7f03f4adfb3e 100644
--- a/mail/heirloom-mailx/Makefile
+++ b/mail/heirloom-mailx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mailx
PORTVERSION= 12.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= SF/heirloom/heirloom-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= heirloom-
diff --git a/mail/heirloom-mailx/files/patch-cmd2.c b/mail/heirloom-mailx/files/patch-cmd2.c
new file mode 100644
index 000000000000..99441629030a
--- /dev/null
+++ b/mail/heirloom-mailx/files/patch-cmd2.c
@@ -0,0 +1,22 @@
+--- cmd2.c 2006/03/04 00:32:16 1.12
++++ cmd2.c 2010/05/09 21:50:54 1.13
+@@ -803,16 +803,17 @@
+ int h = hash(name);
+
+ for (ip = tab->i_head[h]; ip; ip = ip->i_link) {
+- if (asccasecmp(ip->i_field, name)) {
++ if (asccasecmp(ip->i_field, name) == 0) {
+ free(ip->i_field);
+ if (iq != NULL)
+ iq->i_link = ip->i_link;
+ else
+- tab->i_head[h] = NULL;
++ tab->i_head[h] = ip->i_link;
+ free(ip);
+ tab->i_count--;
+ break;
+ }
++ iq = ip;
+ }
+ }
+