aboutsummaryrefslogtreecommitdiff
path: root/mail/horde-imp
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-09-03 03:51:14 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-09-03 03:51:14 +0000
commit9f92454877bf2a113c0c245aec02d24e756f02aa (patch)
treec9c3a7743f6a5aa4c514b9104e9cf161b5f363d0 /mail/horde-imp
parente8e8ce1f5b1c0c5ebe3aca31530c5389ea1a0651 (diff)
downloadports-9f92454877bf2a113c0c245aec02d24e756f02aa.tar.gz
ports-9f92454877bf2a113c0c245aec02d24e756f02aa.zip
add support for some utilities
PR: 30269 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=47339
Diffstat (limited to 'mail/horde-imp')
-rw-r--r--mail/horde-imp/Makefile46
-rw-r--r--mail/horde-imp/pkg-descr2
2 files changed, 47 insertions, 1 deletions
diff --git a/mail/horde-imp/Makefile b/mail/horde-imp/Makefile
index a71d8c6bf25d..1a2a7e837621 100644
--- a/mail/horde-imp/Makefile
+++ b/mail/horde-imp/Makefile
@@ -8,6 +8,7 @@
PORTNAME= imp
PORTVERSION= 2.2.6
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/imp/tarballs/
@@ -17,9 +18,18 @@ MAINTAINER= thierry@thomas.as
# You may define these options:
#
# - WITHOUT_LDAP : if you do not need OpenLDAP;
+# - WITH_LDAP2 : if you prefer OpenLDAP2.
#
# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree;
#
+# - WITHOUT_WV : if your users never receive MS-Word docs;
+#
+# - WITHOUT_XL : if your users never receive MS-Excel sheets;
+#
+# - WITHOUT_ZIP : if not interested by zipinfo;
+#
+# - WITHOUT_ISPELL : for spelling bees...
+#
# - WITHOUT_IMAPSERVER : if your IMAP server runs on another machine;
#
# or you can select to work with one of these servers:
@@ -39,9 +49,14 @@ MAINTAINER= thierry@thomas.as
LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
.if !defined(WITHOUT_LDAP)
+.if defined(WITH_LDAP2)
+LIB_DEPENDS+= ldap.2:\${PORTSDIR}/net/openldap2 \
+ lber.2:\${PORTSDIR}/net/openldap2
+.else
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap \
lber.1:${PORTSDIR}/net/openldap
.endif
+.endif
RUN_DEPENDS+= ${LOCALBASE}/www/horde/:${PORTSDIR}/www/horde
@@ -65,6 +80,19 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/libacap.a:${PORTSDIR}/mail/cyrus-imapd
.endif
.endif
+.if !defined(WITHOUT_WV)
+RUN_DEPENDS+= ${LOCALBASE}/bin/wvHtml:${PORTSDIR}/textproc/wv
+.endif
+.if !defined(WITHOUT_XL)
+RUN_DEPENDS+= ${LOCALBASE}/bin/xlHtml:${PORTSDIR}/textproc/xlhtml
+.endif
+.if !defined(WITHOUT_ZIP)
+RUN_DEPENDS+= ${LOCALBASE}/bin/zipinfo:${PORTSDIR}/archivers/unzip
+.endif
+.if !defined(WITHOUT_ISPELL)
+RUN_DEPENDS+= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
+.endif
+
NO_BUILD= yes
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/DATABASE \
docs/HELP docs/INSTALL docs/SECURITY docs/KNOWN_BUGS \
@@ -95,6 +123,14 @@ pre-install:
${FALSE} ; \
fi
.if !defined(WITHOUT_LDAP)
+.if defined(WITH_LDAP2)
+ @if ! ${LDCONFIG} -r | ${GREP} -q -e "ldap.2"; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "Please configure PHP with OpenLDAP2 support." ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
+.else
@if ! ${LDCONFIG} -r | ${GREP} -q -e "ldap.1"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
@@ -102,6 +138,7 @@ pre-install:
${FALSE} ; \
fi
.endif
+.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
@@ -127,6 +164,15 @@ do-install:
${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${IMPDIR}
${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${IMPDIR}
${CP} -p ${WRKSRC}/*.php3 ${WRKSRC}/*.css ${IMPDIR}
+ ${PERL} -pi -e "s:/usr/bin/ispell:${LOCALBASE}/bin/ispell:g" \
+ ${IMPDIR}/config/defaults.php3.dist
+ ${PERL} -pi -e "s:/usr/bin/wvHtml:${LOCALBASE}/bin/wvHtml:g" \
+ ${IMPDIR}/config/defaults.php3.dist
+ ${PERL} -pi -e "s:/usr/bin/xlHtml:${LOCALBASE}/bin/xlHtml:g" \
+ ${IMPDIR}/config/defaults.php3.dist
+ ${PERL} -pi -e "s:/bin/tar:/usr/bin/tar:g" ${IMPDIR}/config/defaults.php3.dist
+ ${PERL} -pi -e "s:/usr/bin/zipinfo:${LOCALBASE}/bin/zipinfo:g" \
+ ${IMPDIR}/config/defaults.php3.dist
@if [ ! -f ${IMPDIR}/config/defaults.php3 ]; then \
${CP} ${IMPDIR}/config/defaults.php3.dist ${IMPDIR}/config/defaults.php3; \
fi
diff --git a/mail/horde-imp/pkg-descr b/mail/horde-imp/pkg-descr
index ea7fa4003ecd..57770f046f84 100644
--- a/mail/horde-imp/pkg-descr
+++ b/mail/horde-imp/pkg-descr
@@ -1,7 +1,7 @@
IMP is a set of PHP scripts that implement an IMAP based webmail system.
Assuming you have an account on a server that supports IMAP, you can use
an installation of IMP to check your mail from anywhere that you have web
-access.
+access.
WWW: http://www.horde.org/imp/