aboutsummaryrefslogtreecommitdiff
path: root/mail/horde4-ingo
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
commite23ee358fa1ac94e411715abac088791dc154c19 (patch)
tree2f2d07d89e8f9b0b1bbbaa61fc0a3c53d8b1308c /mail/horde4-ingo
parent8931540e0ace91aa22d2f957ccaefa11eb78adca (diff)
downloadports-e23ee358fa1ac94e411715abac088791dc154c19.tar.gz
ports-e23ee358fa1ac94e411715abac088791dc154c19.zip
- Replace WITH_APACHE2 by USE_APACHE, rename httpd.conf.xxx to
httpd-xxx.conf and fix configuration if APACHE_VERSION > 20. - Don't use the MCAL back-end by default for Kronolith, it is deprecated. - Deinstall bug reported by John Nielsen <john (at) jnielsen.net>: respect LHORDEDIR. - Fix horde-passwd installation / deinstallation. - Don't bump PORTREVISION, because running installations are not concerned.
Notes
Notes: svn path=/head/; revision=152847
Diffstat (limited to 'mail/horde4-ingo')
-rw-r--r--mail/horde4-ingo/Makefile21
-rw-r--r--mail/horde4-ingo/distinfo1
-rw-r--r--mail/horde4-ingo/files/pkg-deinstall.in (renamed from mail/horde4-ingo/pkg-deinstall)2
-rw-r--r--mail/horde4-ingo/pkg-plist2
4 files changed, 16 insertions, 10 deletions
diff --git a/mail/horde4-ingo/Makefile b/mail/horde4-ingo/Makefile
index df75e4b751e7..da02cc019ff6 100644
--- a/mail/horde4-ingo/Makefile
+++ b/mail/horde4-ingo/Makefile
@@ -33,10 +33,13 @@ RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
NO_BUILD= yes
USE_PHP= imap
-USE_REINPLACE= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
-PLIST_SUB= INGODIR=${LINGODIR}
+PLIST_SUB= INGODIR=${LINGODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-deinstall
+SUB_LIST= INGODIR=${INGODIR}
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
docs/RELEASE_NOTES docs/TODO
@@ -50,17 +53,21 @@ PEARDIR?= ${LOCALBASE}/share/pear
INGODIR= ${PREFIX}/${LINGODIR}
CONFDIR= ${INGODIR}/config
-HORDE_INC= ${LOCALBASE}/etc/horde
-
.include <bsd.port.pre.mk>
.if defined(WITH_SIEVE) || exists(${LOCALBASE}/cyrus/bin/timsieved)
RUN_DEPENDS+= ${PEARDIR}/Net/Sieve.php:${PORTSDIR}/net/pear-Net_Sieve
.endif
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
+.else
+HORDE_INC= ${LOCALBASE}/etc/horde
+.endif
+
pre-configure:
@${SED} -e "s:/home/httpd/html/horde/ingo:${INGODIR}:g" \
- ${FILESDIR}/httpd.conf.ingo >${WRKDIR}/httpd.conf.ingo
+ ${FILESDIR}/httpd.conf.ingo >${WRKDIR}/httpd-ingo.conf
do-install:
@${MKDIR} ${INGODIR}
@@ -75,7 +82,7 @@ do-install:
.endfor
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${INGODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd.conf.ingo ${HORDE_INC}
+ @${INSTALL_DATA} ${WRKDIR}/httpd-ingo.conf ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -85,8 +92,6 @@ do-install:
.endif
post-install:
- @${SED} -e "s:%%INGODIR%%:${INGODIR}:g;s:%%DOCSDIR%%:${DOCSDIR}:g" \
- < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/mail/horde4-ingo/distinfo b/mail/horde4-ingo/distinfo
index 00afb90f937c..1957b3b5ced9 100644
--- a/mail/horde4-ingo/distinfo
+++ b/mail/horde4-ingo/distinfo
@@ -1,2 +1,3 @@
MD5 (ingo-h3-1.0.2.tar.gz) = 6bc7addfdd3bc18e4d6af5c1d57b7b89
+SHA256 (ingo-h3-1.0.2.tar.gz) = 6bd8d05f986c5b3d58065f7409b9df0912ace8968ed427798497bfd376bb1d29
SIZE (ingo-h3-1.0.2.tar.gz) = 853202
diff --git a/mail/horde4-ingo/pkg-deinstall b/mail/horde4-ingo/files/pkg-deinstall.in
index a3a597d448a6..2289e8963491 100644
--- a/mail/horde4-ingo/pkg-deinstall
+++ b/mail/horde4-ingo/files/pkg-deinstall.in
@@ -9,7 +9,7 @@ if [ x$2 != xDEINSTALL ]; then
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls ${PKG_PREFIX}/www/horde/ingo/config/*php`; do
+ for cf in `ls %%INGODIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
0) # original config file, will be deleted by pkg-plist
diff --git a/mail/horde4-ingo/pkg-plist b/mail/horde4-ingo/pkg-plist
index b288edddd002..697fac19d784 100644
--- a/mail/horde4-ingo/pkg-plist
+++ b/mail/horde4-ingo/pkg-plist
@@ -1,4 +1,4 @@
-etc/horde/httpd.conf.ingo
+%%HORDE_INC%%/httpd-ingo.conf
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/CREDITS