aboutsummaryrefslogtreecommitdiff
path: root/mail/horde4-turba
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-28 20:09:08 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-28 20:09:08 +0000
commit16ecb0ec8abbb1533105fe6698c31058904401b1 (patch)
treeafbea81a9e0d4d6929cb4b3dea9beb9edcb36533 /mail/horde4-turba
parentbdd17e317f7d5da3ae4a440d3149fcd4c7cba769 (diff)
downloadports-16ecb0ec8abbb1533105fe6698c31058904401b1.tar.gz
ports-16ecb0ec8abbb1533105fe6698c31058904401b1.zip
- Update to 2.2-rc3
- Many changes, please see the following: http://www.horde.org/turba/docs/?f=CHANGES.html
Notes
Notes: svn path=/head/; revision=208125
Diffstat (limited to 'mail/horde4-turba')
-rw-r--r--mail/horde4-turba/Makefile3
-rw-r--r--mail/horde4-turba/distinfo6
-rw-r--r--mail/horde4-turba/files/patch-config::sources.php.dist85
-rw-r--r--mail/horde4-turba/pkg-plist303
4 files changed, 244 insertions, 153 deletions
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index 8cee3fb6a1e9..3282a017c37a 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= turba
-PORTVERSION= 2.1.7
+PORTVERSION= 2.2
+DISTVERSIONSUFFIX= -rc3
CATEGORIES= mail www
MAINTAINER= beech@FreeBSD.org
diff --git a/mail/horde4-turba/distinfo b/mail/horde4-turba/distinfo
index 4505463cf015..af3a09b619c2 100644
--- a/mail/horde4-turba/distinfo
+++ b/mail/horde4-turba/distinfo
@@ -1,3 +1,3 @@
-MD5 (turba-h3-2.1.7.tar.gz) = 9cde9a44239c852211204112f3d6edfe
-SHA256 (turba-h3-2.1.7.tar.gz) = 1e0c13bcc32e3b094b889e844879598e7a7967a394ede2cbe538a894a13ac92d
-SIZE (turba-h3-2.1.7.tar.gz) = 1868115
+MD5 (turba-h3-2.2-rc3.tar.gz) = 2c44c85510b7b24599a725ca0271fc25
+SHA256 (turba-h3-2.2-rc3.tar.gz) = 0641a5f9603b80f4eb6b5b9932179ce03251ba115be8bc5103e8ba8cf432b822
+SIZE (turba-h3-2.2-rc3.tar.gz) = 2158573
diff --git a/mail/horde4-turba/files/patch-config::sources.php.dist b/mail/horde4-turba/files/patch-config::sources.php.dist
index 52bf06d5d79c..aeb73b0e369d 100644
--- a/mail/horde4-turba/files/patch-config::sources.php.dist
+++ b/mail/horde4-turba/files/patch-config::sources.php.dist
@@ -1,24 +1,19 @@
---- config/sources.php.dist.orig Mon Nov 7 11:03:26 2005
-+++ config/sources.php.dist Wed Mar 8 23:18:05 2006
-@@ -490,109 +490,109 @@
+--- config/sources.php.dist.orig 2007-11-19 08:05:01.000000000 -0900
++++ config/sources.php.dist 2007-12-03 23:35:17.000000000 -0900
+@@ -636,105 +636,108 @@
// configuration at all - in case we don't have at least a 3.0.6 Horde
// install. (In that case, be sure to change the params array below to suit
- // your needs).
+ // your needs.
-if (!empty($GLOBALS['conf']['imsp']['enabled']) ||
- !isset($GLOBALS['conf']['imsp']['enabled'])) {
- // First, get the user name to login to IMSP server with.
-- $uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
-- $pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
-- if (!strlen($uid)) {
-- $uid = Auth::getBareAuth();
-- $pass = Auth::getCredential('password');
+- $_imsp_auth_user = $GLOBALS['prefs']->getValue('imsp_auth_user');
+- $_imsp_auth_pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
+- if (!strlen($_imsp_auth_user)) {
+- $_imsp_auth_user = Auth::getBareAuth();
+- $_imsp_auth_pass = Auth::getCredential('password');
- }
-- // Note we always use the horde username to append to the key even if we
-- // have an alternate username set in prefs. This is to prevent the
-- // (fringe) case where an IMSP username for one user might be a valid
-- // horde username for another user.
-- $cfgKey = 'IMSP_' . Auth::getAuth();
-- $cfgSources[$cfgKey] = array(
+- $cfgSources['imsp'] = array(
- 'title' => _("IMSP"),
- 'type' => 'imsp',
- 'params' => array(
@@ -27,22 +22,20 @@
- 'auth_method' => $GLOBALS['conf']['imsp']['auth_method'],
- // socket, command, and auth_mechanism are for imtest driver.
- 'socket' => isset($GLOBALS['conf']['imsp']['socket']) ?
-- $GLOBALS['conf']['imsp']['socket'] . $uid . '.sck' :
+- $GLOBALS['conf']['imsp']['socket'] . $_imsp_auth_user . '.sck' :
- '',
- 'command' => isset($GLOBALS['conf']['imsp']['command']) ?
- $GLOBALS['conf']['imsp']['command'] : '' ,
- 'auth_mechanism' => isset($GLOBALS['conf']['imsp']['auth_mechanism']) ?
- $GLOBALS['conf']['imsp']['auth_mechanism'] : '',
-- 'username' => $uid,
-- 'password' => $pass,
-- 'name' => $uid,
+- 'username' => $_imsp_auth_user,
+- 'password' => $_imsp_auth_pass,
+- 'name' => $_imsp_auth_user,
- 'group_id_field' => 'group',
- 'group_id_value' => 'group',
- 'contact_ownership' => false,
- // Dynamically generated acl rights for current user.
- 'my_rights' => '',
-- // Flags this as the user's 'root' IMSP address book.
-- 'is_root' => true
- ),
- 'map' => array(
- '__key' => 'name',
@@ -71,6 +64,7 @@
- 'strict' => array(),
- 'export' => true,
- 'browse' => true,
+- 'use_shares' => false,
- );
-
- /**
@@ -80,32 +74,34 @@
- * book above. Any entries defined explicitly in cfgSources[]
- * will override any entries gathered dynamically below.
- */
-- require_once 'Net/IMSP/Utils.php';
-- $result = Net_IMSP_Utils::getAllBooks($cfgSources[$cfgKey]);
-- $count = 2;
-- if (!is_a($result, 'PEAR_Error')) {
-- $resultCount = count($result);
-- for ($i = 0; $i < $resultCount; $i++) {
-- // Make sure we didn't define this source explicitly,
-- // but set the acls from the server regardless.
-- $dup = false;
-- foreach ($cfgSources as $key => $thisSource) {
-- if (($thisSource['type'] == 'imsp') &&
-- ($thisSource['params']['name'] == $result[$i]['params']['name'])) {
+- if (empty($cfgSources['imsp']['use_shares'])) {
+- require_once 'Net/IMSP/Utils.php';
+- $result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
-
-- $dup = true;
-- $acl = $result[$i]['params']['my_rights'];
-- $cfgSources[$key]['params']['my_rights'] = $acl;
-- break;
+- if (!is_a($result, 'PEAR_Error')) {
+- $resultCount = count($result);
+- for ($i = 0; $i < $resultCount; $i++) {
+- // Make sure we didn't define this source explicitly,
+- // but set the acls from the server regardless.
+- $dup = false;
+- foreach ($cfgSources as $key => $thisSource) {
+- if (($thisSource['type'] == 'imsp') &&
+- ($thisSource['params']['name'] == $result[$i]['params']['name'])) {
+-
+- $dup = true;
+- $acl = $result[$i]['params']['my_rights'];
+- $cfgSources[$key]['params']['my_rights'] = $acl;
+- break;
+- }
+- }
+- if (!$dup) {
+- $cfgSources[$result[$i]['params']['name']] = $result[$i];
- }
- }
-- if (!$dup) {
-- $cfgSources[sprintf('IMSP_%d', $count++)] = $result[$i];
-- }
+- } else {
+- $notification->push($result);
- }
-- } else {
-- $notification->push($result);
-- }
+- }
-}
+//UNCOMMENTIFIMSPif (!empty($GLOBALS['conf']['imsp']['enabled']) ||
+//UNCOMMENTIFIMSP !isset($GLOBALS['conf']['imsp']['enabled'])) {
@@ -167,8 +163,7 @@
+//UNCOMMENTIFIMSP 'search' => array(
+//UNCOMMENTIFIMSP 'name',
+//UNCOMMENTIFIMSP 'email',
-+//UNCOMMENTIFIMSP 'alias',
-+//UNCOMMENTIFIMSP 'company',
++//UNCOMMENTIFIMSP 'alias',+//UNCOMMENTIFIMSP 'company',
+//UNCOMMENTIFIMSP 'homePhone'
+//UNCOMMENTIFIMSP ),
+//UNCOMMENTIFIMSP 'strict' => array(),
diff --git a/mail/horde4-turba/pkg-plist b/mail/horde4-turba/pkg-plist
index 33db5246d4b2..29c830b771a3 100644
--- a/mail/horde4-turba/pkg-plist
+++ b/mail/horde4-turba/pkg-plist
@@ -1,39 +1,87 @@
%%HORDIR%%/add.php
-%%HORDIR%%/addressbooks.php
+%%HORDIR%%/addressbooks/create.php
+%%HORDIR%%/addressbooks/delete.php
+%%HORDIR%%/addressbooks/edit.php
+%%HORDIR%%/addressbooks/index.php
%%HORDIR%%/browse.php
%%HORDIR%%/config/.htaccess
%%HORDIR%%/config/attributes.php.dist
%%HORDIR%%/config/conf.xml
+%%HORDIR%%/config/hooks.php.dist
%%HORDIR%%/config/menu.php.dist
%%HORDIR%%/config/mime_drivers.php.dist
%%HORDIR%%/config/prefs.php.dist
%%HORDIR%%/config/sources.php.dist
+%%HORDIR%%/contact.php
%%HORDIR%%/data.php
%%HORDIR%%/delete.php
-%%HORDIR%%/display.php
+%%HORDIR%%/deletefile.php
%%HORDIR%%/edit.php
%%HORDIR%%/index.php
+%%HORDIR%%/js/QuickFinder.js
+%%HORDIR%%/js/contact_tabs.js
+%%HORDIR%%/js/effects.js
+%%HORDIR%%/js/prototype.js
+%%HORDIR%%/js/redbox.js
+%%HORDIR%%/js/scriptaculous.js
+%%HORDIR%%/js/src/QuickFinder.js
+%%HORDIR%%/js/src/contact_tabs.js
+%%HORDIR%%/js/src/effects.js
+%%HORDIR%%/js/src/prototype.js
+%%HORDIR%%/js/src/redbox.js
+%%HORDIR%%/js/src/scriptaculous.js
+%%HORDIR%%/js/src/tables.js
+%%HORDIR%%/js/tables.js
%%HORDIR%%/lib/.htaccess
%%HORDIR%%/lib/Block/minisearch.php
%%HORDIR%%/lib/Block/tree_menu.php
+%%HORDIR%%/lib/Data/ldif.php
+%%HORDIR%%/lib/Driver.php
+%%HORDIR%%/lib/Driver/favourites.php
+%%HORDIR%%/lib/Driver/group.php
%%HORDIR%%/lib/Driver/imsp.php
%%HORDIR%%/lib/Driver/kolab.php
%%HORDIR%%/lib/Driver/ldap.php
%%HORDIR%%/lib/Driver/null.php
%%HORDIR%%/lib/Driver/prefs.php
+%%HORDIR%%/lib/Driver/share.php
%%HORDIR%%/lib/Driver/sql.php
-%%HORDIR%%/lib/Driver.php
+%%HORDIR%%/lib/Driver/vbook.php
+%%HORDIR%%/lib/Forms/AddContact.php
+%%HORDIR%%/lib/Forms/Contact.php
+%%HORDIR%%/lib/Forms/CreateAddressBook.php
+%%HORDIR%%/lib/Forms/DeleteAddressBook.php
+%%HORDIR%%/lib/Forms/EditAddressBook.php
+%%HORDIR%%/lib/Forms/EditContact.php
%%HORDIR%%/lib/Group.php
%%HORDIR%%/lib/List.php
%%HORDIR%%/lib/ListView.php
-%%HORDIR%%/lib/Object/Group.php
+%%HORDIR%%/lib/Maintenance/Task/upgradelists.php
+%%HORDIR%%/lib/Maintenance/Task/upgradeprefs.php
%%HORDIR%%/lib/Object.php
-%%HORDIR%%/lib/ObjectView.php
-%%HORDIR%%/lib/Renderer.php
+%%HORDIR%%/lib/Object/Group.php
%%HORDIR%%/lib/Turba.php
+%%HORDIR%%/lib/Views/Browse.php
+%%HORDIR%%/lib/Views/Contact.php
+%%HORDIR%%/lib/Views/DeleteContact.php
+%%HORDIR%%/lib/Views/EditContact.php
%%HORDIR%%/lib/api.php
%%HORDIR%%/lib/base.php
%%HORDIR%%/lib/prefs.php
+%%HORDIR%%/lib/tests/ApiTest.php
+%%HORDIR%%/lib/tests/BrowsePageTest.php
+%%HORDIR%%/lib/tests/DriverTest.php
+%%HORDIR%%/lib/tests/GroupTest.php
+%%HORDIR%%/lib/tests/ListTest.php
+%%HORDIR%%/lib/tests/ListViewTest.php
+%%HORDIR%%/lib/tests/TestBase.php
+%%HORDIR%%/lib/tests/ViewBrowseTest.php
+%%HORDIR%%/lib/tests/import.ldif
+%%HORDIR%%/lib/tests/importCRLF.ldif
+%%HORDIR%%/lib/tests/ldif_exportFile.phpt
+%%HORDIR%%/lib/tests/ldif_importFile.phpt
+%%HORDIR%%/lib/tests/ldif_importFileCRLF.phpt
+%%HORDIR%%/lib/tests/tohash.phpt
%%HORDIR%%/lib/tests/tovcard.phpt
%%HORDIR%%/lib/version.php
%%HORDIR%%/locale/.htaccess
@@ -126,150 +174,197 @@
%%HORDIR%%/po/zh_TW.po
%%HORDIR%%/scripts/.htaccess
%%HORDIR%%/scripts/Turba.reg
+%%HORDIR%%/scripts/import_squirrelmail_abook.php
%%HORDIR%%/scripts/import_vcards.php
%%HORDIR%%/scripts/ldap/addou
%%HORDIR%%/scripts/ldap/addou.pl
%%HORDIR%%/scripts/ldap/core.schema.patch
%%HORDIR%%/scripts/ldap/rfc2739.schema
-%%HORDIR%%/scripts/sql/turba.oci8.sql
-%%HORDIR%%/scripts/sql/turba.xml
+%%HORDIR%%/scripts/sql/test.xml
%%HORDIR%%/scripts/sql/turba.mssql.sql
-%%HORDIR%%/scripts/sql/turba.sql
+%%HORDIR%%/scripts/sql/turba.oci8.sql
%%HORDIR%%/scripts/sql/turba.pgsql.sql
-%%HORDIR%%/scripts/sql/turba.mysql.sql
+%%HORDIR%%/scripts/sql/turba.sql
+%%HORDIR%%/scripts/sql/turba.xml
%%HORDIR%%/scripts/sql/turba_weddingguests.sql
%%HORDIR%%/scripts/upgrades/1.1_to_1.2.sql
%%HORDIR%%/scripts/upgrades/1.2_to_2.0.oci8.sql
%%HORDIR%%/scripts/upgrades/1.2_to_2.0.sql
+%%HORDIR%%/scripts/upgrades/2.1_to_2.2_sql_schema.php
+%%HORDIR%%/scripts/upgrades/2007-06-17_flatten_shares.php
%%HORDIR%%/scripts/upgrades/create_default_histories.php
%%HORDIR%%/scripts/upgrades/public_to_horde_share.php
%%HORDIR%%/search.php
%%HORDIR%%/templates/.htaccess
-%%HORDIR%%/templates/addressbooks.inc
+%%HORDIR%%/templates/addressbook_list.php
%%HORDIR%%/templates/block/minisearch.inc
%%HORDIR%%/templates/browse/actions.inc
%%HORDIR%%/templates/browse/column_footers.inc
%%HORDIR%%/templates/browse/column_headers.inc
%%HORDIR%%/templates/browse/contactrow.inc
-%%HORDIR%%/templates/browse/footer.inc
-%%HORDIR%%/templates/browse/footerAlpha.inc
%%HORDIR%%/templates/browse/header.inc
%%HORDIR%%/templates/browse/javascript.inc
%%HORDIR%%/templates/browse/row.inc
%%HORDIR%%/templates/browse/search.inc
%%HORDIR%%/templates/browse/search_criteria.inc
+%%HORDIR%%/templates/browse/search_vbook.inc
%%HORDIR%%/templates/common-header.inc
%%HORDIR%%/templates/data/export.inc
%%HORDIR%%/templates/data/import.inc
+%%HORDIR%%/templates/list/alphaPager.inc
+%%HORDIR%%/templates/list/numPager.inc
%%HORDIR%%/templates/menu.inc
%%HORDIR%%/templates/prefs/addressbookselect.inc
%%HORDIR%%/templates/prefs/columnselect.inc
%%HORDIR%%/templates/prefs/imsp_opt.inc
%%HORDIR%%/test.php
+%%HORDIR%%/themes/bluewhite/screen.css
+%%HORDIR%%/themes/graphics/az.png
+%%HORDIR%%/themes/graphics/az_secondary.png
%%HORDIR%%/themes/graphics/contact.png
%%HORDIR%%/themes/graphics/favicon.ico
%%HORDIR%%/themes/graphics/group.png
%%HORDIR%%/themes/graphics/menu/browse.png
%%HORDIR%%/themes/graphics/menu/new.png
%%HORDIR%%/themes/graphics/new.png
+%%HORDIR%%/themes/graphics/redbox_spinner.gif
+%%HORDIR%%/themes/graphics/search.png
%%HORDIR%%/themes/graphics/turba.png
+%%HORDIR%%/themes/graphics/za.png
+%%HORDIR%%/themes/graphics/za_secondary.png
%%HORDIR%%/themes/ideas/screen.css
%%HORDIR%%/themes/screen.css
+%%HORDIR%%/themes/silver/graphics/az_secondary.png
+%%HORDIR%%/themes/silver/graphics/contact.png
+%%HORDIR%%/themes/silver/graphics/favicon.ico
+%%HORDIR%%/themes/silver/graphics/group.png
+%%HORDIR%%/themes/silver/graphics/menu/browse.png
+%%HORDIR%%/themes/silver/graphics/menu/new.png
+%%HORDIR%%/themes/silver/graphics/new.png
+%%HORDIR%%/themes/silver/graphics/turba.png
+%%HORDIR%%/themes/silver/graphics/za_secondary.png
+%%HORDIR%%/themes/silver/themed_graphics
+%%HORDIR%%/themes/tango-blue/graphics/az_secondary.png
+%%HORDIR%%/themes/tango-blue/graphics/contact.png
+%%HORDIR%%/themes/tango-blue/graphics/favicon.ico
+%%HORDIR%%/themes/tango-blue/graphics/group.png
+%%HORDIR%%/themes/tango-blue/graphics/menu/browse.png
+%%HORDIR%%/themes/tango-blue/graphics/menu/new.png
+%%HORDIR%%/themes/tango-blue/graphics/new.png
+%%HORDIR%%/themes/tango-blue/graphics/turba.png
+%%HORDIR%%/themes/tango-blue/graphics/za_secondary.png
+%%HORDIR%%/themes/tango-blue/themed_graphics
%%HORDIR%%/vcard.php
%%HORDIR%%/view.php
-@dirrmtry %%HORDIR%%/config
-@dirrm %%HORDIR%%/lib/Block
-@dirrm %%HORDIR%%/lib/Driver
-@dirrm %%HORDIR%%/lib/Object
-@dirrm %%HORDIR%%/lib/tests
-@dirrm %%HORDIR%%/lib
-@dirrm %%HORDIR%%/locale/ar_SY/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ar_SY
-@dirrm %%HORDIR%%/locale/bg_BG/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/bg_BG
-@dirrm %%HORDIR%%/locale/ca_ES/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ca_ES
-@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/cs_CZ
-@dirrm %%HORDIR%%/locale/da_DK/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/da_DK
-@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/de_DE
-@dirrm %%HORDIR%%/locale/el_GR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/el_GR
-@dirrm %%HORDIR%%/locale/en_US
-@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/es_ES
-@dirrm %%HORDIR%%/locale/et_EE/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/et_EE
-@dirrm %%HORDIR%%/locale/fa_IR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/fa_IR
-@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/fi_FI
-@dirrm %%HORDIR%%/locale/fr_FR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/fr_FR
-@dirrm %%HORDIR%%/locale/gl_ES/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/gl_ES
-@dirrm %%HORDIR%%/locale/hu_HU/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/hu_HU
-@dirrm %%HORDIR%%/locale/is_IS/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/is_IS
-@dirrm %%HORDIR%%/locale/it_IT/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/it_IT
-@dirrm %%HORDIR%%/locale/ja_JP/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ja_JP
-@dirrm %%HORDIR%%/locale/ko_KR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ko_KR
-@dirrm %%HORDIR%%/locale/lt_LT/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/lt_LT
-@dirrm %%HORDIR%%/locale/lv_LV/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/lv_LV
-@dirrm %%HORDIR%%/locale/mk_MK/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/mk_MK
-@dirrm %%HORDIR%%/locale/nb_NO/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/nb_NO
-@dirrm %%HORDIR%%/locale/nl_NL/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/nl_NL
-@dirrm %%HORDIR%%/locale/nn_NO/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/nn_NO
-@dirrm %%HORDIR%%/locale/pl_PL/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/pl_PL
-@dirrm %%HORDIR%%/locale/pt_BR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/pt_BR
-@dirrm %%HORDIR%%/locale/pt_PT/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/pt_PT
-@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ro_RO
-@dirrm %%HORDIR%%/locale/ru_RU/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ru_RU
-@dirrm %%HORDIR%%/locale/sk_SK/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/sk_SK
-@dirrm %%HORDIR%%/locale/sl_SI/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/sl_SI
-@dirrm %%HORDIR%%/locale/sv_SE/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/sv_SE
-@dirrm %%HORDIR%%/locale/tr_TR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/tr_TR
-@dirrm %%HORDIR%%/locale/uk_UA/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/uk_UA
-@dirrm %%HORDIR%%/locale/zh_CN/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/zh_CN
-@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/zh_TW
-@dirrm %%HORDIR%%/locale
-@dirrm %%HORDIR%%/po
-@dirrm %%HORDIR%%/scripts/ldap
-@dirrm %%HORDIR%%/scripts/sql
-@dirrm %%HORDIR%%/scripts/upgrades
-@dirrm %%HORDIR%%/scripts
-@dirrm %%HORDIR%%/templates/block
-@dirrm %%HORDIR%%/templates/browse
-@dirrm %%HORDIR%%/templates/data
-@dirrm %%HORDIR%%/templates/prefs
-@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/themes/tango-blue/graphics/menu
+@dirrm %%HORDIR%%/themes/tango-blue/graphics
+@dirrm %%HORDIR%%/themes/tango-blue
+@dirrm %%HORDIR%%/themes/silver/graphics/menu
+@dirrm %%HORDIR%%/themes/silver/graphics
+@dirrm %%HORDIR%%/themes/silver
+@dirrm %%HORDIR%%/themes/ideas
@dirrm %%HORDIR%%/themes/graphics/menu
@dirrm %%HORDIR%%/themes/graphics
-@dirrm %%HORDIR%%/themes/ideas
+@dirrm %%HORDIR%%/themes/bluewhite
@dirrm %%HORDIR%%/themes
+@dirrm %%HORDIR%%/templates/prefs
+@dirrm %%HORDIR%%/templates/list
+@dirrm %%HORDIR%%/templates/data
+@dirrm %%HORDIR%%/templates/browse
+@dirrm %%HORDIR%%/templates/block
+@dirrm %%HORDIR%%/templates
+@dirrm %%HORDIR%%/scripts/upgrades
+@dirrm %%HORDIR%%/scripts/sql
+@dirrm %%HORDIR%%/scripts/ldap
+@dirrm %%HORDIR%%/scripts
+@dirrm %%HORDIR%%/po
+@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_TW
+@dirrm %%HORDIR%%/locale/zh_CN/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/zh_CN
+@dirrm %%HORDIR%%/locale/uk_UA/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/uk_UA
+@dirrm %%HORDIR%%/locale/tr_TR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/tr_TR
+@dirrm %%HORDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sv_SE
+@dirrm %%HORDIR%%/locale/sl_SI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sl_SI
+@dirrm %%HORDIR%%/locale/sk_SK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/sk_SK
+@dirrm %%HORDIR%%/locale/ru_RU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ru_RU
+@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ro_RO
+@dirrm %%HORDIR%%/locale/pt_PT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_PT
+@dirrm %%HORDIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pt_BR
+@dirrm %%HORDIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/pl_PL
+@dirrm %%HORDIR%%/locale/nn_NO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nn_NO
+@dirrm %%HORDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nl_NL
+@dirrm %%HORDIR%%/locale/nb_NO/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/nb_NO
+@dirrm %%HORDIR%%/locale/mk_MK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/mk_MK
+@dirrm %%HORDIR%%/locale/lv_LV/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/lv_LV
+@dirrm %%HORDIR%%/locale/lt_LT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/lt_LT
+@dirrm %%HORDIR%%/locale/ko_KR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ko_KR
+@dirrm %%HORDIR%%/locale/ja_JP/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ja_JP
+@dirrm %%HORDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/it_IT
+@dirrm %%HORDIR%%/locale/is_IS/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/is_IS
+@dirrm %%HORDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/hu_HU
+@dirrm %%HORDIR%%/locale/gl_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/gl_ES
+@dirrm %%HORDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fr_FR
+@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fi_FI
+@dirrm %%HORDIR%%/locale/fa_IR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/fa_IR
+@dirrm %%HORDIR%%/locale/et_EE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/et_EE
+@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/es_ES
+@dirrm %%HORDIR%%/locale/en_US
+@dirrm %%HORDIR%%/locale/el_GR/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/el_GR
+@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/de_DE
+@dirrm %%HORDIR%%/locale/da_DK/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/da_DK
+@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/cs_CZ
+@dirrm %%HORDIR%%/locale/ca_ES/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ca_ES
+@dirrm %%HORDIR%%/locale/bg_BG/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/bg_BG
+@dirrm %%HORDIR%%/locale/ar_SY/LC_MESSAGES
+@dirrm %%HORDIR%%/locale/ar_SY
+@dirrm %%HORDIR%%/locale
+@dirrm %%HORDIR%%/lib/tests
+@dirrm %%HORDIR%%/lib/Views
+@dirrm %%HORDIR%%/lib/Object
+@dirrm %%HORDIR%%/lib/Maintenance/Task
+@dirrm %%HORDIR%%/lib/Maintenance
+@dirrm %%HORDIR%%/lib/Forms
+@dirrm %%HORDIR%%/lib/Driver
+@dirrm %%HORDIR%%/lib/Data
+@dirrm %%HORDIR%%/lib/Block
+@dirrm %%HORDIR%%/lib
+@dirrm %%HORDIR%%/js/src
+@dirrm %%HORDIR%%/js
+@dirrm %%HORDIR%%/addressbooks
+@dirrmtry %%HORDIR%%/config
@dirrmtry %%HORDIR%%
@dirrmtry %%HORBAS%%