aboutsummaryrefslogtreecommitdiff
path: root/mail/ifile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:41:33 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:41:33 +0000
commit97cde34830e799a992fb44166190303e823cf7de (patch)
tree9289e51e8add4eb05fef43074ee2fc38b0052d12 /mail/ifile
parent51de64b4e763b7f2565cbbc9cfbef7e6e052a792 (diff)
downloadports-97cde34830e799a992fb44166190303e823cf7de.tar.gz
ports-97cde34830e799a992fb44166190303e823cf7de.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. use getopt_long() instead of getopt_long_only(). Obtained from: NetBSD
Notes
Notes: svn path=/head/; revision=84840
Diffstat (limited to 'mail/ifile')
-rw-r--r--mail/ifile/Makefile8
-rw-r--r--mail/ifile/files/patch-Makefile.in11
-rw-r--r--mail/ifile/files/patch-argp_argp.h11
3 files changed, 24 insertions, 6 deletions
diff --git a/mail/ifile/Makefile b/mail/ifile/Makefile
index e3425f009e76..cbba689e1a6c 100644
--- a/mail/ifile/Makefile
+++ b/mail/ifile/Makefile
@@ -7,21 +7,17 @@
PORTNAME= ifile
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= mail textproc
MASTER_SITES= http://savannah.nongnu.org/download/ifile/default.pkg/${PORTVERSION}/
MAINTAINER= david+ports@bushong.net
COMMENT= An application of machine learning to e-mail filtering
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= ifile.1
-post-patch:
- @${REINPLACE_CMD} -e 's,-lm,-lm -L${LOCALBASE}/lib -lgnugetopt,' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>
diff --git a/mail/ifile/files/patch-Makefile.in b/mail/ifile/files/patch-Makefile.in
new file mode 100644
index 000000000000..eaf6dcf7bcff
--- /dev/null
+++ b/mail/ifile/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue Jun 10 23:09:27 2003
++++ Makefile.in Mon Jul 7 06:50:51 2003
+@@ -46,7 +46,7 @@
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
+ INCLUDEFLAGS =
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
diff --git a/mail/ifile/files/patch-argp_argp.h b/mail/ifile/files/patch-argp_argp.h
new file mode 100644
index 000000000000..d9493d2995b2
--- /dev/null
+++ b/mail/ifile/files/patch-argp_argp.h
@@ -0,0 +1,11 @@
+--- argp/argp.h.orig Tue Jun 10 23:09:27 2003
++++ argp/argp.h Mon Jul 7 04:31:41 2003
+@@ -352,7 +352,7 @@
+ #define ARGP_NO_EXIT 0x20
+
+ /* Use the gnu getopt `long-only' rules for parsing arguments. */
+-#define ARGP_LONG_ONLY 0x40
++#define ARGP_LONG_ONLY 0x00
+
+ /* Turns off any message-printing/exiting options. */
+ #define ARGP_SILENT (ARGP_NO_EXIT | ARGP_NO_ERRS | ARGP_NO_HELP)