aboutsummaryrefslogtreecommitdiff
path: root/mail/ilohamail
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2010-02-09 14:58:53 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2010-02-09 14:58:53 +0000
commitbdaca27c6e25a38239911c4436b6adf0a17f51b2 (patch)
treeaa1d88c602b8624fe99dad336e27cae914364b1f /mail/ilohamail
parent3e0c1fc09905698a2a0fe4f847f4ce0e258b67ed (diff)
downloadports-bdaca27c6e25a38239911c4436b6adf0a17f51b2.tar.gz
ports-bdaca27c6e25a38239911c4436b6adf0a17f51b2.zip
- Use $SUB_FILES to dynamically adjust pkg-message [1]
- Fix mysql commands in pkg-message.in, partially based on [1] - Change MAINTAINER address from tota@rtfm.jp to tota@FreeBSD.org PR: ports/142732 [1] Submitted by: Sevan Janiyan <venture37_AT_geeklan.co.uk> [1] Approved by: maho (mentor)
Notes
Notes: svn path=/head/; revision=249480
Diffstat (limited to 'mail/ilohamail')
-rw-r--r--mail/ilohamail/Makefile9
-rw-r--r--mail/ilohamail/files/pkg-message.in (renamed from mail/ilohamail/pkg-message)4
2 files changed, 5 insertions, 8 deletions
diff --git a/mail/ilohamail/Makefile b/mail/ilohamail/Makefile
index 3130668260ce..12fe0d704b96 100644
--- a/mail/ilohamail/Makefile
+++ b/mail/ilohamail/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= mail www
MASTER_SITES= SF/${PORTNAME}/IlohaMail-stable/${PORTVERSION}
DISTNAME= IlohaMail-${PORTVERSION}
-MAINTAINER= tota@rtfm.jp
+MAINTAINER= tota@FreeBSD.org
COMMENT= IlohaMail is a lightweight multilingual webmail program
NO_BUILD= yes
@@ -33,7 +33,8 @@ ILOHADIR= ${PREFIX}/ilohamail
.endif
PLIST_SUB+= ILOHADIR="${ILOHADIR:S,^${PREFIX}/,,}"
-PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST= ILOHADIR=${ILOHADIR}
pre-everything::
@${ECHO_MSG} ""
@@ -55,10 +56,6 @@ do-install:
.endif
post-install:
- @${SED} -e 's|%%ILOHADIR%%|${ILOHADIR}|g' \
- -e 's|%%DATADIR%%|${DATADIR}|g' \
- -e 's|%%DOCSDIR%%|${DOCSDIR}|g' \
- < ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/ilohamail/pkg-message b/mail/ilohamail/files/pkg-message.in
index 64409c974ac2..671e56ff733a 100644
--- a/mail/ilohamail/pkg-message
+++ b/mail/ilohamail/files/pkg-message.in
@@ -27,10 +27,10 @@ Using the MySQL back-end is also recommended.
mysql> flush privileges;
2. Create a MySQL database.
- $ mysqladmin create webmail
+ $ mysqladmin create webmail -u root -p
3. Create tables.
- $ mysql webmail < %%DATADIR%%/MySQL/sql
+ $ mysql webmail < %%DATADIR%%/MySQL/sql -u root -p
4. Configure %%ILOHADIR%%/conf/db_conf.php.