aboutsummaryrefslogtreecommitdiff
path: root/mail/imp
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-02-14 20:53:47 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-02-14 20:53:47 +0000
commite3c093828685bcf1c3eb72cd4e92a049af26b58e (patch)
treef4f6bb706eb27db2bfff6840a1a66b19d81b96bc /mail/imp
parent42f7eee9d395f556fd6c3fba46e6dae0e31f3b43 (diff)
downloadports-e3c093828685bcf1c3eb72cd4e92a049af26b58e.tar.gz
ports-e3c093828685bcf1c3eb72cd4e92a049af26b58e.zip
Fix bug #1367
Notes
Notes: svn path=/head/; revision=128846
Diffstat (limited to 'mail/imp')
-rw-r--r--mail/imp/Makefile3
-rw-r--r--mail/imp/files/patch-bug136711
2 files changed, 13 insertions, 1 deletions
diff --git a/mail/imp/Makefile b/mail/imp/Makefile
index 15dd2c64fc68..84b29e53c5ab 100644
--- a/mail/imp/Makefile
+++ b/mail/imp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= imp
PORTVERSION= 4.0.2
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/imp/ \
ftp://ftp.planetmirror.com/pub/horde/imp/ \
@@ -201,7 +202,7 @@ pre-configure:
.for fc in ${PATCH2RM}
@${RM} ${WRKSRC}/config/${fc}
.endfor
- @${RM} ${WRKSRC}/lib/MIME/Headers.php.beforeIMP
+ @${RM} ${WRKSRC}/lib/MIME/Headers.php.beforeIMP ${WRKSRC}/lib/IMP.php.orig
pre-install:
.if !defined(BATCH) && !defined(WITHOUT_SSL)
diff --git a/mail/imp/files/patch-bug1367 b/mail/imp/files/patch-bug1367
new file mode 100644
index 000000000000..83db997b1782
--- /dev/null
+++ b/mail/imp/files/patch-bug1367
@@ -0,0 +1,11 @@
+--- lib/IMP.php.orig Wed Jan 26 10:23:02 2005
++++ lib/IMP.php Mon Feb 14 21:14:11 2005
+@@ -582,7 +582,7 @@
+
+ /* Add the list of mailboxes to the lists. */
+ $showmbox = false;
+- if (is_null($filter[0])) {
++ if (count($filter) && is_null($filter[0])) {
+ $showmbox = true;
+ array_shift($filter);
+ }