aboutsummaryrefslogtreecommitdiff
path: root/mail/kiltdown
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-17 08:58:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-17 08:58:03 +0000
commitf2ab274fe3f95bb94af36a54a4acebc83bf323eb (patch)
tree1a6cb15a8571481423fa9c6f8fea7a6ae9521ffb /mail/kiltdown
parentb2ed5e24d7933ef317cbc526221efa170f497dba (diff)
downloadports-f2ab274fe3f95bb94af36a54a4acebc83bf323eb.tar.gz
ports-f2ab274fe3f95bb94af36a54a4acebc83bf323eb.zip
- Unbreak on FreeBSD 5.X: variable p shouldn't be used for two completely
different things (a MessagePriority and QPixmap) in the same sentence. PR: ports/81081 Submitted by: Johan van Selst <johans@stack.nl>
Notes
Notes: svn path=/head/; revision=135450
Diffstat (limited to 'mail/kiltdown')
-rw-r--r--mail/kiltdown/Makefile8
-rw-r--r--mail/kiltdown/files/patch-mailviewer.cc21
2 files changed, 22 insertions, 7 deletions
diff --git a/mail/kiltdown/Makefile b/mail/kiltdown/Makefile
index 8df0a03842c4..c7fde1645d70 100644
--- a/mail/kiltdown/Makefile
+++ b/mail/kiltdown/Makefile
@@ -41,10 +41,4 @@ do-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/kiltdown/kiltdown ${PREFIX}/bin/
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502122
-BROKEN= gcc34: no match for operator==
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/kiltdown/files/patch-mailviewer.cc b/mail/kiltdown/files/patch-mailviewer.cc
new file mode 100644
index 000000000000..ae761c748d8b
--- /dev/null
+++ b/mail/kiltdown/files/patch-mailviewer.cc
@@ -0,0 +1,21 @@
+--- kiltdown/mailviewer.cc.orig Sun May 15 22:29:50 2005
++++ kiltdown/mailviewer.cc Sun May 15 22:28:00 2005
+@@ -950,13 +950,13 @@ void MailViewer::layoutComponents()
+ ? ID_LOW_PRIORITY_TEXT
+ : ID_HIGH_PRIORITY_TEXT);
+ if (pstr) {
+- QPixmap p(p == LowPriority ? lowpriIcon : priorityhdrIcon);
+- priorityPixLabel->setPixmap(p);
+- priorityPixLabel->setGeometry(4, top, p.width() + 1, ctlHeight);
++ QPixmap qp(p == LowPriority ? lowpriIcon : priorityhdrIcon);
++ priorityPixLabel->setPixmap(qp);
++ priorityPixLabel->setGeometry(4, top, qp.width() + 1, ctlHeight);
+ priorityLabel->setText(pstr);
+ localFree(pstr);
+- priorityLabel->setGeometry(p.width() + 5, top,
+- this->width() - p.width() - 13,
++ priorityLabel->setGeometry(qp.width() + 5, top,
++ this->width() - qp.width() - 13,
+ ctlHeight);
+ top += ctlHeight + 5;
+ priorityPixLabel->show();