aboutsummaryrefslogtreecommitdiff
path: root/mail/libspf-alt
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-05-26 10:46:31 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-05-26 10:46:31 +0000
commit1bcb7bdcc61177d14400261725be715670dd8c25 (patch)
tree03e25facf71a499949a25e0033279357368d4c87 /mail/libspf-alt
parentfcb15482973979637702bb2b2238ff7b86fbf27f (diff)
downloadports-1bcb7bdcc61177d14400261725be715670dd8c25.tar.gz
ports-1bcb7bdcc61177d14400261725be715670dd8c25.zip
Add libspf-alt, a library that allows email
systems such as Exim to check SPF records.
Notes
Notes: svn path=/head/; revision=110040
Diffstat (limited to 'mail/libspf-alt')
-rw-r--r--mail/libspf-alt/Makefile31
-rw-r--r--mail/libspf-alt/distinfo2
-rw-r--r--mail/libspf-alt/files/patch-config::ltmain.sh45
-rw-r--r--mail/libspf-alt/pkg-descr6
-rw-r--r--mail/libspf-alt/pkg-plist22
5 files changed, 106 insertions, 0 deletions
diff --git a/mail/libspf-alt/Makefile b/mail/libspf-alt/Makefile
new file mode 100644
index 000000000000..bea78aa32e6d
--- /dev/null
+++ b/mail/libspf-alt/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mailutils
+# Date created: 26 May 2004
+# Whom: Oliver Eikemeier
+#
+# $FreeBSD$
+#
+
+PORTNAME= libspf-alt
+PORTVERSION= 0.4.0
+CATEGORIES= mail devel
+MASTER_SITES= http://www.midwestcs.com/spf/%SUBDIR%/
+MASTER_SITE_SUBDIR= libspf-alt
+DISTNAME= libspf_alt-${PORTVERSION}
+
+MAINTAINER= eik@FreeBSD.org
+COMMENT= Library that allows email systems such as Exim to check SPF records
+
+GNU_CONFIGURE= yes
+USE_ICONV= yes
+USE_GETTEXT= yes
+INSTALLS_SHLIB= yes
+
+CPPFLAGS+= ${PTHREAD_CFLAGS} \
+ -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/mail/libspf-alt/distinfo b/mail/libspf-alt/distinfo
new file mode 100644
index 000000000000..f8ece47f6331
--- /dev/null
+++ b/mail/libspf-alt/distinfo
@@ -0,0 +1,2 @@
+MD5 (libspf_alt-0.4.0.tar.gz) = d314fdf5c89145487fe40c61beccca32
+SIZE (libspf_alt-0.4.0.tar.gz) = 598003
diff --git a/mail/libspf-alt/files/patch-config::ltmain.sh b/mail/libspf-alt/files/patch-config::ltmain.sh
new file mode 100644
index 000000000000..ba37b6e23a43
--- /dev/null
+++ b/mail/libspf-alt/files/patch-config::ltmain.sh
@@ -0,0 +1,45 @@
+--- config/ltmain.sh.orig Mon Mar 29 03:03:25 2004
++++ config/ltmain.sh Wed May 26 11:52:51 2004
+@@ -1346,7 +1346,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1363,6 +1363,12 @@
+
+ -module)
+ module=yes
++ case $host in
++ *-*-freebsd*)
++ # Do not build the useless static library
++ build_old_libs=no
++ ;;
++ esac
+ continue
+ ;;
+
+@@ -5533,10 +5539,16 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
+- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+- instname="$dir/$name"i
+- $show "$install_prog $instname $destdir/$name"
+- $run eval "$install_prog $instname $destdir/$name" || exit $?
++ case $host in
++ *-*-freebsd*)
++ # Do not install the useless pseudo-library
++ ;;
++ *)
++ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
++ instname="$dir/$name"i
++ $show "$install_prog $instname $destdir/$name"
++ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ esac
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/mail/libspf-alt/pkg-descr b/mail/libspf-alt/pkg-descr
new file mode 100644
index 000000000000..76111ab5d564
--- /dev/null
+++ b/mail/libspf-alt/pkg-descr
@@ -0,0 +1,6 @@
+The libspf-alt SPF implementation is a library that allows email systems
+such as Exim to check SPF records and make sure that the email is authorized
+by the domain name that it is coming from. This prevents email forgery,
+commonly used by spammers, scammers and email viruses/worms.
+
+WWW: http://www.midwestcs.com/spf/libspf-alt/
diff --git a/mail/libspf-alt/pkg-plist b/mail/libspf-alt/pkg-plist
new file mode 100644
index 000000000000..499e0095bbff
--- /dev/null
+++ b/mail/libspf-alt/pkg-plist
@@ -0,0 +1,22 @@
+bin/spf_example
+bin/spf_example_2mx
+bin/spf_example_2mx_static
+bin/spf_example_static
+bin/spfd
+bin/spfd_static
+bin/spfquery
+bin/spfquery_static
+bin/spftest
+bin/spftest_static
+include/spf_alt/spf.h
+include/spf_alt/spf_dns.h
+include/spf_alt/spf_dns_cache.h
+include/spf_alt/spf_dns_null.h
+include/spf_alt/spf_dns_resolv.h
+include/spf_alt/spf_dns_test.h
+include/spf_alt/spf_dns_zone.h
+include/spf_alt/spf_lib_version.h
+@dirrm include/spf_alt
+lib/libspf_alt.a
+lib/libspf_alt.so
+lib/libspf_alt.so.1