aboutsummaryrefslogtreecommitdiff
path: root/mail/libsrs_alt
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-23 20:54:27 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-23 20:54:27 +0000
commitfd7a5c82986523d16a3887db71c837bbff2482e0 (patch)
tree932997c5ce77794aa92dec68abfab413c77a8f1f /mail/libsrs_alt
parent332b5377146403ab671421cb4cdc43147252489a (diff)
downloadports-fd7a5c82986523d16a3887db71c837bbff2482e0.tar.gz
ports-fd7a5c82986523d16a3887db71c837bbff2482e0.zip
This is a complete standalone C implementation of the SRS (Sender
Rewriting Scheme) and includes a command line utility and daemon, test utility and static and dynamic libraries. SRS is a stop-gap for users of SPF (Sender Policy Framework). WWW: http://srs.mirtol.com PR: ports/94831 Submitted by: Simon Dick <simond@irrelevant.org>
Notes
Notes: svn path=/head/; revision=158021
Diffstat (limited to 'mail/libsrs_alt')
-rw-r--r--mail/libsrs_alt/Makefile35
-rw-r--r--mail/libsrs_alt/distinfo3
-rw-r--r--mail/libsrs_alt/pkg-descr6
-rw-r--r--mail/libsrs_alt/pkg-plist6
4 files changed, 50 insertions, 0 deletions
diff --git a/mail/libsrs_alt/Makefile b/mail/libsrs_alt/Makefile
new file mode 100644
index 000000000000..4fdf361f40d4
--- /dev/null
+++ b/mail/libsrs_alt/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libsrs_alt
+# Date created: 22 March 2006
+# Whom: Simon Dick <simond@irrelevant.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsrs_alt
+DISTVERSION= 1.0rc1a
+CATEGORIES= mail
+MASTER_SITES= http://srs.mirtol.com/
+
+MAINTAINER= simond@irrelevant.org
+COMMENT= Sender Rewriting Scheme C Implementation
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+SHLIB_MAJOR= 1
+GNU_CONFIGURE= yes
+
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+
+OPTIONS= COMPAT_BASE64 "Enable MTA Friendly base64 compatibility mode" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_COMPAT_BASE64)
+CONFIGURE_ARGS+= --with-base64compat
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,^(test_LDFLAGS.*$$),\1 -lcompat,' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/mail/libsrs_alt/distinfo b/mail/libsrs_alt/distinfo
new file mode 100644
index 000000000000..0dced3fe0263
--- /dev/null
+++ b/mail/libsrs_alt/distinfo
@@ -0,0 +1,3 @@
+MD5 (libsrs_alt-1.0rc1a.tar.bz2) = 1eda222957d339cba28178add3fb5f61
+SHA256 (libsrs_alt-1.0rc1a.tar.bz2) = 69cb6059b0271b42c48f487be9b416fd04974c09d7c7672ebb1137b4cd315f06
+SIZE (libsrs_alt-1.0rc1a.tar.bz2) = 232642
diff --git a/mail/libsrs_alt/pkg-descr b/mail/libsrs_alt/pkg-descr
new file mode 100644
index 000000000000..fb58bc0db342
--- /dev/null
+++ b/mail/libsrs_alt/pkg-descr
@@ -0,0 +1,6 @@
+This is a complete standalone C implementation of the SRS (Sender
+Rewriting Scheme) and includes a command line utility and daemon,
+test utility and static and dynamic libraries. SRS is a stop-gap
+for users of SPF (Sender Policy Framework).
+
+WWW: http://srs.mirtol.com
diff --git a/mail/libsrs_alt/pkg-plist b/mail/libsrs_alt/pkg-plist
new file mode 100644
index 000000000000..afb15bf30f2a
--- /dev/null
+++ b/mail/libsrs_alt/pkg-plist
@@ -0,0 +1,6 @@
+bin/srs
+include/srs_alt.h
+lib/libsrs_alt.a
+lib/libsrs_alt.la
+lib/libsrs_alt.so
+lib/libsrs_alt.so.%%SHLIB_MAJOR%%