aboutsummaryrefslogtreecommitdiff
path: root/mail/lmtpd/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-10-26 21:49:27 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-10-26 21:49:27 +0000
commit6b0f8137e340125b9c62117f425489f2b688b8d6 (patch)
treedaac77013f7fcbde78c21a2f663d9e395fe08a5c /mail/lmtpd/Makefile
parent7f338a595fa355855e711a8058bb80a059f01e13 (diff)
downloadports-6b0f8137e340125b9c62117f425489f2b688b8d6.tar.gz
ports-6b0f8137e340125b9c62117f425489f2b688b8d6.zip
- Update to 0.9.9 (fixes a security problem)
PR: 58332 Submitted by: maintainer Approved by: krion (implicit)
Notes
Notes: svn path=/head/; revision=92246
Diffstat (limited to 'mail/lmtpd/Makefile')
-rw-r--r--mail/lmtpd/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/mail/lmtpd/Makefile b/mail/lmtpd/Makefile
index 122d84524549..a6b326c91dce 100644
--- a/mail/lmtpd/Makefile
+++ b/mail/lmtpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lmtpd
-PORTVERSION= 0.9.8
+PORTVERSION= 0.9.9
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pll
@@ -16,13 +16,18 @@ COMMENT= LMTPD is a lmtp server compliant with RFC 2033 and Maildir++
LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql323-client \
pcre:${PORTSDIR}/devel/pcre \
- iconv:${PORTSDIR}/converters/libiconv
+ iconv:${PORTSDIR}/converters/libiconv \
+ db3.3:${PORTSDIR}/databases/db3
BUILD_DEPENDS= ${LOCALBASE}/lib/libhome.a:${PORTSDIR}/misc/libhome
GNU_CONFIGURE= YES
-
-CONFIGURE_ARGS+= --with-mysqllog --without-db3 --without-db4 --with-pcre --without-perl
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
+CONFIGURE_ARGS= --with-mysqllog --with-db3 -without-db4 --with-pcre --without-perl
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN8= lmtpd.8
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/lmtpd.conf-sample ${PREFIX}/etc/lmtpd.conf.dist
+
.include <bsd.port.mk>