aboutsummaryrefslogtreecommitdiff
path: root/mail/mail-notification
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-06 22:52:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-06 22:52:22 +0000
commita73585b8f1df1e379fd773304c3ab29cd2d52cfb (patch)
treede00d8f73f198ac3e30466dca9b130ef677ecd39 /mail/mail-notification
parentc90a2edfd4e2e0b6077de023fc85a0b0fdadfde9 (diff)
downloadports-a73585b8f1df1e379fd773304c3ab29cd2d52cfb.tar.gz
ports-a73585b8f1df1e379fd773304c3ab29cd2d52cfb.zip
Update to 1.1.
PR: 78514 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=130489
Diffstat (limited to 'mail/mail-notification')
-rw-r--r--mail/mail-notification/Makefile34
-rw-r--r--mail/mail-notification/distinfo4
-rw-r--r--mail/mail-notification/pkg-plist15
3 files changed, 29 insertions, 24 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index 0ca176eb5576..d5a45d9f1d95 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mail-notification
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= mailnotify
@@ -22,6 +22,8 @@ CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_GCC= 3.4
+GCONF_SCHEMAS= mail-notification.schemas
+INSTALLS_OMF= yes
OPTIONS= MBOX "mbox support" on \
MH "MH support" on \
@@ -32,7 +34,7 @@ OPTIONS= MBOX "mbox support" on \
SASL "SASL authentication support" on \
SYLPHEED "Sylpheed support" on \
GMAIL "Gmail support" on \
- MIME "MIME support" on
+ GMAIL_TIMESTAMPS "Gmail timestamps support" on
.include <bsd.port.pre.mk>
@@ -56,29 +58,28 @@ CONFIGURE_ARGS+= --disable-imap
WITHOUT_SSL= yes
WITHOUT_SASL= yes
.endif
-.if defined(WITHOUT_MBOX) \
- && defined(WITHOUT_MH) \
- && defined(WITHOUT_MAILDIR) \
- && defined(WITHOUT_POP3) \
- && defined(WITHOUT_IMAP) \
- && defined(WITHOUT_SYLPHEED)
-# MIME support not needed
-WITHOUT_MIME= yes
-.endif
.if defined(WITHOUT_SYLPHEED)
CONFIGURE_ARGS+= --disable-sylpheed
.endif
.if defined(WITHOUT_GMAIL)
CONFIGURE_ARGS+= --disable-gmail
+WITHOUT_GMAIL_TIMESTAMPS= yes
.else
LIB_DEPENDS+= soup-2.2:${PORTSDIR}/devel/libsoup
.endif
-.if defined(WITHOUT_MIME)
-CONFIGURE_ARGS+= --disable-mime
+.if defined(WITHOUT_GMAIL_TIMESTAMPS)
+CONFIGURE_ARGS+= --disable-gmail-timestamps
.else
+LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
+.endif
+.if defined(WITH_MBOX) \
+ || defined(WITH_MH) \
+ || defined(WITH_MAILDIR) \
+ || defined(WITH_POP3) \
+ || defined(WITH_IMAP) \
+ || defined(WITH_SYLPHEED)
LIB_DEPENDS+= gmime-2.0:${PORTSDIR}/mail/gmime2
.endif
-
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --disable-ssl
.else
@@ -90,5 +91,10 @@ CONFIGURE_ARGS+= --disable-sasl
.else
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
.endif
+.if defined(WITH_POP3) || defined(WITH_IMAP) || defined(WITH_GMAIL)
+PLIST_SUB+= AUTHENTICATION=""
+.else
+PLIST_SUB+= AUTHENTICATION="@comment "
+.endif
.include <bsd.port.post.mk>
diff --git a/mail/mail-notification/distinfo b/mail/mail-notification/distinfo
index c7ce4cfe71b5..521e69c7fab7 100644
--- a/mail/mail-notification/distinfo
+++ b/mail/mail-notification/distinfo
@@ -1,2 +1,2 @@
-MD5 (mail-notification-1.0.tar.gz) = 9f458da2a222490330ed93d3298ced75
-SIZE (mail-notification-1.0.tar.gz) = 622289
+MD5 (mail-notification-1.1.tar.gz) = 2359fb53128b12cf295bdf8553e5869b
+SIZE (mail-notification-1.1.tar.gz) = 683776
diff --git a/mail/mail-notification/pkg-plist b/mail/mail-notification/pkg-plist
index 8875db92b9c2..35b78a8bad78 100644
--- a/mail/mail-notification/pkg-plist
+++ b/mail/mail-notification/pkg-plist
@@ -1,7 +1,4 @@
bin/mail-notification
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/mail-notification.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/mail-notification.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/mail-notification.schemas > /dev/null || /usr/bin/true
etc/sound/events/mail-notification.soundlist
libdata/bonobo/servers/GNOME_MailNotification_Automation.server
share/gnome/applications/mail-notification.desktop
@@ -10,19 +7,21 @@ share/gnome/help/mail-notification/C/documentation-license.xml
share/gnome/help/mail-notification/C/figures/mail.png
share/gnome/help/mail-notification/C/mail-notification.xml
share/gnome/help/mail-notification/C/software-license.xml
-share/gnome/mail-notification/ui/authentication.glade
+%%AUTHENTICATION%%share/gnome/mail-notification/ui/authentication.glade
+share/gnome/mail-notification/ui/edit-toolbars.glade
share/gnome/mail-notification/ui/gmail.png
+share/gnome/mail-notification/ui/hand-open.png
share/gnome/mail-notification/ui/logo.png
-share/gnome/mail-notification/ui/mail-notification.png
share/gnome/mail-notification/ui/mailbox-properties.glade
+share/gnome/mail-notification/ui/main-window.png
+share/gnome/mail-notification/ui/main.glade
+share/gnome/mail-notification/ui/menus.xml
share/gnome/mail-notification/ui/properties.glade
-share/gnome/mail-notification/ui/summary-dialog.glade
share/gnome/mail-notification/ui/summary-popup.glade
+share/gnome/mail-notification/ui/toolbars.xml
share/gnome/mail-notification/ui/unsupported.png
share/gnome/mail-notification/ui/welcome.glade
share/gnome/omf/mail-notification/mail-notification-C.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/mail-notification/mail-notification-C.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/mail-notification/mail-notification-C.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/mail-notification.png
share/locale/bg/LC_MESSAGES/mail-notification.mo
share/locale/de/LC_MESSAGES/mail-notification.mo