aboutsummaryrefslogtreecommitdiff
path: root/mail/mail-notification
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-02-20 22:50:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-02-20 22:50:17 +0000
commitda4102067bcde872a080b97607d5f6b58960631d (patch)
treefbfef940f01e00fea1883aefef8dedbc8df645e1 /mail/mail-notification
parent284cc7d7f995759920c536cbf3f6f363c34e405a (diff)
downloadports-da4102067bcde872a080b97607d5f6b58960631d.tar.gz
ports-da4102067bcde872a080b97607d5f6b58960631d.zip
- Update to 4.1 and unbreak with Evolution
PR: ports/117710 Submitted by: Marcin Wisnicki <mwisnicki+freebsd@gmail.com> Approved by: maintainer timeout (jylefort; 3 months)
Notes
Notes: svn path=/head/; revision=207673
Diffstat (limited to 'mail/mail-notification')
-rw-r--r--mail/mail-notification/Makefile12
-rw-r--r--mail/mail-notification/distinfo6
-rw-r--r--mail/mail-notification/files/patch-01-mail-notification-findevo_21256
-rw-r--r--mail/mail-notification/files/patch-02-mail-notification-evo-api-change11
-rw-r--r--mail/mail-notification/files/patch-03-openssl-threads11
-rw-r--r--mail/mail-notification/pkg-plist8
6 files changed, 92 insertions, 12 deletions
diff --git a/mail/mail-notification/Makefile b/mail/mail-notification/Makefile
index 553606a4760a..d0979c3743cc 100644
--- a/mail/mail-notification/Makefile
+++ b/mail/mail-notification/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mail-notification
-DISTVERSION= 4.0
-PORTREVISION= 3
+DISTVERSION= 4.1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= mailnotify
@@ -17,7 +16,10 @@ COMMENT= A mail notification for freedesktop.org-compliant system trays
LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
+USE_BZIP2= yes
USE_XLIB= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomeprefix gnomehack eel2
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -72,9 +74,9 @@ PLIST_SUB+= GMAIL=""
CONFIGURE_ARGS+=--disable-evolution
PLIST_SUB+= EVOLUTION="@comment "
.else
-EVO_VERSION= 2.10
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin-${EVO_VERSION}.pc:${PORTSDIR}/mail/evolution
-RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin-${EVO_VERSION}.pc:${PORTSDIR}/mail/evolution
+EVO_VERSION= 2.12
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin.pc:${PORTSDIR}/mail/evolution
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/evolution-plugin.pc:${PORTSDIR}/mail/evolution
PLIST_SUB+= EVOLUTION="" EVO_VERSION=${EVO_VERSION}
.endif
.if defined(WITHOUT_MOZILLA)
diff --git a/mail/mail-notification/distinfo b/mail/mail-notification/distinfo
index 9c43b7b36d28..f28b96aa74c4 100644
--- a/mail/mail-notification/distinfo
+++ b/mail/mail-notification/distinfo
@@ -1,3 +1,3 @@
-MD5 (mail-notification-4.0.tar.gz) = 0e10b221de4389fa9275fb7bf52dc010
-SHA256 (mail-notification-4.0.tar.gz) = e8f462420d1398d293ee3b9451e854c4ca9bf030111c38e3e4247cf2813db378
-SIZE (mail-notification-4.0.tar.gz) = 956007
+MD5 (mail-notification-4.1.tar.bz2) = 4d9617ad0e7eded0953ac6d152f06a46
+SHA256 (mail-notification-4.1.tar.bz2) = c3dea02bf7060e3e30851adb629b3b3b78e163371c4001028d011d81976d9193
+SIZE (mail-notification-4.1.tar.bz2) = 713068
diff --git a/mail/mail-notification/files/patch-01-mail-notification-findevo_212 b/mail/mail-notification/files/patch-01-mail-notification-findevo_212
new file mode 100644
index 000000000000..dbdc1898ab73
--- /dev/null
+++ b/mail/mail-notification/files/patch-01-mail-notification-findevo_212
@@ -0,0 +1,56 @@
+diff -Naur mail-notification-4.1.org/configure mail-notification-4.1/configure
+--- configure 2007-06-28 18:06:41.000000000 +0200
++++ configure 2007-06-28 18:07:08.000000000 +0200
+@@ -24403,12 +24403,12 @@
+ pkg_cv_EVOLUTION_PLUGIN_CFLAGS="$EVOLUTION_PLUGIN_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"evolution-plugin-\$evolution_branch \$evolution_plugin_min_version\"") >&5
+- ($PKG_CONFIG --exists --print-errors "evolution-plugin-$evolution_branch $evolution_plugin_min_version") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"evolution-plugin \$evolution_plugin_min_version\"") >&5
++ ($PKG_CONFIG --exists --print-errors "evolution-plugin $evolution_plugin_min_version") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_EVOLUTION_PLUGIN_CFLAGS=`$PKG_CONFIG --cflags "evolution-plugin-$evolution_branch $evolution_plugin_min_version" 2>/dev/null`
++ pkg_cv_EVOLUTION_PLUGIN_CFLAGS=`$PKG_CONFIG --cflags "evolution-plugin $evolution_plugin_min_version" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -24421,12 +24421,12 @@
+ pkg_cv_EVOLUTION_PLUGIN_LIBS="$EVOLUTION_PLUGIN_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"evolution-plugin-\$evolution_branch \$evolution_plugin_min_version\"") >&5
+- ($PKG_CONFIG --exists --print-errors "evolution-plugin-$evolution_branch $evolution_plugin_min_version") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"evolution-plugin \$evolution_plugin_min_version\"") >&5
++ ($PKG_CONFIG --exists --print-errors "evolution-plugin $evolution_plugin_min_version") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_EVOLUTION_PLUGIN_LIBS=`$PKG_CONFIG --libs "evolution-plugin-$evolution_branch $evolution_plugin_min_version" 2>/dev/null`
++ pkg_cv_EVOLUTION_PLUGIN_LIBS=`$PKG_CONFIG --libs "evolution-plugin $evolution_plugin_min_version" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -24445,9 +24445,9 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- EVOLUTION_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "evolution-plugin-$evolution_branch $evolution_plugin_min_version"`
++ EVOLUTION_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "evolution-plugin $evolution_plugin_min_version"`
+ else
+- EVOLUTION_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "evolution-plugin-$evolution_branch $evolution_plugin_min_version"`
++ EVOLUTION_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "evolution-plugin $evolution_plugin_min_version"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$EVOLUTION_PLUGIN_PKG_ERRORS" >&5
+@@ -24468,7 +24468,7 @@
+ if test $found = yes; then
+ { echo "$as_me:$LINENO: checking for the Evolution plugin directory" >&5
+ echo $ECHO_N "checking for the Evolution plugin directory... $ECHO_C" >&6; }
+- evolution_plugindir=`$PKG_CONFIG --variable=plugindir evolution-plugin-$evolution_branch 2>/dev/null`
++ evolution_plugindir=`$PKG_CONFIG --variable=plugindir evolution-plugin 2>/dev/null`
+ if test -n "$evolution_plugindir"; then
+ { echo "$as_me:$LINENO: result: $evolution_plugindir" >&5
+ echo "${ECHO_T}$evolution_plugindir" >&6; }
diff --git a/mail/mail-notification/files/patch-02-mail-notification-evo-api-change b/mail/mail-notification/files/patch-02-mail-notification-evo-api-change
new file mode 100644
index 000000000000..b5915438f712
--- /dev/null
+++ b/mail/mail-notification/files/patch-02-mail-notification-evo-api-change
@@ -0,0 +1,11 @@
+--- src/mn-evolution-folder-tree-control.c.orig 2007-06-26 13:41:11.000000000 +0200
++++ src/mn-evolution-folder-tree-control.c 2007-10-31 03:53:10.000000000 +0100
+@@ -264,7 +264,7 @@
+ switch (arg_id)
+ {
+ case PROP_SELECTED_URI:
+- em_folder_tree_set_selected(tree, BONOBO_ARG_GET_STRING(arg));
++ em_folder_tree_set_selected(tree, BONOBO_ARG_GET_STRING(arg), TRUE);
+ break;
+
+ default:
diff --git a/mail/mail-notification/files/patch-03-openssl-threads b/mail/mail-notification/files/patch-03-openssl-threads
new file mode 100644
index 000000000000..74ab914cf05e
--- /dev/null
+++ b/mail/mail-notification/files/patch-03-openssl-threads
@@ -0,0 +1,11 @@
+--- configure.orig 2007-06-26 13:40:19.000000000 +0200
++++ configure 2007-10-31 03:47:03.000000000 +0100
+@@ -24236,7 +24236,7 @@
+ #include <openssl/opensslconf.h>
+
+ int main() {
+-#ifdef OPENSSL_THREADS
++#if defined(OPENSSL_THREADS) || defined(THREADS)
+ exit(0); /* ok */
+ #else
+ exit(1); /* no thread support */
diff --git a/mail/mail-notification/pkg-plist b/mail/mail-notification/pkg-plist
index fc5cfa7cac38..248a0e01657b 100644
--- a/mail/mail-notification/pkg-plist
+++ b/mail/mail-notification/pkg-plist
@@ -35,10 +35,10 @@ share/locale/ru/LC_MESSAGES/mail-notification.mo
share/locale/sr/LC_MESSAGES/mail-notification.mo
share/locale/sr@Latn/LC_MESSAGES/mail-notification.mo
share/locale/sv/LC_MESSAGES/mail-notification.mo
-%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/liborg-gnome-mail-notification.a
-%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/liborg-gnome-mail-notification.la
-%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/liborg-gnome-mail-notification.so
-%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/org-gnome-mail-notification.eplug
+%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/liborg-jylefort-mail-notification.a
+%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/liborg-jylefort-mail-notification.la
+%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/liborg-jylefort-mail-notification.so
+%%EVOLUTION%%lib/evolution/%%EVO_VERSION%%/plugins/org-jylefort-mail-notification.eplug
@dirrm share/omf/mail-notification
@dirrm share/mail-notification/ui
@dirrm share/mail-notification