aboutsummaryrefslogtreecommitdiff
path: root/mail/mailagent
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-11-23 17:02:37 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-11-23 17:02:37 +0000
commit47409b2f7e1ab4b2fcbcc4656221f15ac4b7b1d7 (patch)
treebf83d0a76b74f426fa56438b1f58a6ad4de5c15c /mail/mailagent
parent06edab400703f0d73110a09ed630961381598b05 (diff)
downloadports-47409b2f7e1ab4b2fcbcc4656221f15ac4b7b1d7.tar.gz
ports-47409b2f7e1ab4b2fcbcc4656221f15ac4b7b1d7.zip
In pre-extract:, check if the make was run by root. If so, abort the
extraction/build as it won't go through the sanity tests afterwards. Copy example files in agent/examples into ${PREFIX}/share/examples/mailagent.
Notes
Notes: svn path=/head/; revision=8774
Diffstat (limited to 'mail/mailagent')
-rw-r--r--mail/mailagent/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index 55af37e82fa2..864c5a54f2cb 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 Sep 1996
# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.19 1997/07/13 18:49:23 max Exp $
+# $Id: Makefile,v 1.20 1997/09/16 01:03:26 max Exp $
#
DISTNAME= mailagent-3.0@58
@@ -38,5 +38,12 @@ pre-extract:
echo "Please set umask to 022 before running make,"; \
echo "or mailagent will not build successfully."; \
false; fi
+ @if [ `id -u` = 0 ]; then \
+ echo "Do not build mailagent as root or it won't pass the sanity tests."; \
+ false; fi
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/examples/mailagent
+ ${INSTALL_DATA} ${WRKSRC}/agent/examples/* ${PREFIX}/share/examples/mailagent
.include <bsd.port.mk>