aboutsummaryrefslogtreecommitdiff
path: root/mail/mailagent
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-01-20 02:30:08 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-01-20 02:30:08 +0000
commitef07f290e469e6c4b0b44133f0564d57883cf45a (patch)
treede0025cd0f563fcca9ce6ec42cfc21c3bab8a159 /mail/mailagent
parentbb941f5603e42502036ee993f6ca232e42b710ac (diff)
downloadports-ef07f290e469e6c4b0b44133f0564d57883cf45a.tar.gz
ports-ef07f290e469e6c4b0b44133f0564d57883cf45a.zip
Added pre-extract target to check and cause error if it's not 022.
This is because the build procedure doesn't go quite well if it's other than 022. Rported by: "Barry Friedman" <friedman@nortel.ca>
Notes
Notes: svn path=/head/; revision=5390
Diffstat (limited to 'mail/mailagent')
-rw-r--r--mail/mailagent/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index b552373343a6..9369b3964432 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 Sep 1996
# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.5 1996/12/08 01:44:51 max Exp $
+# $Id: Makefile,v 1.6 1997/01/16 09:53:21 max Exp $
#
DISTNAME= mailagent-3.0pl53
@@ -20,9 +20,8 @@ MAINTAINER= max@FreeBSD.ORG
RUN_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
-WRKSRC= ${WRKDIR}/mailagent-3.0
-
NO_PACKAGE= "Correct FQDN needs to be hardcoded"
+WRKSRC= ${WRKDIR}/mailagent-3.0
IS_INTERACTIVE= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
@@ -40,4 +39,10 @@ MAN1= edusers.1 mailagent.1 maildist.1 \
# from several other man pages with .so macro.
PERLPATH!= dirname `which perl5.003`
+pre-extract:
+ @if [ `/bin/sh -c umask` != 022 ]; then \
+ echo "Please set umask to 022 before running make,"; \
+ echo "or mailagent will not build successfully."; \
+ false; fi
+
.include <bsd.port.mk>