aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
authorJean Milanez Melo <jmelo@FreeBSD.org>2006-05-09 18:07:54 +0000
committerJean Milanez Melo <jmelo@FreeBSD.org>2006-05-09 18:07:54 +0000
commit46df1211236bc0ae84e1423feb116f68956cb67c (patch)
tree846e0f79a2945afce472a2b2c0b650f4f47eace9 /mail/mailman/Makefile
parentacca6bf6b1fb2b5f89c9184b86756e3ab608bcd8 (diff)
downloadports-46df1211236bc0ae84e1423feb116f68956cb67c.tar.gz
ports-46df1211236bc0ae84e1423feb116f68956cb67c.zip
- Add pre-fetch to show build time options.
Approved by: mnag (mentor)
Notes
Notes: svn path=/head/; revision=161830
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index b715d5919c71..edafd36665e9 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -107,6 +107,18 @@ PLIST_SUB+= SUB_HTDIG=""
PLIST_SUB+= SUB_HTDIG="@comment "
.endif
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "You may change the following build options:"
+ @${ECHO} "MM_USERNAME=mailman The username of the Mailman user."
+ @${ECHO} "MM_USERID=91 The user ID of the Mailman user."
+ @${ECHO} "MM_GROUPNAME=mailman The group to which the Mailman user will belong."
+ @${ECHO} "MM_GROUPID=MM_USERID The group ID for the Mailman user."
+ @${ECHO} "MM_DIR=mailman Mailman will be installed in ${PREFIX}/${MM_DIR}."
+ @${ECHO} "CGI_GID=www The group name or id under which your web server executes CGI scripts."
+ @${ECHO} "IMGDIR=www/icons Icon images will be installed in ${PREFIX}/${IMGDIR}."
+ @${ECHO} ""
+
post-patch:
@${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
${WRKSRC}/Mailman/Defaults.py.in