aboutsummaryrefslogtreecommitdiff
path: root/mail/mailx
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-03 02:58:28 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-03 02:58:28 +0000
commitd396bf6dfe8093cb5f444cdd06b7873e707415f2 (patch)
tree078a4dcffb0d66fc6a460cf9b76f47e8d3ea8668 /mail/mailx
parentb143148eef8ea7224e5048d1b261474bd7a7d353 (diff)
downloadports-d396bf6dfe8093cb5f444cdd06b7873e707415f2.tar.gz
ports-d396bf6dfe8093cb5f444cdd06b7873e707415f2.zip
Initial import of mailx version 0.5.
A mail command with mailx extensions. PR: 10161 Submitted by: Issei Suzuki <issei@jp.FreeBSD.org>
Notes
Notes: svn path=/head/; revision=18377
Diffstat (limited to 'mail/mailx')
-rw-r--r--mail/mailx/Makefile37
-rw-r--r--mail/mailx/distinfo3
-rw-r--r--mail/mailx/pkg-comment1
-rw-r--r--mail/mailx/pkg-descr17
-rw-r--r--mail/mailx/pkg-plist3
5 files changed, 61 insertions, 0 deletions
diff --git a/mail/mailx/Makefile b/mail/mailx/Makefile
new file mode 100644
index 000000000000..4edd7c9d8f44
--- /dev/null
+++ b/mail/mailx/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mailx
+# Version required: 5
+# Date created: 18 Febrary 1999
+# Whom: Issei Suzuki <issei@jp.FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= mailx-0.5
+CATEGORIES= mail
+MASTER_SITES= ftp://ports.jp.freebsd.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/ \
+ ftp://ftp.noc.titech.ac.jp/pub/tmp/aki/FreeBSD/mailx/
+DISTFILES= mail-2.2.8.tar.gz mailx-memo-2.2.8R
+
+PATCH_SITES= ftp://ports.jp.freebsd.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/ \
+ ftp://ftp.noc.titech.ac.jp/pub/tmp/aki/FreeBSD/mailx/
+PATCHFILES= mailx.v05.patch.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= issei@jp.FreeBSD.ORG
+
+EXTRACT_ONLY= mail-2.2.8.tar.gz
+WRKSRC= ${WRKDIR}/mail-2.2.8
+USE_PERL5= yes
+MAN1= mailx.1
+MANCOMPRESSED= yes
+
+post-patch:
+ ${PERL5} -pi.bak -e 's/^(\.Nm mail)/$$1x/i; s/^(\.Dt MAIL)/$$1X/' ${WRKSRC}/mail.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mail ${PREFIX}/bin/mailx
+ ${INSTALL_MAN} ${WRKSRC}/mail.1.gz ${PREFIX}/man/man1/mailx.1.gz
+ ${MKDIR} ${PREFIX}/share/doc/mailx
+ ${INSTALL_DATA} ${DISTDIR}/mailx-memo-2.2.8R ${PREFIX}/share/doc/mailx
+
+.include <bsd.port.mk>
diff --git a/mail/mailx/distinfo b/mail/mailx/distinfo
new file mode 100644
index 000000000000..0f6ccef6109d
--- /dev/null
+++ b/mail/mailx/distinfo
@@ -0,0 +1,3 @@
+MD5 (mail-2.2.8.tar.gz) = 5f3a8c97ed7b30cbc165bf38248e4e2a
+MD5 (mailx-memo-2.2.8R) = fa61fd210e90647820778b2a704c6199
+MD5 (mailx.v05.patch.gz) = 0fabc29c57907dd484bb2c431022decb
diff --git a/mail/mailx/pkg-comment b/mail/mailx/pkg-comment
new file mode 100644
index 000000000000..203d7864456e
--- /dev/null
+++ b/mail/mailx/pkg-comment
@@ -0,0 +1 @@
+Mail command with mailx extensions.
diff --git a/mail/mailx/pkg-descr b/mail/mailx/pkg-descr
new file mode 100644
index 000000000000..04433020f333
--- /dev/null
+++ b/mail/mailx/pkg-descr
@@ -0,0 +1,17 @@
+Mail command with mailx extensions.
+
+ Mailx command is based on BSD mail command, but it also provides some
+enhanced features such as:
+
+o Edit header information.
+o Use pager program to display long message.
+o Add pipe (|) command. You can pass the mail message to the shell command by
+ using this feature.
+o Add Save, Copy command.
+o Add askcc, askbcc command. The mailx program ask you Cc: and Bcc: at the
+ beggining.
+o Add hsubject command. This is similar to subject command, but it only
+ displays Subject: headers.
+o Add tilda escape command.
+
+See also the files in ${PREFIX}/share/doc/mailx directory.
diff --git a/mail/mailx/pkg-plist b/mail/mailx/pkg-plist
new file mode 100644
index 000000000000..09fe2d50aa2f
--- /dev/null
+++ b/mail/mailx/pkg-plist
@@ -0,0 +1,3 @@
+bin/mailx
+share/doc/mailx/mailx-memo-2.2.8R
+@dirrm share/doc/mailx