aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-callback
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-02-11 14:15:33 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-02-11 14:15:33 +0000
commit818ca057278c1e4c2781146666151a3c12fd3c7f (patch)
treecd2de55d793e6f72326ce585e1bd7a2c9fa31efe /mail/milter-callback
parent8c834adc2a7b8b32dba3348c8520c19d76fce576 (diff)
downloadports-818ca057278c1e4c2781146666151a3c12fd3c7f.tar.gz
ports-818ca057278c1e4c2781146666151a3c12fd3c7f.zip
Add milter-callback, a sendmail milter to perform a envelope-from sender
verification on target MX.
Notes
Notes: svn path=/head/; revision=249576
Diffstat (limited to 'mail/milter-callback')
-rw-r--r--mail/milter-callback/Makefile46
-rw-r--r--mail/milter-callback/distinfo3
-rw-r--r--mail/milter-callback/files/milter-callback.in28
-rw-r--r--mail/milter-callback/files/pkg-message.in12
-rw-r--r--mail/milter-callback/pkg-descr9
-rw-r--r--mail/milter-callback/pkg-plist3
6 files changed, 101 insertions, 0 deletions
diff --git a/mail/milter-callback/Makefile b/mail/milter-callback/Makefile
new file mode 100644
index 000000000000..622a511aec6e
--- /dev/null
+++ b/mail/milter-callback/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: milter-callback
+# Date created: 10 Feb 2010
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= milter-callback
+PORTVERSION= 1.5.2
+CATEGORIES= mail
+MASTER_SITES= http://unix.zhegan.in/distfiles/ \
+ CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Milter to perform a envelope-from sender verification on target MX
+
+USE_BZIP2= yes
+USE_RC_SUBR= milter-callback
+
+SUB_FILES= pkg-message
+MAN8= milter-callback.8
+
+# make sure flat distfile gets extracted in ${WRKSRC}
+EXTRACT_AFTER_ARGS= | (${MKDIR} ${WRKSRC}; ${TAR} -xf - --no-same-owner \
+ --no-same-permissions -C ${WRKSRC})
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|" \
+ ${WRKSRC}/${PORTNAME}.c
+ @${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/var/tmp/|/var/run/|' \
+ ${WRKSRC}/${PORTNAME}.conf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MANPREFIX}/man/man8
+
+ ${MKDIR} ${PREFIX}/etc/mail
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf \
+ ${PREFIX}/etc/mail/${PORTNAME}.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/milter-callback/distinfo b/mail/milter-callback/distinfo
new file mode 100644
index 000000000000..e7a21a4edf48
--- /dev/null
+++ b/mail/milter-callback/distinfo
@@ -0,0 +1,3 @@
+MD5 (milter-callback-1.5.2.tar.bz2) = 57582990c638ab6dbb2ebf3752afcc28
+SHA256 (milter-callback-1.5.2.tar.bz2) = f312ca5f45d007333fcb7a5b0b0db9842f933a549d0e759887ecc2be3f788673
+SIZE (milter-callback-1.5.2.tar.bz2) = 1295341
diff --git a/mail/milter-callback/files/milter-callback.in b/mail/milter-callback/files/milter-callback.in
new file mode 100644
index 000000000000..8ec17a4fbd27
--- /dev/null
+++ b/mail/milter-callback/files/milter-callback.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: milter-callback
+# REQUIRE: DAEMON
+# BEFORE: mail
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable `milter-callback':
+#
+# miltercallback_enable="YES"
+#
+
+. "/etc/rc.subr"
+
+name="miltercallback"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/libexec/milter-callback"
+required_files="%%PREFIX%%/etc/mail/milter-callback.conf"
+
+# read configuration and set defaults
+load_rc_config "$name"
+: ${miltercallback_enable="NO"}
+
+run_rc_command "$1"
diff --git a/mail/milter-callback/files/pkg-message.in b/mail/milter-callback/files/pkg-message.in
new file mode 100644
index 000000000000..8688bd2ea57d
--- /dev/null
+++ b/mail/milter-callback/files/pkg-message.in
@@ -0,0 +1,12 @@
+
+================================================================================
+
+- Create %%PREFIX%%/etc/mail/milter-callback.conf
+
+- Add the following line to your sendmail.mc:
+
+ INPUT_MAIL_FILTER(`milter-callback', \
+ `S=unix:/var/run/milter-callback.sock, F=T, T=S:3m;R:6m')
+
+================================================================================
+
diff --git a/mail/milter-callback/pkg-descr b/mail/milter-callback/pkg-descr
new file mode 100644
index 000000000000..8f9a1725fd2b
--- /dev/null
+++ b/mail/milter-callback/pkg-descr
@@ -0,0 +1,9 @@
+milter-callback is a sendmail milter intended to:
+
+ * perform a envelope-from sender verification on target MX
+ * perform an optional envelope-from sender verification on sending peer
+ * drop e-mails from nonexistent hostsparts, mail domains and nonexistent users
+ * log to database all connections processed (only pgsql is supported at this
+ time)
+
+WWW: http://unix.zhegan.in
diff --git a/mail/milter-callback/pkg-plist b/mail/milter-callback/pkg-plist
new file mode 100644
index 000000000000..70b09930d5bd
--- /dev/null
+++ b/mail/milter-callback/pkg-plist
@@ -0,0 +1,3 @@
+libexec/milter-callback
+etc/mail/milter-callback.conf.sample
+@dirrmtry etc/mail