aboutsummaryrefslogtreecommitdiff
path: root/mail/mlmmj
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
commit17e550ca2fd180b150f6645ced5f3bb45bc32292 (patch)
treee856fa025c5b15bbef21f621e347c51780662a47 /mail/mlmmj
parentb4599e3d63c3a94b17026b18d1f8ac27faac53fc (diff)
downloadports-17e550ca2fd180b150f6645ced5f3bb45bc32292.tar.gz
ports-17e550ca2fd180b150f6645ced5f3bb45bc32292.zip
Explicitly depend on p5-Digest-MD5 only if PERL_LEVEL < 500703
Explicitly depend on p5-Digest-SHA only if PERL_LEVEL < 501000
Notes
Notes: svn path=/head/; revision=261560
Diffstat (limited to 'mail/mlmmj')
-rw-r--r--mail/mlmmj/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/mail/mlmmj/Makefile b/mail/mlmmj/Makefile
index 20be7abf8510..fd19cee054cb 100644
--- a/mail/mlmmj/Makefile
+++ b/mail/mlmmj/Makefile
@@ -25,8 +25,7 @@ WANT_PHP_WEB= yes
.if defined(WITH_PERL_WEBINTERFACE)
RUN_DEPENDS+= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/CGI/FastTemplate.pm:${PORTSDIR}/www/p5-CGI-FastTemplate \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+ ${SITE_PERL}/CGI/FastTemplate.pm:${PORTSDIR}/www/p5-CGI-FastTemplate
.endif
.if defined(WITH_PERL_WEBINTERFACE)
@@ -55,6 +54,14 @@ MAKE_JOBS_SAFE= yes
MAN1= mlmmj-bounce.1 mlmmj-list.1 mlmmj-maintd.1 mlmmj-make-ml.sh.1 mlmmj-process.1 mlmmj-recieve.1 mlmmj-send.1 mlmmj-sub.1 mlmmj-unsub.1
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PERL_WEBINTERFACE)
+. if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+. endif
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/src/mlmmj-make-ml.sh
@@ -86,4 +93,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/contrib/web/php-admin/conf/* ${PREFIX}/www/mlmmj/php-admin/conf
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>