aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-10-25 22:16:39 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-10-25 22:16:39 +0000
commit17e8b4a7e881dab65c4ceee3ab00284d45dae3d8 (patch)
tree5abe737efe247ffeb8eec0c386916c67b6d19954 /mail/mutt-devel
parentcf8da7b020c80b2f5dd4d15016358efc62b4ef8c (diff)
downloadports-17e8b4a7e881dab65c4ceee3ab00284d45dae3d8.tar.gz
ports-17e8b4a7e881dab65c4ceee3ab00284d45dae3d8.zip
- Add the new option "smime_encrypt_self" to addtionally encrypt
to the default key also - Fix some SGML errors in the manual PR: 58526 Submitted by: maintainer Approved by: krion (implicit)
Notes
Notes: svn path=/head/; revision=92151
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt-devel/files/patch-manual.sgml47
-rw-r--r--mail/mutt-devel/files/patch-smime-self65
-rw-r--r--mail/mutt-devel/files/patch-smime-sender23
-rw-r--r--mail/mutt-devel/scripts/generate-plist2
5 files changed, 119 insertions, 20 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index dc8618b8e214..13f5d4225c8d 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -93,7 +93,7 @@ PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
MAINTAINER?= udo.schweigert@siemens.com
COMMENT?= The Mongrel of Mail User Agents (part Elm, Pine, Mush, mh, etc.)
-DIST_SUBDIR= mutt
+DIST_SUBDIR= mutt
DOCSDIR?= ${PREFIX}/share/doc/mutt
EXAMPLESDIR?= ${PREFIX}/share/examples/mutt
DATADIR?= ${PREFIX}/share/mutt
diff --git a/mail/mutt-devel/files/patch-manual.sgml b/mail/mutt-devel/files/patch-manual.sgml
new file mode 100644
index 000000000000..0d0ddbf69d93
--- /dev/null
+++ b/mail/mutt-devel/files/patch-manual.sgml
@@ -0,0 +1,47 @@
+--- doc/manual.sgml.head Tue Mar 4 08:49:49 2003
++++ doc/manual.sgml.head Sat Oct 25 16:38:09 2003
+@@ -886,34 +886,34 @@
+ defined maps are:
+
+ <descrip>
+-<tag/generic
++<tag/generic/
+ This is not a real menu, but is used as a fallback for all of the other
+ menus except for the pager and editor modes. If a key is not defined in
+ another menu, Mutt will look for a binding to use in this menu. This allows
+ you to bind a key to a certain function in multiple menus instead of having
+ multiple bind statements to accomplish the same task.
+-<tag/alias
++<tag/alias/
+ The alias menu is the list of your personal aliases as defined in your
+ muttrc. It is the mapping from a short alias name to the full email
+ address(es) of the recipient(s).
+-<tag/attach
++<tag/attach/
+ The attachment menu is used to access the attachments on received messages.
+-<tag/browser
++<tag/browser/
+ The browser is used for both browsing the local directory structure, and for
+ listing all of your incoming mailboxes.
+-<tag/editor
++<tag/editor/
+ The editor is the line-based editor the user enters text data.
+-<tag/index
++<tag/index/
+ The index is the list of messages contained in a mailbox.
+-<tag/compose
++<tag/compose/
+ The compose menu is the screen used when sending a new message.
+-<tag/pager
++<tag/pager/
+ The pager is the mode used to display message/attachment data, and help
+ listings.
+-<tag/pgp
++<tag/pgp/
+ The pgp menu is used to select the OpenPGP keys used for encrypting outgoing
+ messages.
+-<tag/postpone
++<tag/postpone/
+ The postpone menu is similar to the index menu, except is used when
+ recalling a message the user was composing, but saved until later.
+ </descrip>
diff --git a/mail/mutt-devel/files/patch-smime-self b/mail/mutt-devel/files/patch-smime-self
new file mode 100644
index 000000000000..424808d3210f
--- /dev/null
+++ b/mail/mutt-devel/files/patch-smime-self
@@ -0,0 +1,65 @@
+--- crypt.c 7 Mar 2003 08:23:27 -0000 3.17
++++ crypt.c 7 May 2003 14:57:00 -0000
+@@ -246,8 +246,18 @@
+ if ((WithCrypto & APPLICATION_SMIME)
+ && (msg->security & APPLICATION_SMIME))
+ {
+- if (!(tmp_pbody = crypt_smime_build_smime_entity (tmp_smime_pbody,
+- keylist)))
++ char *new_keylist = keylist;
++
++ if (SmimeDefaultKey && query_quadoption(OPT_SMIMEENCRYPTSELF, _("Encrypt message to S/MIME Default Key also?")) == M_YES)
++ {
++ int size = mutt_strlen(keylist) + mutt_strlen (SmimeDefaultKey) + 2; /* +1 for NULL, +1 for \n */
++ new_keylist = safe_malloc(size);
++ snprintf(new_keylist, size, "%s%s\n", keylist, SmimeDefaultKey);
++ }
++
++ tmp_pbody = crypt_smime_build_smime_entity (tmp_smime_pbody, new_keylist);
++ safe_free((void **)&new_keylist);
++ if (!tmp_pbody)
+ {
+ /* signed ? free it! */
+ return (-1);
+--- init.h 14 Apr 2003 09:09:53 -0000 3.38
++++ init.h 7 May 2003 14:57:02 -0000
+@@ -1585,6 +1585,11 @@
+ /*
+ */
+
++ { "smime_encrypt_self", DT_QUAD, R_NONE, OPT_SMIMEENCRYPTSELF, M_YES },
++ /*
++ ** .pp
++ ** Encrypt the message to smime_default_key too.
++ */
+ { "smime_timeout", DT_NUM, R_NONE, UL &SmimeTimeout, 300 },
+ /*
+ ** .pp
+diff -u -d -b -B -r3.18 mutt.h
+--- mutt.h Tue Mar 4 08:49:48 2003
++++ mutt.h Sat Oct 25 16:17:56 2003
+@@ -271,6 +271,7 @@
+
+ OPT_PRINT,
+ OPT_INCLUDE,
++ OPT_SMIMEENCRYPTSELF,
+ OPT_DELETE,
+ OPT_MFUPTO,
+ OPT_MIMEFWD,
+--- contrib/smime.rc.orig Sat Mar 2 13:11:35 2002
++++ contrib/smime.rc Sat Oct 25 17:56:28 2003
+@@ -23,9 +23,12 @@
+
+ # The (default) keyfile for signing/decrypting. Uncomment the following
+ # line and replace the keyid with your own.
+-set smime_default_key="12345678.0"
++# set smime_default_key="12345678.0"
++# Uncomment the following line in addition to the one above, if you want that
++# all encrypted messages are also encrypted with your default key.
++# set smime_encrypt_self = yes
+
+-# Uncommen to make mutt ask what key to use when trying to decrypt a message.
++# Uncomment to make mutt ask what key to use when trying to decrypt a message.
+ # It will use the default key above (if that was set) else.
+ # unset smime_decrypt_use_default_key
+
diff --git a/mail/mutt-devel/files/patch-smime-sender b/mail/mutt-devel/files/patch-smime-sender
index 43e1028443cf..a8a9cacf5559 100644
--- a/mail/mutt-devel/files/patch-smime-sender
+++ b/mail/mutt-devel/files/patch-smime-sender
@@ -37,31 +37,18 @@
OPTSDEFAULTDECRYPTKEY,
#endif
#ifdef HAVE_PGP
---- contrib/smime.rc.orig Sat Mar 2 12:59:50 2002
-+++ contrib/smime.rc Fri May 31 17:09:04 2002
-@@ -6,9 +6,12 @@
+--- contrib/smime.rc.orig Sat Oct 25 17:57:35 2003
++++ contrib/smime.rc Sat Oct 25 17:57:35 2003
+@@ -6,8 +6,11 @@
# will be the default method unless the following option is set
set smime_is_default
-# Uncoment this if you don't want to set labels for certificates you add.
+# Uncomment this if you don't want to set labels for certificates you add.
# unset smime_ask_cert_label
-
++
+# Uncomment this if you don't want to check for sender's email address
+# set smime_dont_check_sender = yes
-+
+
# Passphrase expiration
set smime_timeout=300
-
-@@ -23,9 +26,9 @@
-
- # The (default) keyfile for signing/decrypting. Uncomment the following
- # line and replace the keyid with your own.
--set smime_default_key="12345678.0"
-+# set smime_default_key="12345678.0"
-
--# Uncommen to make mutt ask what key to use when trying to decrypt a message.
-+# Uncomment to make mutt ask what key to use when trying to decrypt a message.
- # It will use the default key above (if that was set) else.
- # unset smime_decrypt_use_default_key
-
diff --git a/mail/mutt-devel/scripts/generate-plist b/mail/mutt-devel/scripts/generate-plist
index 0f3f431aaeb3..45881f3a0dc5 100644
--- a/mail/mutt-devel/scripts/generate-plist
+++ b/mail/mutt-devel/scripts/generate-plist
@@ -122,7 +122,7 @@ EOF
fi
if [ "$MUTT_HTML" = "yes" ]; then
- html=366
+ html=367
if [ "$MUTT_COMPRESSED_FOLDERS" = "yes" ]; then
html=$(($html + 5))
fi