aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1997-05-19 13:40:38 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1997-05-19 13:40:38 +0000
commit0beb15f284d573672f8661781153542cbd423773 (patch)
tree8a03ffb2c1250dd2ae4a1ad048d7f53501dd7653 /mail/mutt/Makefile
parent5d9b41e9cf60bb8e524369edcc7af831aafe611a (diff)
downloadports-0beb15f284d573672f8661781153542cbd423773.tar.gz
ports-0beb15f284d573672f8661781153542cbd423773.zip
Back out, commited in wrong directory
Notes
Notes: svn path=/head/; revision=6488
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile68
1 files changed, 15 insertions, 53 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index cca33b5323f5..1bee0c4e0aa6 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -1,75 +1,37 @@
# ex:ts=8
-# New ports collection makefile for: mutt w/pgp hooks
+# New ports collection makefile for: mutt
# Version required: 0.xy
# Date created: Thur July 25, 1996
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.32 1997/05/17 05:34:22 obrien Exp $
+# $Id: Makefile,v 1.28 1997/05/17 05:34:21 obrien Exp $
-BASEDIST= mutt-0.74
-DISTNAME= ${BASEDIST}
-PKGNAME= mutt-pgp-0.74
+DISTNAME= ${PKGNAME}e
+PKGNAME= mutt-0.74
CATEGORIES= mail
-MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/
-MASTER_SITE_OVERRIDE=
+MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/ \
+ ftp://ftp.ibp.fr/pub/unix/mail/mutt/ \
+ ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
+ ftp://ftp.teuto.de/pub/user/lmb/ \
+ ftp://ftp.funet.fi/pub/unix/mail/mutt/
-PATCH_SITES= http://www.frmug.org/mutt/mutt/0.73/ \
- http://www.math.fu-berlin.de/~leitner/mutt/0.73/ \
- http://www.efrei.fr/~parmelan/mutt/0.73/ \
- ftp://www.frmug.org/pub/mutt/mutt/0.73/
+PATCH_SITES= ftp://ftp.nuxi.com/pub/mutt/${PKGNAME:S/^mutt-//}/ \
+ http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
+ http://www.math.fu-berlin.de/~leitner/mutt/${PKGNAME:S/^mutt-//}/ \
+ http://www.efrei.fr/~parmelan/mutt/${PKGNAME:S/^mutt-//}/ \
+ ftp://www.frmug.org/pub/mutt/mutt/${PKGNAME:S/^mutt-//}/
PATCHFILES=
MAINTAINER= obrien@FreeBSD.org
-# Need to define USA_RESIDENT to YES or NO
-RESTRICTED= "USA ITAR export restrictions (has PGP hooks)"
-
DIST_SUBDIR= mutt
+WRKSRC= ${WRKDIR}/${PKGNAME}
#PATCH_DIST_STRIP= -p2
PATCH_DIST_STRIP= -p1
#PATCH_DIST_STRIP=
GNU_CONFIGURE= yes
MAN1= mutt.1
-.if !defined(USA_RESIDENT) || (${USA_RESIDENT} != YES && ${USA_RESIDENT} != yes && ${USA_RESIDENT} != NO && ${USA_RESIDENT} != no)
-pre-fetch:
- @echo
- @echo You must set variable USA_RESIDENT to YES, if you are USA resident,
- @echo or to NO if you aren\'t a USA resident in order to build this package
- @false
-
-.elif defined(USA_RESIDENT)
-.if ${USA_RESIDENT} == YES || ${USA_RESIDENT} == yes
-# can't grab patches from Nuxi unless you are in USA/Canada
-PATCH_SITES:= ftp://ftp.nuxi.com/pub/mutt/${BASEDIST:S/^mutt-//}/ \
- ${PATCH_SITES}
-pre-fetch: # don't use "do-fetch" otherwise we won't get the patches
- @${MKDIR} ${DISTDIR}/${DIST_SUBDIR}
- @(cd ${DISTDIR}/${DIST_SUBDIR} ; \
- if [ ! -f ${DISTFILES} -a ! -f `${BASENAME} ${DISTFILES}` ]; then \
- ${FETCH_CMD} -o /tmp/README.US-only ${MASTER_SITES}README.US-only ; \
- sed -e 's:US-only/.*:&:w /tmp/muttusa.dir' /tmp/README.US-only >/dev/null ; \
- USADISTRIB=`sed -e 's:^.*US-only/::' /tmp/muttusa.dir` ; \
- ${FETCH_CMD} -m ${FETCH_BEFORE_ARGS} ${MASTER_SITES}US-only/$$USADISTRIB/${DISTNAME}${EXTRACT_SUFX} ${FETCH_AFTER_ARGS} ; \
- /bin/rm -f /tmp/README.US-only /tmp/muttusa.dir ; \
- fi)
-FILESDIR= ${.CURDIR}/files.usa
-
-.else #non-USA resident
-DISTNAME= ${BASEDIST}e
-FILESDIR= ${.CURDIR}/files.non_usa
-MASTER_SITES:= ftp://ftp.ibp.fr/pub/unix/mail/mutt/mutt/ \
- ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
- ftp://ftp.teuto.de/pub/user/lmb/ \
- ftp://ftp.funet.fi/pub/unix/mail/mutt/ \
- ${MASTER_SITES}
-# 01.pgp.1 needs to be applied before all others!
-PATCHFILES:= 01.pgp.1 ${PATCHFILES}
-WRKSRC= ${WRKDIR}/${BASEDIST}
-
-.endif # USA resident = yes
-.endif # USA resident set
-
post-install:
@#### don't strip until out of beta peroid