aboutsummaryrefslogtreecommitdiff
path: root/mail/nmh/Makefile
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>2001-06-27 14:41:55 +0000
committerMark Murray <markm@FreeBSD.org>2001-06-27 14:41:55 +0000
commitb6831fc7e96c20f18506bff32b6f570f6c552d37 (patch)
treeac0d9825e9754981df218e2517e9e1f7e7619f28 /mail/nmh/Makefile
parent712b71974369247e51d7e366a79b9506e1fcd684 (diff)
downloadports-b6831fc7e96c20f18506bff32b6f570f6c552d37.tar.gz
ports-b6831fc7e96c20f18506bff32b6f570f6c552d37.zip
Do not spam installed config files - instead install the config files
with '.default' suffixes.
Notes
Notes: svn path=/head/; revision=44508
Diffstat (limited to 'mail/nmh/Makefile')
-rw-r--r--mail/nmh/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index bb7fc16f106b..af1131c2d62d 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -48,6 +48,7 @@
PORTNAME= nmh
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.mhost.com/pub/nmh/ \
${MASTER_SITE_LOCAL}
@@ -97,5 +98,11 @@ post-install:
@PKG_PREFIX='${PREFIX}' ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
chgrp mail ${PREFIX}/bin/inc
${CHMOD} g+s ${PREFIX}/bin/inc
+ for file in ${PREFIX}/etc/nmh/*.default ; do \
+ if [ \! -f $${file%%.default} ] ; then \
+ cp $$file $${file%%.default} ; \
+ chmod u+w $${file%%.default} ; \
+ fi \
+ done
.include <bsd.port.mk>