aboutsummaryrefslogtreecommitdiff
path: root/mail/openwebmail/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-08-12 16:56:40 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-08-12 16:56:40 +0000
commit7d8948793817e43fbbd0150e3ea820b988819bef (patch)
tree71ace1f3c503dd1eac1f845d98f242dc5c1d8216 /mail/openwebmail/Makefile
parent4a695692d0d083c1948486cf7456d494fa723a9f (diff)
downloadports-7d8948793817e43fbbd0150e3ea820b988819bef.tar.gz
ports-7d8948793817e43fbbd0150e3ea820b988819bef.zip
minor fixes
- add --quiet argument for CPIO - remove the arguments of speedy_suidperl
Notes
Notes: svn path=/head/; revision=116046
Diffstat (limited to 'mail/openwebmail/Makefile')
-rw-r--r--mail/openwebmail/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index e8d7c3eadfab..07ad5512c058 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -115,7 +115,7 @@ pre-fetch:
.endif
pre-patch:
- @${PERL} -pi.bak -e 's,${LOCALBASE}/bin/speedy_suid,${LOCALBASE}/bin/speedy_suidperl,g' ${PATCH_WRKSRC}/uty/*.diff
+ @${PERL} -pi.bak -e 's,${LOCALBASE}/bin/speedy_suid.*,${LOCALBASE}/bin/speedy_suidperl,g' ${PATCH_WRKSRC}/uty/*.diff
post-patch:
@${MV} ${PATCH_WRKSRC}/etc/openwebmail.conf ${PATCH_WRKSRC}/etc/openwebmail.conf-dist
@@ -150,9 +150,9 @@ pre-install:
do-install:
@${MKDIR} ${OWCGIDIR} ${OWDATADIR}
@cd ${WRKSRC}/cgi-bin/openwebmail && ${FIND} . \
- | ${CPIO} -dpum -R ${BINOWN}:mail ${OWCGIDIR}
+ | ${CPIO} -dpum --quiet -R ${BINOWN}:mail ${OWCGIDIR}
@cd ${WRKSRC}/data/openwebmail && ${FIND} . \
- | ${CPIO} -dpum -R ${SHAREOWN}:${SHAREGRP} ${OWDATADIR}
+ | ${CPIO} -dpum --quiet -R ${SHAREOWN}:${SHAREGRP} ${OWDATADIR}
.if !exists(${OWCGIDIR}/etc/openwebmail.conf)
@${CP} ${OWCGIDIR}/etc/openwebmail.conf-dist ${OWCGIDIR}/etc/openwebmail.conf
.endif