aboutsummaryrefslogtreecommitdiff
path: root/mail/openwebmail
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-10-13 07:21:02 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-10-13 07:21:02 +0000
commit1b600ff552940a2ddedfc3243fdc2f3e2d5de229 (patch)
tree93ce35d893b6ede9a0a33c727551568d4077da3b /mail/openwebmail
parent0e4889b1d7bbe8f505a2ceb3750a6b6d3c5f8c12 (diff)
downloadports-1b600ff552940a2ddedfc3243fdc2f3e2d5de229.tar.gz
ports-1b600ff552940a2ddedfc3243fdc2f3e2d5de229.zip
WITH_SPEEDYCGI needs suidperl enabled under perl 5.8.4 or above,
so, disable it first, and enable it again if perl exists and enabled suidperl
Notes
Notes: svn path=/head/; revision=119159
Diffstat (limited to 'mail/openwebmail')
-rw-r--r--mail/openwebmail/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index fd201a6cfb64..d5a11b013563 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -42,13 +42,21 @@ OPTIONS= ANTIWORD "AntiWord" off \
.include <bsd.port.pre.mk>
-# WITH_SPEEDYCGI needs suidperl enabled under perl5.8
-PERL_V!= ${PERL} -V
-.if ${PERL_LEVEL} > 500800 && ${PERL_V:M*dosuid*} == "" && defined(WITH_SPEEDYCGI)
+# WITH_SPEEDYCGI needs suidperl enabled under perl 5.8.4 or above,
+# so, disable it first, and enable it again if perl exists and enabled suidperl
+.if ${PERL_LEVEL} >= 500804 && defined(WITH_SPEEDYCGI)
DISABLE_SPEEDYCGI=yes
WITHOUT_SPEEDYCGI=yes
.undef WITH_SPEEDYCGI
-.endif
+.if exists(${PERL})
+PERL_V!= ${PERL} -V
+.if ${PERL_V:M*dosuid*} != ""
+.undef DISABLE_SPEEDYCGI
+.undef WITHOUT_SPEEDYCGI
+WITH_SPEEDYCGI= yes
+.endif # dosuid
+.endif # exists(${PERL})
+.endif # perl5.8
.if ${PERL_LEVEL} < 500800
RUN_DEPENDS+= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
@@ -114,9 +122,10 @@ post-patch:
.if defined(DISABLE_SPEEDYCGI)
@${ECHO_MSG} ""
@${ECHO_MSG} "WARNING:"
- @${ECHO_MSG} "Your perl doesn't support SUID, so SpeedyCGI support is disabled automatically."
+ @${ECHO_MSG} "Your perl doesn't support SUID, or you don't have perl yet,"
+ @${ECHO_MSG} "so SpeedyCGI support is disabled automatically."
@${ECHO_MSG} "If you want SpeedyCGI support, please reinstall perl with ENABLE_SUIDPERL=yes,"
- @${ECHO_MSG} "and reinstall ${PORTNAME} again."
+ @${ECHO_MSG} "and reinstall ${PORTNAME}."
@${ECHO_MSG} ""
.endif
@${MV} ${PATCH_WRKSRC}/etc/openwebmail.conf ${PATCH_WRKSRC}/etc/openwebmail.conf-dist