aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-MIME/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-08-29 16:17:22 +0000
committerLars Thegler <lth@FreeBSD.org>2004-08-29 16:17:22 +0000
commitd03042efd7fb6b1949cec988a7a696fc636eecc6 (patch)
treeba1095483f964274778833db69c393e12170352a /mail/p5-Email-MIME/Makefile
parent0d2dc10b68c0ac4b84946094c5bad0391a48d349 (diff)
downloadports-d03042efd7fb6b1949cec988a7a696fc636eecc6.tar.gz
ports-d03042efd7fb6b1949cec988a7a696fc636eecc6.zip
Add p5-Email-MIME 1.8, easy MIME message parsing.
Notes
Notes: svn path=/head/; revision=117577
Diffstat (limited to 'mail/p5-Email-MIME/Makefile')
-rw-r--r--mail/p5-Email-MIME/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/mail/p5-Email-MIME/Makefile b/mail/p5-Email-MIME/Makefile
new file mode 100644
index 000000000000..475e227f26e3
--- /dev/null
+++ b/mail/p5-Email-MIME/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-Email-MIME
+# Date created: 2004-08-29
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-MIME
+PORTVERSION= 1.8
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Easy MIME message parsing
+
+BUILD_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/Email/MIME/Encodings.pm:${PORTSDIR}/mail/p5-Email-MIME-Encodings \
+ ${SITE_PERL}/Email/MIME/ContentType.pm:${PORTSDIR}/mail/p5-Email-MIME-ContentType \
+ ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::MIME.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= ${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools
+.endif
+
+.if ${PERL_LEVEL} <= 500503
+post-patch:
+ ${PERL} -pi -e '$$_ = "" if /require 5.006;/;' \
+ -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' \
+ ${WRKSRC}/MIME.pm
+.endif
+
+.include <bsd.port.post.mk>