aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-ListDetector
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-23 15:41:27 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-23 15:41:27 +0000
commit7770f0ec6ea3c163e885b50e72319be373083c12 (patch)
treefe4d83872bfd526cdecccef212c038507fafcb25 /mail/p5-Mail-ListDetector
parented156534bd153974ff5d9fb6f1be1dadf71c228e (diff)
downloadports-7770f0ec6ea3c163e885b50e72319be373083c12.tar.gz
ports-7770f0ec6ea3c163e885b50e72319be373083c12.zip
add p5-Mail-ListDetector 0.15
Perl module for detecting mailing list messages PR: 29665 Reviewed by: ade
Notes
Notes: svn path=/head/; revision=46718
Diffstat (limited to 'mail/p5-Mail-ListDetector')
-rw-r--r--mail/p5-Mail-ListDetector/Makefile43
-rw-r--r--mail/p5-Mail-ListDetector/distinfo1
-rw-r--r--mail/p5-Mail-ListDetector/pkg-comment1
-rw-r--r--mail/p5-Mail-ListDetector/pkg-descr13
-rw-r--r--mail/p5-Mail-ListDetector/pkg-plist21
5 files changed, 79 insertions, 0 deletions
diff --git a/mail/p5-Mail-ListDetector/Makefile b/mail/p5-Mail-ListDetector/Makefile
new file mode 100644
index 000000000000..159af730df0d
--- /dev/null
+++ b/mail/p5-Mail-ListDetector/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-Mail-ListDetector
+# Date created: 13 August 2001
+# Whom: petef
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-ListDetector
+PORTVERSION= 0.15
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Email/Valid.pm:${PORTSDIR}/mail/p5-Email-Valid \
+ ${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Mail::ListDetector.3 \
+ Mail::ListDetector::Detector::Base.3 \
+ Mail::ListDetector::Detector::Ezmlm.3 \
+ Mail::ListDetector::Detector::Listar.3 \
+ Mail::ListDetector::Detector::Mailman.3 \
+ Mail::ListDetector::Detector::Majordomo.3 \
+ Mail::ListDetector::Detector::RFC2369.3 \
+ Mail::ListDetector::Detector::Smartlist.3 \
+ Mail::ListDetector::Detector::Yahoogroups.3 \
+ Mail::ListDetector::List.3
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/examples/Mail-ListDetector
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/sample.pl \
+ ${PREFIX}/share/examples/Mail-ListDetector
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-ListDetector/distinfo b/mail/p5-Mail-ListDetector/distinfo
new file mode 100644
index 000000000000..2ba7cf95b3f5
--- /dev/null
+++ b/mail/p5-Mail-ListDetector/distinfo
@@ -0,0 +1 @@
+MD5 (Mail-ListDetector-0.15.tar.gz) = 4db1808a06539751b8331ed4232c5df8
diff --git a/mail/p5-Mail-ListDetector/pkg-comment b/mail/p5-Mail-ListDetector/pkg-comment
new file mode 100644
index 000000000000..49d6f529018c
--- /dev/null
+++ b/mail/p5-Mail-ListDetector/pkg-comment
@@ -0,0 +1 @@
+Perl module for detecting mailing list messages
diff --git a/mail/p5-Mail-ListDetector/pkg-descr b/mail/p5-Mail-ListDetector/pkg-descr
new file mode 100644
index 000000000000..288654f4056a
--- /dev/null
+++ b/mail/p5-Mail-ListDetector/pkg-descr
@@ -0,0 +1,13 @@
+This module analyzses a Mail::Internet object and returns a
+Mail::ListDetector::List object representing the mailing list the
+email was sent to, if any.
+
+The RFC2369 mailing list detector is also capable of matching some
+Mailman and Ezmlm messages. It is deliberately checked last to allow
+the more specific Mailman and Ezmlm parsing to happen first, and
+more accurately identify the type of mailing list involved.
+
+WWW: http://search.cpan.org/search?dist=Mail-ListDetector
+
+- Pete
+petef@FreeBSD.org
diff --git a/mail/p5-Mail-ListDetector/pkg-plist b/mail/p5-Mail-ListDetector/pkg-plist
new file mode 100644
index 000000000000..580690e1d0dd
--- /dev/null
+++ b/mail/p5-Mail-ListDetector/pkg-plist
@@ -0,0 +1,21 @@
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/Ezmlm.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/Listar.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/Mailman.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/Majordomo.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/RFC2369.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/Smartlist.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector/Yahoogroups.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/List.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Mail/ListDetector/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/ListDetector/.packlist
+share/examples/Mail-ListDetector/sample.pl
+@dirrm share/examples/Mail-ListDetector
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/ListDetector
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Mail/ListDetector
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Mail 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector/Detector
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Mail/ListDetector
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Mail 2>/dev/null || true