aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Net-SMTP_auth
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 00:12:59 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 00:12:59 +0000
commit87faabe2dca9100a7e8d84bf7dad7b79e37546d6 (patch)
treec97618b2e3c396dcf74bf793bc7424fbac73e45f /mail/p5-Net-SMTP_auth
parente0467e5a541411e476bda555be372c46c3f6148f (diff)
downloadports-87faabe2dca9100a7e8d84bf7dad7b79e37546d6.tar.gz
ports-87faabe2dca9100a7e8d84bf7dad7b79e37546d6.zip
Net::SMTP_auth implements a client interface to the SMTP and ESMTP protocol
AUTH service extension, enabling a perl5 application to talk to and authenticate against SMTP servers. This documentation assumes that you are familiar with the concepts of the SMTP protocol described in RFC821 and with the AUTH service extension described in RFC2554. WWW: http://search.cpan.org/dist/Net-SMTP_auth/
Notes
Notes: svn path=/head/; revision=175965
Diffstat (limited to 'mail/p5-Net-SMTP_auth')
-rw-r--r--mail/p5-Net-SMTP_auth/Makefile37
-rw-r--r--mail/p5-Net-SMTP_auth/distinfo3
-rw-r--r--mail/p5-Net-SMTP_auth/pkg-descr7
-rw-r--r--mail/p5-Net-SMTP_auth/pkg-plist6
4 files changed, 53 insertions, 0 deletions
diff --git a/mail/p5-Net-SMTP_auth/Makefile b/mail/p5-Net-SMTP_auth/Makefile
new file mode 100644
index 000000000000..e87a8e367a8d
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Net-SMTP_auth
+# Date created: 2006-10-31
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMTP_auth
+PORTVERSION= 0.08
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Simple Mail Transfer Protocol Client with AUTHentication
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
+ ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SMTP_auth.3
+
+.include <bsd.port.pre.mk>
+
+#.if ${PERL_LEVEL} < 500600
+#IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+#.endif
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Net-SMTP_auth/distinfo b/mail/p5-Net-SMTP_auth/distinfo
new file mode 100644
index 000000000000..a0a98c9d33e6
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SMTP_auth-0.08.tar.gz) = 23a911893c92c7c26ab9a78882691d9c
+SHA256 (Net-SMTP_auth-0.08.tar.gz) = d6ff0b477394801f97b63a985c223989d904e24a10ff8ddcb3b52de8fb025a03
+SIZE (Net-SMTP_auth-0.08.tar.gz) = 5365
diff --git a/mail/p5-Net-SMTP_auth/pkg-descr b/mail/p5-Net-SMTP_auth/pkg-descr
new file mode 100644
index 000000000000..baab12808247
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/pkg-descr
@@ -0,0 +1,7 @@
+Net::SMTP_auth implements a client interface to the SMTP and ESMTP protocol
+AUTH service extension, enabling a perl5 application to talk to and
+authenticate against SMTP servers. This documentation assumes that you are
+familiar with the concepts of the SMTP protocol described in RFC821 and with
+the AUTH service extension described in RFC2554.
+
+WWW: http://search.cpan.org/dist/Net-SMTP_auth/
diff --git a/mail/p5-Net-SMTP_auth/pkg-plist b/mail/p5-Net-SMTP_auth/pkg-plist
new file mode 100644
index 000000000000..138a54786733
--- /dev/null
+++ b/mail/p5-Net-SMTP_auth/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP_auth/.packlist
+%%SITE_PERL%%/Net/SMTP_auth.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMTP_auth
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net