aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-SES/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-05-09 07:16:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-05-09 07:16:38 +0000
commitc7e7593a9d95ab2fcbd8fc3a09b6b71a3dfbdacd (patch)
treee2bc64b5dae70a170a91febda0eeda52fc367ebc /mail/p5-SES/Makefile
parentb4f8b532f452bc20e16c8c2fc78ac0825b6828f2 (diff)
downloadports-c7e7593a9d95ab2fcbd8fc3a09b6b71a3dfbdacd.tar.gz
ports-c7e7593a9d95ab2fcbd8fc3a09b6b71a3dfbdacd.zip
- Add p5-SES
Perl module of Amazon Simple Email Services WWW: http://aws.amazon.com/code/Amazon-SES/8945574369528337 PR: ports/156713 Submitted by: Stephon Chen <stephon@pixnet.tw>
Notes
Notes: svn path=/head/; revision=273847
Diffstat (limited to 'mail/p5-SES/Makefile')
-rw-r--r--mail/p5-SES/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/mail/p5-SES/Makefile b/mail/p5-SES/Makefile
new file mode 100644
index 000000000000..4c90f3a88135
--- /dev/null
+++ b/mail/p5-SES/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-SES
+# Date created: 2011-04-29
+# Whom: Stephon Chen <stephon@pixnet.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SES
+PORTVERSION= 1.00
+CATEGORIES= mail perl5
+MASTER_SITES= http://aws-catalog-download-files.s3.amazonaws.com/
+PKGNAMEPREFIX= p5-
+DISTNAME= Amazon${PORTNAME}-2011-03-03
+
+MAINTAINER= stephon@pixnet.tw
+COMMENT= Perl module of Amazon Simple Email Services
+
+RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/bin
+
+PLIST_FILES= bin/ses-get-stats.pl \
+ bin/ses-send-email.pl \
+ bin/ses-verify-email-address.pl \
+ %%SITE_PERL%%/SES.pm
+
+SCRIPTS= ses-get-stats.pl ses-send-email.pl ses-verify-email-address.pl
+
+post-extract:
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e '1 s|/usr/bin/perl|${PERL}|' ${SCRIPTS}
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/SES.pm ${PREFIX}/${SITE_PERL_REL}/
+
+.include <bsd.port.mk>