aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-ZConf-Mail
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 17:44:55 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 17:44:55 +0000
commit7baa3768c103f72e343fcafb111e9423beab9534 (patch)
treeb2cb10e825af1c547931f657e56cfb25e652c8a7 /mail/p5-ZConf-Mail
parentd96e62226375af17679d3fb66a31a8b8b9358c4f (diff)
downloadports-7baa3768c103f72e343fcafb111e9423beab9534.tar.gz
ports-7baa3768c103f72e343fcafb111e9423beab9534.zip
This module implements various functions needed for making a ZConf backed mail
cleint. It also currently includes two small utilities, listed below. zcmailcompose - Composes a mail message and sends it using the specified account. zcgetmail - A getmail replacement using ZConf::Mail. WWW: http://search.cpan.org/dist/ZConf-Mail/ PR: ports/ports/130564 Submitted by: Zane C, Bowers <vvelox at vvelox.net>
Notes
Notes: svn path=/head/; revision=226899
Diffstat (limited to 'mail/p5-ZConf-Mail')
-rw-r--r--mail/p5-ZConf-Mail/Makefile34
-rw-r--r--mail/p5-ZConf-Mail/distinfo3
-rw-r--r--mail/p5-ZConf-Mail/pkg-descr9
-rw-r--r--mail/p5-ZConf-Mail/pkg-plist7
4 files changed, 53 insertions, 0 deletions
diff --git a/mail/p5-ZConf-Mail/Makefile b/mail/p5-ZConf-Mail/Makefile
new file mode 100644
index 000000000000..bdf53917d044
--- /dev/null
+++ b/mail/p5-ZConf-Mail/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-ZConf-Mail
+# Date created: 2009-01-14
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZConf-Mail
+PORTVERSION= 0.0.0
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Misc mail client functions backed by ZConf
+
+RUN_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/ZConf.pm:${PORTSDIR}/net/p5-ZConf \
+ ${SITE_PERL}/Email/Simple/Creator.pm:${PORTSDIR}/mail/p5-Email-Simple-Creator \
+ ${SITE_PERL}/Mail/IMAPTalk.pm:${PORTSDIR}/mail/p5-Mail-IMAPTalk \
+ ${SITE_PERL}/Mail/IMAPTalk.pm:${PORTSDIR}/mail/p5-Mail-IMAPTalk \
+ ${SITE_PERL}/Mail/POP3Client.pm:${PORTSDIR}/mail/p5-Mail-POP3Client \
+ ${SITE_PERL}/Net/SMTP_auth.pm:${PORTSDIR}/mail/p5-Net-SMTP_auth \
+ ${SITE_PERL}/Net/SMTP/TLS.pm:${PORTSDIR}/mail/p5-Net-SMTP-TLS \
+ ${SITE_PERL}/Mail/Box.pm:${PORTSDIR}/mail/p5-Mail-Box \
+ ${SITE_PERL}/Curses/UI.pm:${PORTSDIR}/devel/p5-Curses-UI \
+ ${SITE_PERL}/IO/MultiPipe.pm:${PORTSDIR}/devel/p5-IO-MultiPipe
+
+PERL_CONFIGURE= yes
+
+MAN3= ZConf::Mail.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-ZConf-Mail/distinfo b/mail/p5-ZConf-Mail/distinfo
new file mode 100644
index 000000000000..f3497623f70d
--- /dev/null
+++ b/mail/p5-ZConf-Mail/distinfo
@@ -0,0 +1,3 @@
+MD5 (ZConf-Mail-0.0.0.tar.gz) = f3ba77ee987db2dccf51d42bdbeca501
+SHA256 (ZConf-Mail-0.0.0.tar.gz) = ee2e8c151b5fe4500d00af70b1ff86bf4ebc2141ba61c1d38361d38699a9329f
+SIZE (ZConf-Mail-0.0.0.tar.gz) = 13694
diff --git a/mail/p5-ZConf-Mail/pkg-descr b/mail/p5-ZConf-Mail/pkg-descr
new file mode 100644
index 000000000000..1f19fcbe8093
--- /dev/null
+++ b/mail/p5-ZConf-Mail/pkg-descr
@@ -0,0 +1,9 @@
+This module implements various functions needed for making a ZConf backed mail
+cleint. It also currently includes two small utilities, listed below.
+
+zcmailcompose - Composes a mail message and sends it using the specified
+ account.
+zcgetmail - A getmail replacement using ZConf::Mail.
+
+
+WWW: http://search.cpan.org/dist/ZConf-Mail/
diff --git a/mail/p5-ZConf-Mail/pkg-plist b/mail/p5-ZConf-Mail/pkg-plist
new file mode 100644
index 000000000000..04d059cb3c7f
--- /dev/null
+++ b/mail/p5-ZConf-Mail/pkg-plist
@@ -0,0 +1,7 @@
+bin/zcmailcompose
+bin/zcgetmail
+%%SITE_PERL%%/ZConf/Mail.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Mail/.packlist
+@dirrmtry %%SITE_PERL%%/Zconf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Mail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf