aboutsummaryrefslogtreecommitdiff
path: root/mail/pecl-pop3
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-20 15:48:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-20 15:48:03 +0000
commit174c5f7bf8a7097aca5f7d62f4c574543bb883c6 (patch)
tree506bf89f2fa1add0838524826ec4c9f199eaed9f /mail/pecl-pop3
parent5d6190bb0dca8eb14cbe7906e7ffa57a2003ebab (diff)
downloadports-174c5f7bf8a7097aca5f7d62f4c574543bb883c6.tar.gz
ports-174c5f7bf8a7097aca5f7d62f4c574543bb883c6.zip
The POP3 extension makes it possible for a PHP
script to connect to and interact with a POP3 mail server. It is based on the PHP streams interface and requires no external library. WWW: http://pecl.php.net/package/POP3 PR: ports/115366 Submitted by: buganini at gmail.com
Notes
Notes: svn path=/head/; revision=197971
Diffstat (limited to 'mail/pecl-pop3')
-rw-r--r--mail/pecl-pop3/Makefile25
-rw-r--r--mail/pecl-pop3/distinfo3
-rw-r--r--mail/pecl-pop3/files/patch-pop3.c15
-rw-r--r--mail/pecl-pop3/pkg-descr6
4 files changed, 49 insertions, 0 deletions
diff --git a/mail/pecl-pop3/Makefile b/mail/pecl-pop3/Makefile
new file mode 100644
index 000000000000..f9a00f00e619
--- /dev/null
+++ b/mail/pecl-pop3/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pecl-pop3
+# Date created: 10 August 2007
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= pop3
+PORTVERSION= 1.0.2
+CATEGORIES= mail
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= buganini@gmail.com
+COMMENT= POP3 Client Library for PHP
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+PHP_MODNAME= pop3
+
+.include <bsd.port.mk>
diff --git a/mail/pecl-pop3/distinfo b/mail/pecl-pop3/distinfo
new file mode 100644
index 000000000000..0552757c9b87
--- /dev/null
+++ b/mail/pecl-pop3/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/pop3-1.0.2.tgz) = cdbe4f41aa37bcf45e651d5568f3a8d2
+SHA256 (PECL/pop3-1.0.2.tgz) = da74aa68832b4158dc834c6809b2c5315769c97a9a898b84471d6b077e83506c
+SIZE (PECL/pop3-1.0.2.tgz) = 9185
diff --git a/mail/pecl-pop3/files/patch-pop3.c b/mail/pecl-pop3/files/patch-pop3.c
new file mode 100644
index 000000000000..2103783eb62a
--- /dev/null
+++ b/mail/pecl-pop3/files/patch-pop3.c
@@ -0,0 +1,15 @@
+--- pop3.c Fri Aug 10 04:11:56 2007
++++ pop3.c Fri Aug 10 04:12:25 2007
+@@ -172,8 +172,12 @@
+
+ intern = emalloc(sizeof(pop3_object));
+ intern->zo.ce = class_type;
++#if ZEND_MODULE_API_NO >= 20050922
++ intern->zo.guards = NULL;
++#else
+ intern->zo.in_get = 0;
+ intern->zo.in_set = 0;
++#endif
+ intern->zo.properties = NULL;
+ intern->ptr = NULL;
+
diff --git a/mail/pecl-pop3/pkg-descr b/mail/pecl-pop3/pkg-descr
new file mode 100644
index 000000000000..b620931ff4a0
--- /dev/null
+++ b/mail/pecl-pop3/pkg-descr
@@ -0,0 +1,6 @@
+The POP3 extension makes it possible for a PHP
+script to connect to and interact with a POP3 mail server.
+It is based on the PHP streams interface and requires no
+external library.
+
+WWW: http://pecl.php.net/package/POP3