aboutsummaryrefslogtreecommitdiff
path: root/mail/php56-imap
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
commitf23aed7bde4b7e82cbb2943a38f6f60f51038567 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /mail/php56-imap
parentb3f383ce848e6d547e583f3f4ce764dd3c400cb6 (diff)
downloadports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.tar.gz
ports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.zip
Import PHP 5.6 branch!
Notes
Notes: svn path=/head/; revision=367268
Diffstat (limited to 'mail/php56-imap')
-rw-r--r--mail/php56-imap/Makefile10
-rw-r--r--mail/php56-imap/files/patch-config.m442
2 files changed, 52 insertions, 0 deletions
diff --git a/mail/php56-imap/Makefile b/mail/php56-imap/Makefile
new file mode 100644
index 000000000000..fb2e5394f3e0
--- /dev/null
+++ b/mail/php56-imap/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= mail
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -imap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/php56-imap/files/patch-config.m4 b/mail/php56-imap/files/patch-config.m4
new file mode 100644
index 000000000000..ab7120b2c8c8
--- /dev/null
+++ b/mail/php56-imap/files/patch-config.m4
@@ -0,0 +1,42 @@
+--- config.m4.orig 2010-02-07 14:06:54.000000000 +0100
++++ config.m4 2010-03-08 11:56:24.000000000 +0100
+@@ -103,6 +103,8 @@
+ PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
+ [ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir IMAP: pcre install prefix], no, no)
+
+ if test "$PHP_IMAP" != "no"; then
+ PHP_SUBST(IMAP_SHARED_LIBADD)
+@@ -119,6 +121,30 @@
+ fi
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ dnl Check for c-client version 2004
+ AC_EGREP_HEADER(mail_fetch_overview_sequence, $IMAP_INC_DIR/mail.h, [
+ AC_DEFINE(HAVE_IMAP2004,1,[ ])