aboutsummaryrefslogtreecommitdiff
path: root/mail/pop3lite
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
commit789d75c728ef23566a07bf5b9bc2190bf34ff4f1 (patch)
treedc7540d42fa2d5d7c1c74515e3bdbf6ab842cd17 /mail/pop3lite
parentd1a9e827c98542eb35619dffa314cba50fb08b58 (diff)
downloadports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.tar.gz
ports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.zip
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a. -Remove devel/libtool15 and devel/libltdl15. -Fix ports build with libtool22/libltdl22. -Bump ports that depend on libltdl22 due to shared library version change. -Explain what to do update in the UPDATING. It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop and applications in the runtime. With help: marcus and kwm Pointyhat-exp: a few times by pav Tested by: pgollucci, "Romain Tartière" <romain@blogreen.org>, and a few MarcusCom CVS users. Also, I might have missed a few. Repocopy by: marcus Approved by: portmgr
Notes
Notes: svn path=/head/; revision=238781
Diffstat (limited to 'mail/pop3lite')
-rw-r--r--mail/pop3lite/Makefile10
-rw-r--r--mail/pop3lite/files/patch-libtool22145
2 files changed, 153 insertions, 2 deletions
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index 2c2a619e2769..9eca8273735e 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pop3lite
PORTVERSION= 0.2.4a
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +15,20 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A flexible, modular RFC-compliant POP3 daemon
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22 libltdl:22
USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN5= pop3lite.conf.5
MAN8= pop3lite.8
INFO= pop3lite-admin
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/mail/pop3lite/files/patch-libtool22 b/mail/pop3lite/files/patch-libtool22
new file mode 100644
index 000000000000..689e80be2264
--- /dev/null
+++ b/mail/pop3lite/files/patch-libtool22
@@ -0,0 +1,145 @@
+--- bootstrap.mk.orig 2009-07-15 09:34:19.000000000 -0500
++++ bootstrap.mk 2009-07-15 09:34:31.000000000 -0500
+@@ -49,11 +49,7 @@
+ endef
+
+ all: bootstrap
+-update: aclocal.m4 config.h.in Makefile.in ltmain.sh configure \
+- update-libltdl
+-update-libltdl: gnu/libltdl/aclocal.m4 gnu/libltdl/config.h.in \
+- gnu/libltdl/Makefile.in gnu/libltdl/ltmain.sh \
+- gnu/libltdl/configure
++update: aclocal.m4 config.h.in Makefile.in ltmain.sh configure
+
+ check-autoconf check-aclocal check-automake check-libtool \
+ check-libtoolize check-autoheader: check-%:
+@@ -66,42 +62,26 @@
+ fi
+
+ bootstrap: bootstrap-libtoolize bootstrap-aclocal bootstrap-autoheader \
+- bootstrap-automake bootstrap-autoconf bootstrap-ltdl
++ bootstrap-automake bootstrap-autoconf
+
+ bootstrap-libtoolize bootstrap-aclocal bootstrap-autoheader \
+ bootstrap-automake bootstrap-autoconf: bootstrap-%: check-%
+ $($*) $(P3L_$*_OPTIONS)
+
+-bootstrap-ltdl: check-autoconf check-automake check-aclocal check-autoheader
+- cd gnu/libltdl && $(aclocal)
+- cd gnu/libltdl && $(autoheader)
+- cd gnu/libltdl && $(automake) $(P3L_automake_OPTIONS)
+- cd gnu/libltdl && $(autoconf) $(P3L_autoconf_OPTIONS)
+
+-gnu/libltdl/aclocal.m4: gnu/libltdl/configure.ac
+- cd gnu/libltdl && $(aclocal)
+ aclocal.m4: configure.ac
+ $(aclocal) $(P3L_aclocal_OPTIONS)
+
+-gnu/libltdl/config.h.in: gnu/libltdl/aclocal.m4 gnu/libltdl/configure.ac
+- cd gnu/libltdl && $(autoheader)
+- touch $@
+ config.h.in: aclocal.m4 configure.ac
+ $(autoheader) $(P3L_autoheader_OPTIONS)
+ touch $@
+
+-gnu/libltdl/Makefile.in: gnu/libltdl/configure.ac gnu/libltdl/Makefile.am
+- cd gnu/libltdl && $(automake) $(P3L_automake_OPTIONS)
+ Makefile.in: configure.ac Makefile.am
+ $(automake) $(P3L_automake_OPTIONS)
+
+-gnu/libltdl/ltmain.sh: gnu/libltdl/Makefile.am gnu/libltdl/configure.ac
+- cd gnu/libltdl && $(libtoolize) $(P3L_libtoolize_OPTIONS)
+ ltmain.sh: Makefile.am configure.ac
+ $(libtoolize) $(P3L_libtoolize_OPTIONS)
+
+-gnu/libltdl/configure: gnu/libltdl/aclocal.m4 gnu/libltdl/configure.ac
+- cd gnu/libltdl && $(autoconf) $(P3L_autoconf_OPTIONS)
+ configure: aclocal.m4 configure.ac
+ $(autoconf) $(P3L_autoconf_OPTIONS)
+
+@@ -111,4 +91,4 @@
+ .PHONY: check-autoconf check-aclocal check-automake check-libtool \
+ check-libtoolize check-autoheader boostrap boostrap-libtoolize \
+ bootstrap-aclocal bootstrap-autoheader bootstrap-automake \
+- bootstrap-autoconf bootstrap-ltdl update update-libltdl
++ bootstrap-autoconf update
+--- configure.orig 2009-07-15 09:29:11.000000000 -0500
++++ configure 2009-07-15 09:31:35.000000000 -0500
+@@ -300,7 +300,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subdirs_all="$ac_subdirs_all gnu/libltdl"
++ac_subdirs_all="$ac_subdirs_all"
+
+ # Initialize some variables set by options.
+ ac_init_help=
+@@ -3144,15 +3144,8 @@
+
+ fi
+
+- case $enable_ltdl_convenience in
+- no) { { echo "$as_me:3148: error: this package needs a convenience libltdl" >&5
+-echo "$as_me: error: this package needs a convenience libltdl" >&2;}
+- { (exit 1); exit 1; }; } ;;
+- "") enable_ltdl_convenience=yes
+- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
+- esac
+- LIBLTDL='${top_builddir}/'gnu/libltdl/libltdlc.la
+- INCLTDL='-I${top_srcdir}/'gnu/libltdl
++LIBLTDL='-lltdl'
++INCLTDL='-I/usr/local/include'
+
+ # Check whether --enable-shared or --disable-shared was given.
+ if test "${enable_shared+set}" = set; then
+@@ -10374,7 +10367,7 @@
+ P3L_BUILTIN_LIST=`echo "$P3L_BUILTIN_LIST" | sed -e "s% test-modules % %g"`
+ fi
+
+-subdirs="$subdirs gnu/libltdl"
++subdirs="$subdirs"
+
+ if test "x$static_daemon" != "xno"
+ then
+--- gnu/Makefile.in.orig 2009-07-15 09:35:48.000000000 -0500
++++ gnu/Makefile.in 2009-07-15 09:35:51.000000000 -0500
+@@ -138,7 +138,7 @@
+ install_sh = @install_sh@
+ moddocdir = @moddocdir@
+
+-SUBDIRS = getopt libltdl md5
++SUBDIRS = getopt md5
+
+ EXTRA_DIST = README
+ subdir = gnu
+--- src/Makefile.in.orig 2009-07-15 09:37:37.000000000 -0500
++++ src/Makefile.in 2009-07-15 09:37:39.000000000 -0500
+@@ -143,7 +143,7 @@
+ CLEANFILES = *~ TAGS gmon.out builtin-modules.c
+ DISTCLEANFILES = stamp-builtin depcomp
+
+-LTDL_LIB = $(top_builddir)/gnu/libltdl/libltdlc.la
++LTDL_LIB = -lltdl
+
+ @HAVE_MD5_LIB_TRUE@MD5_LIB = -lmd
+ @HAVE_MD5_LIB_FALSE@MD5_LIB = $(top_builddir)/gnu/md5/libmd5.la
+@@ -157,7 +157,6 @@
+ $(EXTRA_CFLAGS)
+
+ INCLUDES = -I$(top_builddir)/includes \
+- -I$(top_srcdir)/gnu/libltdl \
+ -I$(top_srcdir)/includes \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DMODULEDIR=\"$(pkglibdir)\" \
+@@ -204,10 +203,8 @@
+ misc.$(OBJEXT) module.$(OBJEXT) standalone.$(OBJEXT)
+ nodist_pop3lite_OBJECTS = builtin-modules.$(OBJEXT)
+ pop3lite_OBJECTS = $(am_pop3lite_OBJECTS) $(nodist_pop3lite_OBJECTS)
+-@HAVE_MD5_LIB_TRUE@pop3lite_DEPENDENCIES = \
+-@HAVE_MD5_LIB_TRUE@ $(top_builddir)/gnu/libltdl/libltdlc.la
++@HAVE_MD5_LIB_TRUE@pop3lite_DEPENDENCIES =
+ @HAVE_MD5_LIB_FALSE@pop3lite_DEPENDENCIES = \
+-@HAVE_MD5_LIB_FALSE@ $(top_builddir)/gnu/libltdl/libltdlc.la \
+ @HAVE_MD5_LIB_FALSE@ $(top_builddir)/gnu/md5/libmd5.la
+
+ DEFS = @DEFS@