aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-current/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-11-21 15:38:36 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-11-21 15:38:36 +0000
commit8a2cbd2c5c26780a94a2831f72aed48dec5ce716 (patch)
treed162efc59cf03be071de71aa2f87d768d5599a30 /mail/postfix-current/Makefile
parent118eb9fffc5e35611cc3d4ff9ac079ec450ca27d (diff)
downloadports-8a2cbd2c5c26780a94a2831f72aed48dec5ce716.tar.gz
ports-8a2cbd2c5c26780a94a2831f72aed48dec5ce716.zip
Update to latest snapshot
Remove patches and use REINPLACE_CMD where possible PR: 45527 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=70673
Diffstat (limited to 'mail/postfix-current/Makefile')
-rw-r--r--mail/postfix-current/Makefile30
1 files changed, 28 insertions, 2 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 6773690fbcf8..b543abdd9482 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -13,8 +13,8 @@
# POSTFIX_OPTIONS can be set in /etc/make.conf also.
PORTNAME= postfix
-PORTVERSION= 1.1.11-20020917
-PORTREVISION= 1
+PORTVERSION= 1.1.11-20021115
+#PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
@@ -30,6 +30,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= khera@kciLink.com
USE_SUBMAKE= yes
+USE_REINPLACE= yes
MAN1= mailq.1 newaliases.1 postalias.1 postcat.1 postconf.1 postdrop.1 \
postfix.1 postkick.1 postlock.1 postlog.1 postmap.1 postqueue.1 \
@@ -42,6 +43,10 @@ MAN8= bounce.8 cleanup.8 defer.8 error.8 flush.8 lmtp.8 local.8 \
master.8 nqmgr.8 pickup.8 pipe.8 qmgr.8 qmqpd.8 showq.8 smtp.8 \
smtpd.8 spawn.8 trivial-rewrite.8 virtual.8
+# TLS patch adds to MAN8 but doesn't have .html file, so avoid trying to
+# patch it.
+MAN8base=$(MAN8:S/tlsmgr.8//)
+
NO_LATEST_LINK= yes
CONF1= main.cf master.cf access aliases canonical pcre_table regexp_table \
@@ -70,6 +75,27 @@ post-patch:
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
${ECHO} "all: default" >> Makefile)
+pre-patch:
+.for file in ${MAN1}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/man/man1/${file} ${WRKSRC}/html/${file}.html
+.endfor
+.for file in ${MAN5}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/man/man5/${file} ${WRKSRC}/html/${file}.html
+.endfor
+.for file in ${MAN8base}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/man/man8/${file} ${WRKSRC}/html/${file}.html
+.endfor
+.for file in faq rate rewrite uce
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
+ ${WRKSRC}/html/${file}.html
+.endfor
+.for file in ${CONF1}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" ${WRKSRC}/conf/${file}
+.endfor
+
pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL