aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-current
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-07-19 12:59:11 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-07-19 12:59:11 +0000
commit0350c7361c215e53765ba835851134de65c038bd (patch)
tree2fba50d27cd09db025d8b1adf23fc67d58d85c59 /mail/postfix-current
parent6e89799a34eaa84ad6d510ec9cd0f1bbffedf340 (diff)
downloadports-0350c7361c215e53765ba835851134de65c038bd.tar.gz
ports-0350c7361c215e53765ba835851134de65c038bd.zip
* UPDATING
Add entry about OPTIONS and SPF patch in mail/postfix * mail/Makefile Add postfix22 * mail/postfix [1] Update to 2.3.0 Use OPTIONS instead of scripts Add message about unsupported POSTFIX_OPTIONS Remove SPF patch since that's not apply clean Update pkg-descr Change rcNG to rc only Update CONFLICTS * mail/postfix-current Now postfix-current are called postfix-current instead of postfix. Update CONFLICTS Bump PORTREVISION Store OPTIONSFILE in another local to not conflict with mail/postfix Change rcNG to rc only * mail/postfix1 Update CONFLICTS * mail/postfix21 Update CONFLICTS Change rcNG to rc only * mail/postfix22 [2] Update CONFLICTS Change rcNG to rc only Approved by: maintainer [1] Repocopy by: marcus [2]
Notes
Notes: svn path=/head/; revision=168234
Diffstat (limited to 'mail/postfix-current')
-rw-r--r--mail/postfix-current/Makefile37
-rw-r--r--mail/postfix-current/pkg-install2
-rw-r--r--mail/postfix-current/pkg-message2
3 files changed, 14 insertions, 27 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 2280c809c069..e3a9a798a59d 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postfix
DISTVERSION= 2.4-20060711
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
@@ -14,20 +15,21 @@ MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
ftp://ftp.tux.org/pub/net/postfix/experimental/ \
http://mirrors.rootservices.net/postfix/experimental/ \
ftp://ftp.samurai.com/pub/postfix/experimental/
+PKGNAMESUFFIX= -current
DISTNAME= postfix-${DISTVERSION}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= mnag@FreeBSD.org
COMMENT= A secure alternative to widely-used Sendmail
-CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-3].* \
+CONFLICTS= courier-0.* postfix-1.* postfix-2.* \
sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
-NO_LATEST_LINK= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
USE_RC_SUBR= postfix.sh
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" off \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" off \
@@ -74,12 +76,11 @@ MAKEFILEFLAGS+= CC="${CC}" OPT="${CFLAGS}"
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
- MKDIR="${MKDIR}" \
- POSTFIX_OPTIONS="${POSTFIX_OPTIONS}"
+ MKDIR="${MKDIR}"
.include <bsd.port.pre.mk>
-# Default requirement for postfix rcNG
+# Default requirement for postfix rc script
_REQUIRE= DAEMON
.if defined(WITH_PCRE)
@@ -113,7 +114,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
BROKEN= Select only one SASL authentication method
.endif
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
-POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DDEF_SASL_SERVER=\"dovecot\"
+POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DDEF_SERVER_SASL_TYPE=\"dovecot\"
.endif
.if defined(WITH_SASLKRB)
@@ -151,23 +152,23 @@ POSTFIX_AUXLIBS+= -L${BDB_LIB_DIR} -l${BDB_LIB_NAME}
.endif
.if defined(WITH_MYSQL)
-USE_MYSQL=YES
+USE_MYSQL= yes
POSTFIX_CCARGS+= -DHAS_MYSQL -I${LOCALBASE}/include/mysql
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib/mysql -lmysqlclient -lz -lcrypt -lm
_REQUIRE+= mysql
.endif
.if defined(WITH_PGSQL)
-USE_PGSQL=YES
+USE_PGSQL= yes
POSTFIX_CCARGS+= -DHAS_PGSQL -I${LOCALBASE}/include -I${LOCALBASE}/pgsql/include
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -L${LOCALBASE}/pgsql/lib -lpq -lcrypt
_REQUIRE+= postgresql
.endif
.if defined(WITH_OPENLDAP)
-USE_OPENLDAP=YES
+USE_OPENLDAP= yes
.if defined(WITH_OPENLDAP_VER)
-WANT_OPENLDAP_VER=${WITH_OPENLDAP_VER}
+WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
.endif
POSTFIX_CCARGS+= -DHAS_LDAP -I${LOCALBASE}/include
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lldap -llber
@@ -181,7 +182,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lcdb
.endif
.if defined(WITH_NIS)
-POSTFIX_CCARGS+= -DHAS_NIS
+POSTFIX_CCARGS+= -DHAS_NIS
_REQUIRE+= ypserv
.endif
@@ -203,20 +204,6 @@ READMEDIR=${PREFIX}/share/doc/postfix
SUB_LIST+= REQUIRE="${_REQUIRE}"
pre-patch:
-.if defined(POSTFIX_OPTIONS)
- @${ECHO_MSG}
- @${ECHO_MSG}
- @${ECHO_MSG}
- @${ECHO_MSG} "***** ALERT *****"
- @${ECHO_MSG} "POSTFIX_OPTIONS don't work anymore, now"
- @${ECHO_MSG} "${PORTNAME} use OPTIONS, consider use:"
- @${ECHO_MSG} "# make config"
- @${ECHO_MSG}
- @${ECHO_MSG}
- @${ECHO_MSG}
- @sleep 10
-.endif
-
.if defined(WITH_SASL) && !defined(WITH_MYSQL) && exists(${LOCALBASE}/lib/libsasl.a)
@if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | ${GREP} -wq "mysql_init"; then \
${ECHO_MSG}; \
diff --git a/mail/postfix-current/pkg-install b/mail/postfix-current/pkg-install
index 71e11cbeeeaf..9d50ad8ff1dd 100644
--- a/mail/postfix-current/pkg-install
+++ b/mail/postfix-current/pkg-install
@@ -4,7 +4,7 @@
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
-# will make the port/package use defaults which makes postfix replaces
+# will make the port/package use defaults which make postfix replace
# sendmail as much as possible.
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
diff --git a/mail/postfix-current/pkg-message b/mail/postfix-current/pkg-message
index d4bc72bd9c7d..8efe52a59817 100644
--- a/mail/postfix-current/pkg-message
+++ b/mail/postfix-current/pkg-message
@@ -1,4 +1,4 @@
-To enable postfix rcNG startup script please add postfix_enable="YES" in
+To enable postfix rc startup script please add postfix_enable="YES" in
your rc.conf
If you not need sendmail anymore, please add in your rc.conf: