aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix21
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-05-08 20:02:45 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-05-08 20:02:45 +0000
commit8e96515ce13bed2cb89f2d19ee8aa5a26d4f55c3 (patch)
tree572f8ab6e6d51746810b7282ce0a2336faa3fb3b /mail/postfix21
parent707d970ab97fc6d162c87af5e300c7f109359821 (diff)
downloadports-8e96515ce13bed2cb89f2d19ee8aa5a26d4f55c3.tar.gz
ports-8e96515ce13bed2cb89f2d19ee8aa5a26d4f55c3.zip
Add PGSQL support
PR: 37864 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=58735
Diffstat (limited to 'mail/postfix21')
-rw-r--r--mail/postfix21/distinfo1
-rw-r--r--mail/postfix21/scripts/configure.postfix14
2 files changed, 13 insertions, 2 deletions
diff --git a/mail/postfix21/distinfo b/mail/postfix21/distinfo
index 9d93ab04e030..46cd5c159433 100644
--- a/mail/postfix21/distinfo
+++ b/mail/postfix21/distinfo
@@ -1,3 +1,4 @@
MD5 (postfix/postfix-1.1.8.tar.gz) = 3b07a59e8bdb46af8c1d82f085a62d73
MD5 (postfix/pfixtls-0.8.7-1.1.7-0.9.6c.tar.gz) = a00656e4e7fd1e4827c3e805799d2359
MD5 (postfix/postfix-1.1.7+ipv6.patch.gz) = 9564e8e1e3ddfb885bb1ffaaf75c670b
+MD5 (postfix/postfix-pg.postfix-1.1.8.patch) = e0f4d910a6d6648d9b48e2244f2764ba
diff --git a/mail/postfix21/scripts/configure.postfix b/mail/postfix21/scripts/configure.postfix
index 9fe9d65f5056..d723b55f213b 100644
--- a/mail/postfix21/scripts/configure.postfix
+++ b/mail/postfix21/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.20 2002-05-06 19:59:29 dwcjr Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.21 2002-05-08 20:02:45 dwcjr Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -17,6 +17,7 @@ PCRE "Perl Compatible Regular Expressions" OFF \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
+PgSQL "PostgreSQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
@@ -99,6 +100,15 @@ while [ "$1" ]; do
echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz"
echo "MYSQL_SUFFIX= +mysql"
;;
+ \"PgSQL\")
+ echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
+ echo "POSTFIX_CCARGS+= -DHAS_PGSQL -I\${LOCALBASE}/include -I\${LOCALBASE}/pgsql/include"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -L\${LOCALBASE}/pgsql/lib -lpq -lcrypt"
+ echo "PGSQL_SUFFIX= +pgsql"
+ echo "PATCH_SITES+= http://mat.cc/postfix/"
+ echo "PATCHFILES+= postfix-pg.postfix-1.1.8.patch"
+ echo "PATCH_DIST_STRIP= -p1"
+ ;;
\"OpenLDAP\")
echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/libldap.a:\${PORTSDIR}/net/openldap"
echo "POSTFIX_CCARGS+= -DHAS_LDAP -I\${LOCALBASE}/include"
@@ -142,4 +152,4 @@ echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
# we ask the configure questions) doesn't pick up the extensions, but
# any subsequent build will. so "make; make install" will build twice.
# don't do this for now.
-#echo "PKGNAMESUFFIX= \${PCRE_SUFFIX}\${SASL_SUFFIX}\${DB3_SUFFIX}\${MYSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${IPv6_SUFFIX}"
+#echo "PKGNAMESUFFIX= \${PCRE_SUFFIX}\${SASL_SUFFIX}\${DB3_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${IPv6_SUFFIX}"