aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix22/scripts
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-03-04 07:31:25 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-03-04 07:31:25 +0000
commitad1a88f01167098e905896ab7eef4a30a7c95ab9 (patch)
tree61111fc1f2012c83a4250511fb735708cb4353a1 /mail/postfix22/scripts
parent4e097dc65e6a90ff7c5b3c94dcfd5dbf36827049 (diff)
downloadports-ad1a88f01167098e905896ab7eef4a30a7c95ab9.tar.gz
ports-ad1a88f01167098e905896ab7eef4a30a7c95ab9.zip
Batch building of packages for postfix is failing due to PCRE issues.
PR: 48896 Submitted by: Vivek Khera <khera@kcilink.com>
Notes
Notes: svn path=/head/; revision=76835
Diffstat (limited to 'mail/postfix22/scripts')
-rw-r--r--mail/postfix22/scripts/configure.postfix18
1 files changed, 7 insertions, 11 deletions
diff --git a/mail/postfix22/scripts/configure.postfix b/mail/postfix22/scripts/configure.postfix
index bb63ba51c780..8c8bd60686bb 100644
--- a/mail/postfix22/scripts/configure.postfix
+++ b/mail/postfix22/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.30 2003-03-03 12:56:05 nectar Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.31 2003-03-04 07:31:25 leeym Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -9,8 +9,6 @@ tempfile=`mktemp -t checklist`
if [ "${POSTFIX_OPTIONS}" ]; then
set ${POSTFIX_OPTIONS}
-else
- set PCRE
fi
for i; do
@@ -21,7 +19,7 @@ if [ -z "${BATCH}" ]; then
/usr/bin/dialog --title "Postfix configuration options" --clear \
--checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" "$status_PCRE" \
+NOPCRE "DISABLE Perl Compatible Regular Expressions" "$status_NOPCRE" \
SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
TLS "SSL and TLS" "$status_TLS" \
@@ -64,12 +62,10 @@ SUB_TEST="@comment "
while [ "$1" ]; do
case $1 in
- PCRE)
- echo "LIB_DEPENDS+= pcre.0:\${PORTSDIR}/devel/pcre"
- echo "POSTFIX_CCARGS+= -DHAS_PCRE -I\${LOCALBASE}/include"
- echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lpcre"
- echo "PCRE_SUFFIX= +pcre"
- SUB_PCRE=""
+ NOPCRE)
+ echo "WITHOUT_PCRE= yes"
+ echo "NOPCRE_SUFFIX= +nopcre"
+ SUB_NOPCRE=""
;;
SASL)
echo "LIB_DEPENDS+= sasl.8:\${PORTSDIR}/security/cyrus-sasl"
@@ -230,4 +226,4 @@ echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
# we ask the configure questions) doesn't pick up the extensions, but
# any subsequent build will. so "make; make install" will build twice.
# don't do this for now.
-#echo "PKGNAMESUFFIX= \${PCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${IPv6_SUFFIX}"
+#echo "PKGNAMESUFFIX= \${NOPCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${IPv6_SUFFIX}"