aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix26
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-30 17:54:17 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-30 17:54:17 +0000
commitd6b4a77a4a65085ba09ddf6c2dbbd7dc648584a7 (patch)
tree8c27500c28547de4861f64f36c93cb97ce15b27b /mail/postfix26
parent9e1fae484b5b247c833bbcb8682b184badbb41c9 (diff)
downloadports-d6b4a77a4a65085ba09ddf6c2dbbd7dc648584a7.tar.gz
ports-d6b4a77a4a65085ba09ddf6c2dbbd7dc648584a7.zip
- Add cdb map lookups
PR: ports/84382 Submitted by: IWAMOTO Kouichi <sue@iwmt.org> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=141483
Diffstat (limited to 'mail/postfix26')
-rw-r--r--mail/postfix26/scripts/configure.postfix11
1 files changed, 9 insertions, 2 deletions
diff --git a/mail/postfix26/scripts/configure.postfix b/mail/postfix26/scripts/configure.postfix
index e34694ca7318..071ee76eb8e3 100644
--- a/mail/postfix26/scripts/configure.postfix
+++ b/mail/postfix26/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.63 2005-07-06 16:37:35 jylefort Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.64 2005-08-30 17:54:17 garga Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -34,6 +34,7 @@ DB43 "Berkeley DB4.3 (required if SASL also built with DB4.3)" "$status_DB43" \
MySQL "MySQL map lookups (choose version with WITH_MYSQL_VER)" "$status_MySQL" \
PgSQL "PostgreSQL map lookups (choose with DEFAULT_PGSQL_VER)" "$status_PgSQL" \
OpenLDAP "OpenLDAP map lookups (choose ver. with WITH_OPENLDAP_VER)" "$status_OpenLDAP" \
+CDB "CDB map lookups" "$status_CDB" \
NIS "NIS map lookups" "$status_NIS" \
VDA "VDA (Virtual Delivery Agent)" "$status_VDA" \
Test "SMTP/LMTP test server and generator" "$status_Test" \
@@ -205,6 +206,12 @@ while [ "$1" ]; do
/bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lldap -llber"
/bin/echo "OPENLDAP_SUFFIX= +openldap"
;;
+ CDB)
+ /bin/echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/libcdb.a:\${PORTSDIR}/databases/tinycdb"
+ /bin/echo "POSTFIX_CCARGS+= -DHAS_CDB -I\${LOCALBASE}/include"
+ /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lcdb"
+ /bin/echo "CDB_SUFFIX= +cdb"
+ ;;
NIS)
/bin/echo "POSTFIX_CCARGS+= -DHAS_NIS"
/bin/echo "NIS_SUFFIX= +nis"
@@ -253,4 +260,4 @@ fi
# we ask the configure questions) doesn't pick up the extensions, but
# any subsequent build will. so "make; make install" will build twice.
# don't do this for now.
-#/bin/echo "PKGNAMESUFFIX= \${NOPCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${NIS_SUFFIX}\${SPF_SUFFIX}"
+#/bin/echo "PKGNAMESUFFIX= \${NOPCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${CDB_SUFFIX}\${TLS_SUFFIX}\${NIS_SUFFIX}\${SPF_SUFFIX}"