aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix26
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-11-27 06:48:55 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-11-27 06:48:55 +0000
commit451f311149806c8bbe63bebedb25d2945e1950ed (patch)
treebace2cd1b8ce0e33cc32b08b91937d06933ec3f5 /mail/postfix26
parent64f1e9a4b4114f99ef4d9c56074f4cc1be2c90ad (diff)
downloadports-451f311149806c8bbe63bebedb25d2945e1950ed.tar.gz
ports-451f311149806c8bbe63bebedb25d2945e1950ed.zip
Update to 2.6.8, fix a typo in CONFLICTS, and modify
pkg-install script to check whether Postfix is already enabled in mailer.conf[1]. Submitted by: ohauer (via email) [1]
Notes
Notes: svn path=/head/; revision=265257
Diffstat (limited to 'mail/postfix26')
-rw-r--r--mail/postfix26/Makefile4
-rw-r--r--mail/postfix26/distinfo6
-rw-r--r--mail/postfix26/files/pkg-install.in32
3 files changed, 25 insertions, 17 deletions
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index 3eaf3e8dfc3a..3fd97f7124cd 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.6.7
+PORTVERSION= 2.6.8
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -23,7 +23,7 @@ COMMENT= A secure alternative to widely-used Sendmail
VDAVERSION= 2.6.5
CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-57-9].* postfix-current-2.* \
- sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
+ sendmail-8.* sendmail+*-8.* smail-3.* zmailer-2.*
NO_LATEST_LINK= yes
USE_SUBMAKE= yes
diff --git a/mail/postfix26/distinfo b/mail/postfix26/distinfo
index 69509a3083c2..6c910afa239e 100644
--- a/mail/postfix26/distinfo
+++ b/mail/postfix26/distinfo
@@ -1,6 +1,4 @@
-MD5 (postfix/postfix-2.6.7.tar.gz) = d82e78cb5ffd3528d4fe0aa8626f4923
-SHA256 (postfix/postfix-2.6.7.tar.gz) = 7070003cb8d2e89e9c018220c5cac54ab91f68519d9daa3126bf32f5bbcf0594
-SIZE (postfix/postfix-2.6.7.tar.gz) = 3327583
-MD5 (postfix/postfix-2.6.5-vda-ng.patch.gz) = 43e54d0a1a016b90d15a1bd231e6fa38
+SHA256 (postfix/postfix-2.6.8.tar.gz) = 9702d867856eb386616d70154bf12009700ff8805df4895b1cc86158651f8fd6
+SIZE (postfix/postfix-2.6.8.tar.gz) = 3329462
SHA256 (postfix/postfix-2.6.5-vda-ng.patch.gz) = e1c04e9d268dc84832334997e1f593af9877dbd5030708280427a0dc4452e797
SIZE (postfix/postfix-2.6.5-vda-ng.patch.gz) = 12435
diff --git a/mail/postfix26/files/pkg-install.in b/mail/postfix26/files/pkg-install.in
index d40b5b63dea1..6b67fe4b5982 100644
--- a/mail/postfix26/files/pkg-install.in
+++ b/mail/postfix26/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/files/pkg-install.in,v 1.4 2010-03-04 13:52:09 itetcu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/files/pkg-install.in,v 1.5 2010-11-27 06:48:55 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -13,6 +13,7 @@ DAEMONDIR=${DAEMONDIR:=%%DAEMONDIR%%}
READMEDIR=${READMEDIR:=%%READMEDIR%%}
BATCH=${BATCH:=no}
POSTFIX_DEFAULT_MTA=${POSTFIX_DEFAULT_MTA:=no}
+MC=/etc/mail/mailer.conf
if [ "${POSTFIX_DEFAULT_MTA}" = "no" ]; then
DEFAULT_REPLACE_MAILERCONF=n
@@ -144,15 +145,24 @@ replace() {
}
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^send-mail.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^mailq.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^newaliases.*${PREFIX}/sbin/sendmail" ${MC}
+ ret=$?
+ if [ ${ret} -ne 0 ]; then
+ if yesno "Would you like to activate Postfix in ${MC}" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f ${MC} ${MC}.old
+ echo "#" > ${MC}
+ echo -n "# Execute the Postfix sendmail program" >> ${MC}
+ echo ", named ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "#" >> ${MC}
+ echo "sendmail ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "send-mail ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "mailq ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "newaliases ${PREFIX}/sbin/sendmail" >> ${MC}
+ fi
+ else
+ echo "Postfix already activated in ${MC}"
fi
fi