aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-07-26 01:49:28 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-07-26 01:49:28 +0000
commitd56e5eb7da85c86f483901245e78f7afa333f815 (patch)
tree400bb89a5f2aa3a1482b01f8f1fa5c295478a7a6 /mail/postfix
parent0d6bf530f37cf6339c616d2c672ac4110571bbfd (diff)
downloadports-d56e5eb7da85c86f483901245e78f7afa333f815.tar.gz
ports-d56e5eb7da85c86f483901245e78f7afa333f815.zip
Update to 2.8.4 and use the ports framework to
create USERS and GROUPS. Also remove replace() function from pkg-install script. PR: ports/158765 Submitted by: ohauer
Notes
Notes: svn path=/head/; revision=278342
Diffstat (limited to 'mail/postfix')
-rw-r--r--mail/postfix/Makefile7
-rw-r--r--mail/postfix/distinfo4
-rw-r--r--mail/postfix/files/pkg-install.in72
3 files changed, 6 insertions, 77 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 66dd1d58ecfb..e7f80cd32ad8 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.8.3
+PORTVERSION= 2.8.4
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -29,6 +29,8 @@ CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-79].* postfix-base-2.[0-79].* \
IS_INTERACTIVE= yes
.endif
+USERS= postfix
+GROUPS= mail maildrop postfix
MAKE_JOBS_SAFE= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
@@ -348,9 +350,6 @@ do-configure:
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
${ECHO} "all: default" >> Makefile)
-pre-su-install:
- @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
@cd ${WRKSRC} && ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
config_directory=${ETCDIR} \
diff --git a/mail/postfix/distinfo b/mail/postfix/distinfo
index 2b3b3a25a3ce..8b8542b7c895 100644
--- a/mail/postfix/distinfo
+++ b/mail/postfix/distinfo
@@ -1,5 +1,5 @@
-SHA256 (postfix/postfix-2.8.3.tar.gz) = 288267caede6ea1c4f155855395aa957998909a4968af431b8057062f7d60b49
-SIZE (postfix/postfix-2.8.3.tar.gz) = 3645105
+SHA256 (postfix/postfix-2.8.4.tar.gz) = 979a85b06de1a85be121bfb685e590da9a1441b08b16a89a5e4abc7f1de29df5
+SIZE (postfix/postfix-2.8.4.tar.gz) = 3646391
SHA256 (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = e5c38e5bc226cab109c02a4e530ab1aefd3bb06f2169f3e052bdf83d2727aacc
SIZE (postfix/postfix-2.8.0-libspf2-1.2.x-0.patch.gz) = 8191
SHA256 (postfix/postfix-vda-v10-2.8.1.patch) = 13ca7430b68dc19e21ee26c1c1109e1527a656777fa2f224cd3ce2d594435f12
diff --git a/mail/postfix/files/pkg-install.in b/mail/postfix/files/pkg-install.in
index 5aabca2e4dbf..09d33bcc5362 100644
--- a/mail/postfix/files/pkg-install.in
+++ b/mail/postfix/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix/files/pkg-install.in,v 1.4 2010-11-27 06:48:50 sahil Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix/files/pkg-install.in,v 1.5 2011-07-26 01:49:28 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -56,63 +56,6 @@ yesno() {
done
}
-if [ "$2" = "PRE-INSTALL" ]; then
- USER=postfix
- UID=125
- GROUP=postfix
- GID=125
- GROUP2=maildrop
- GID2=126
-
- if /usr/sbin/pw groupshow "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw groupshow "${GROUP2}" 2>/dev/null; then
- echo "You already have a group \"${GROUP2}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP2} -g ${GID2}; then
- echo "Added group \"${GROUP2}\"."
- else
- echo "Adding group \"${GROUP2}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if /usr/sbin/pw useradd ${USER} -u ${UID} -g ${GROUP} -h - -d /var/spool/postfix -s ${NOLOGIN} -c "Postfix Mail System"; then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw show group mail | grep -q "${USER}" 2>/dev/null; then
- echo "You already have user \"${USER}\" in group \"mail\", so I will use it."
- else
- echo "You need user \"${USER}\" added to group \"mail\"."
- if yesno "Would you like me to add it" y; then
- /usr/sbin/pw groupmod mail -m ${USER} || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-fi
if [ "$2" = "POST-INSTALL" ]; then
SAMPLES="main.cf master.cf"
@@ -130,19 +73,6 @@ if [ "$2" = "POST-INSTALL" ]; then
upgrade-package
fi
-replace() {
- local orig repl
-
- orig=$1
- repl=$2
- if [ -e ${orig} ]; then
- /bin/mv -f ${orig} ${orig}.OFF
- /bin/chmod 0 ${orig}.OFF
- fi
- if [ -e ${repl} ]; then
- /bin/ln -s ${repl} ${orig}
- fi
-}
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \