aboutsummaryrefslogtreecommitdiff
path: root/mail/premail
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2000-10-12 00:42:08 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2000-10-12 00:42:08 +0000
commitdbbf489035234e65894a3ceb2dc1c4bc337d2b50 (patch)
tree85fe2953deb5a54b6f7fadd96c8ba2da325d3ad5 /mail/premail
parentcd756a963ddfd59f83deca797b9b8d54f79f2a1a (diff)
downloadports-dbbf489035234e65894a3ceb2dc1c4bc337d2b50.tar.gz
ports-dbbf489035234e65894a3ceb2dc1c4bc337d2b50.zip
Try more hard to find proper nym server when alias@nym form is given - reject
non-nym servers automatically
Notes
Notes: svn path=/head/; revision=33718
Diffstat (limited to 'mail/premail')
-rw-r--r--mail/premail/Makefile1
-rw-r--r--mail/premail/files/patch-aa57
2 files changed, 46 insertions, 12 deletions
diff --git a/mail/premail/Makefile b/mail/premail/Makefile
index a17c51fb7a9e..b0a2204fff5a 100644
--- a/mail/premail/Makefile
+++ b/mail/premail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= premail
PORTVERSION= 0.46
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= ftp://ftp.jpunix.com/pub/remailer-tools/ \
ftp://ftp.kiarchive.ru/pub/unix/crypto/
diff --git a/mail/premail/files/patch-aa b/mail/premail/files/patch-aa
index d53762a683a8..190bb7b2f593 100644
--- a/mail/premail/files/patch-aa
+++ b/mail/premail/files/patch-aa
@@ -1,5 +1,5 @@
---- premail.orig Sat Oct 25 02:19:07 1997
-+++ premail Thu Jul 6 11:55:51 2000
+--- premail.old Sat Oct 25 02:19:07 1997
++++ premail Thu Oct 12 04:33:18 2000
@@ -2,7 +2,7 @@
#
# premail, an e-mail privacy package
@@ -483,7 +483,40 @@
# print STDERR "+ $invoc\n";
if (system ($invoc)) {
print STDERR "Edit failed.\n";
-@@ -5495,6 +5544,7 @@
+@@ -5350,6 +5399,11 @@
+ $addrtail = $address{$rem};
+ $addrtail =~ s/^([^\@]+)\@//;
+ if ($addrtail2 eq $addrtail) {
++ if (!$options{$rem}) {
++ next;
++ }
++ @options = split (/ /, $options{$rem});
++ next unless (&member ('newnym', @options));
+ $remailer = $rem;
+ }
+ }
+@@ -5427,6 +5481,20 @@
+ $addrtail = $address{$rem};
+ $addrtail =~ s/^([^\@]+)\@//;
+ if ($addrtail2 eq $addrtail) {
++ if (!$options{$rem}) {
++ next;
++ }
++ @options = split (/ /, $options{$rem});
++ next unless (&member ('newnym', @options));
++ if (&member ('newnym', @options)) {
++ ;
++ }
++ elsif (&member ('alpha', @options)) {
++ next if ($importnym);
++ }
++ else {
++ next;
++ }
+ $remailer = $rem;
+ }
+ }
+@@ -5495,6 +5563,7 @@
}
}
}
@@ -491,7 +524,7 @@
if ($#args >= 1) {
$to = $args[1];
} elsif ($#args < 0) {
-@@ -5609,7 +5659,6 @@
+@@ -5609,7 +5678,6 @@
$fullname = &query ('Full name of pseudonym (not just '
. 'E-mail address)', $fullname);
$fullname =~ s/[\'\^\n]//g; # kludge for secrets file
@@ -499,7 +532,7 @@
$signsend = &query ('Sign mail with (R)emailer key, '
. '(P)seudonym key or (N)o key?',
$signsend);
-@@ -5652,7 +5701,7 @@
+@@ -5652,7 +5720,7 @@
}
# print "Here's the encrypted block:\n";
# system "cat $replyblock_fn";
@@ -508,7 +541,7 @@
if (&member ('newnym', @options)) {
$secret = "\$nym\{\'$time\,$remailer\=$nym\'\} \= ".
"\'chain=$chain\^to=$to^"
-@@ -5771,6 +5820,7 @@
+@@ -5771,6 +5839,7 @@
if (!open (IN, $body)) {
&error ("Internal error opening replyblock\n");
}
@@ -516,7 +549,7 @@
@in_headers = ("To: $to\n");
push (@in_headers, "Chain: $chain\n") if $chain;
$header_sep = "\n";
-@@ -5784,6 +5834,7 @@
+@@ -5784,6 +5853,7 @@
}
&send_group ($groups[0]);
close (IN);
@@ -524,7 +557,7 @@
}
sub find_nym {
-@@ -5997,7 +6048,7 @@
+@@ -5997,7 +6067,7 @@
# The main loop
$quit = 0;
@@ -533,7 +566,7 @@
while (!$quit) {
$rin = $win = $ein = '';
vec ($rin, fileno(STDIN), 1) = 1 unless $ineof;
-@@ -6315,7 +6366,7 @@
+@@ -6315,7 +6385,7 @@
# Open a Web connection for the file as file handle WWW.
my ($url) = @_;
my ($host, $port, $suf);
@@ -542,7 +575,7 @@
my ($name, $proto);
my ($that);
my ($savesel, $gotsep);
-@@ -6330,7 +6381,7 @@
+@@ -6330,7 +6400,7 @@
$host = $1;
$port = $2;
$suf = $3;
@@ -551,7 +584,7 @@
else { $port = 80; }
($fqdn, $aliases, $type, $len, $thataddr) = gethostbyname ($host);
return &pdv ("Host not found: $host\n") if ($thataddr eq '');
-@@ -6345,7 +6396,7 @@
+@@ -6345,7 +6415,7 @@
unpack ('C4', $thataddr), $port));
eval {
$SIG{'ALRM'} = sub { die "Timeout error on $url\n" };
@@ -560,7 +593,7 @@
# bind(WWW, $this) || &die_disarm ("bind: $!\n");
# &pdv ("bound the socket...\n");
connect(WWW, $that) || &die_disarm ("connect: $!\n");
-@@ -6368,6 +6419,21 @@
+@@ -6368,6 +6438,21 @@
};
if ($@) { return &pdv ($@); }
return &pdv ("No response from server\n") unless $gotsep;