aboutsummaryrefslogtreecommitdiff
path: root/mail/pymsgauth
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-06-05 21:35:21 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-06-05 21:35:21 +0000
commitd2444b3ae60e8337f624268d5c32b7dcf6220594 (patch)
treec39fc5dc19983d2b43c06c95c8b65f304e7102a4 /mail/pymsgauth
parent7f288c0d6a0ec759b049337a9ef7d5f18c0503c9 (diff)
downloadports-d2444b3ae60e8337f624268d5c32b7dcf6220594.tar.gz
ports-d2444b3ae60e8337f624268d5c32b7dcf6220594.zip
- Add staging support
- Convert to USES=shebangfix, bump PORTREVISION - shebangs changed - Convert to new options framework - Remove Author from pkg-descr
Notes
Notes: svn path=/head/; revision=356712
Diffstat (limited to 'mail/pymsgauth')
-rw-r--r--mail/pymsgauth/Makefile30
-rw-r--r--mail/pymsgauth/pkg-descr1
2 files changed, 15 insertions, 16 deletions
diff --git a/mail/pymsgauth/Makefile b/mail/pymsgauth/Makefile
index 1cd1b0862154..7109f1205ad9 100644
--- a/mail/pymsgauth/Makefile
+++ b/mail/pymsgauth/Makefile
@@ -3,35 +3,35 @@
PORTNAME= pymsgauth
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= mail python
MASTER_SITES= http://pyropus.ca/software/pymsgauth/
MAINTAINER= ports@FreeBSD.org
COMMENT= Automatically process qsecretary confirmation requests
+USES= shebangfix
+SHEBANG_FILES= pymsgauth-clean pymsgauth-confirm pymsgauth-mail
USE_PYTHON= yes
+NO_BUILD= yes
SUB_FILES= pkg-message
DOCS= BUGS CHANGELOG pymsgauth.txt pymsgauth.html
EXAMPLES= pymsgauthrc-example
-NO_STAGE= yes
-do-build:
- ${REINPLACE_CMD} -e 's,#!/usr/bin/python,#!/usr/bin/env python,' \
- ${WRKSRC}/pymsgauth-*
- ${RM} ${WRKSRC}/pymsgauth-*.bak
+OPTIONS_DEFINE= DOCS
do-install:
- @${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${WRKSRC}/pymsgauth-* ${DATADIR}
- ${LN} -sf ${DATADIR}/pymsgauth-* ${PREFIX}/bin
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${WRKSRC}/pymsgauth-* \
+ ${STAGEDIR}${DATADIR}
+.for f in clean confirm mail
+ ${LN} -sf ${DATADIR}/pymsgauth-${f} ${STAGEDIR}${PREFIX}/bin
+.endfor
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/mail/pymsgauth/pkg-descr b/mail/pymsgauth/pkg-descr
index a8c77b33ff83..17d1fc61d350 100644
--- a/mail/pymsgauth/pkg-descr
+++ b/mail/pymsgauth/pkg-descr
@@ -2,5 +2,4 @@ pymsgauth is a toolkit for automatically and securely dealing with qsecretary
confirmation notices (used on mailing lists run by D.J. Bernstein).
It is written in Python, and licensed under GPL.
-Author: Charles Cazabon
WWW: http://pyropus.ca/software/pymsgauth/